FreeBSD freeze during boot when running in Qemu KVM on AMD and Intel

Bug #746114 reported by Gijs Peskens on 2011-03-30
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running latest kernel on 11.04 and just installed the kvm tools.

After creating a virtual machine using the gui and starting it the vm freezes almost instantly, the bootloader timer of freebsd either freezes directly or ticks down no further than 7.

This seems to be the same bug as reported on this post in a mailing list:
http://www.spinics.net/lists/kvm/msg51211.html

where also a fix is suggested:
http://www.spinics.net/lists/kvm/msg51226.html
with more details in:

http://www.spinics.net/lists/kvm/msg51244.html

With KVM disabled FreeBSD does boot, but my machine should be capable of running KVM and FreeBSD should be able to run as DomU

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: linux-image (not installed)
Regression: Yes
Reproducible: Yes
ProcVersionSignature: Ubuntu 2.6.38-7.39-generic 2.6.38
Uname: Linux 2.6.38-7-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: gijs 1499 F.... pulseaudio
 /dev/snd/pcmC0D0p: gijs 1499 F...m pulseaudio
CRDA: Error: [Errno 2] Bestand of map bestaat niet
Card0.Amixer.info:
 Card hw:0 'SB'/'HDA ATI SB at 0xfe5f4000 irq 16'
   Mixer name : 'Realtek ALC892'
   Components : 'HDA:10ec0892,104383c0,00100302'
   Controls : 32
   Simple ctrls : 18
Card1.Amixer.info:
 Card hw:1 'Generic'/'HD-Audio Generic at 0xfe6bc000 irq 46'
   Mixer name : 'ATI R6xx HDMI'
   Components : 'HDA:1002aa01,00aa0100,00100200'
   Controls : 4
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'IEC958',0
   Capabilities: pswitch pswitch-joined penum
   Playback channels: Mono
   Mono: Playback [on]
Date: Thu Mar 31 01:06:04 2011
HibernationDevice: RESUME=UUID=22d07050-e2e4-4184-b5fd-85da6e412e72
MachineType: System manufacturer System Product Name
ProcEnviron:
 LANGUAGE=nl_NL:en_US:en
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=eabe60eb-9799-4974-9405-080beaf2690d ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-2.6.38-7-generic N/A
 linux-backports-modules-2.6.38-7-generic N/A
 linux-firmware 1.49
RfKill:

SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/23/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1801
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M4A89GTD-PRO
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1801:bd12/23/2010:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM4A89GTD-PRO:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer

Gijs Peskens (gijspeskens) wrote :
Gijs Peskens (gijspeskens) wrote :

oooooooooooh reallt _not_ happy about automagic addition of some files, I see my IP in WifiSyslog

description: updated
Brad Figg (brad-figg) on 2011-04-07
Changed in linux (Ubuntu):
status: New → Confirmed
Roger (gobba) wrote :

As a workaround, really annoying one thou, you can start the freebsd guest and connect to the console with vnc. Start hammering the enter key before the countdown screen, so you can get an enter keypress in instantly as that screen shows up. Then the guest will continue booting.

There are patches in the kvm git kernel that fixes this as described in the link from original post.

Plecebo (larry-schwerzler) wrote :

This bug and 780657 are likely due to the same issue.

In that report you can disable to FreeBSD boot menu (or alternatively replace the bios in KVM) as a work around also.

As reported by: Bjoern Connolly (pobox) https://launchpad.net/~pobox
beastie_disable="YES" in /boot/loader.conf solves the problem of booting FreeBSD.

Hey Guys,

I ran into the same bug as Gijs Peskens did. My FreeBSD virtual maschines are freezing at the boot menu if the beastie logo is enabled and if I use a qemu version from saucy (1.5.0+dfsg-3ubuntu5.3) or trusty (1.7.0+dfsg-3ubuntu5). Version 1.2.0+noroms-0ubuntu2.12.10.6 and 1.0+noroms-0ubuntu14.13 from quantal/precise are working fine.

I've no control of the virtual maschines, only the host system so I can't modify the /boot/loader.conf. Any thoughts on how I can fix this issue on the server side?

Let my know if you need any logs or more information-

Forgot to mention:

I've tested this on two different CPUs:
model name : Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2620 0 @ 2.00GHz

so this isn't only AMD related.

summary: - FreeBSD freeze when running in Qemu KVM on AMD
+ FreeBSD freeze during boot when running in Qemu KVM on AMD and Intel

Hi,

could anybody offer me some ideas for debugging. Or has anybody some thoughts about this issue?

Tested this with vanilla Qemu 1.7.1 and 1.5. I have no issues with these vanilla versions. the bug seems to be ubuntu related

This happens also with vanilla kernel, so its more an qemu-kvm bug then kernel related

affects: linux (Ubuntu) → qemu-kvm (Ubuntu)
Serge Hallyn (serge-hallyn) wrote :

Please give us a url for an iso we can use to install, and the install options you are using. I'll see if I can reproduce with 14.04's qemu and with upstream git HEAD.

Hi Serge,

You should be able to reproduce this with any iso from http://ftp.freebsd.org/pub/FreeBSD/releases/amd64/amd64/ISO-IMAGES/10.0/

Let me know if you need more information.

Serge Hallyn (serge-hallyn) wrote :

I still was not able to reproduce this, using virt-manager on trusty and using mostly the defaults.

Serge Hallyn (serge-hallyn) wrote :

In comment #9 you said "with vanilla kernel" - can you please list the exact kernel versions you've tried (and which qemu versions you tried with them, including whether they were hand-built from git or packages from Ubuntu)

I tried 3.2.0-27-generic and 3.11.0-18-generic from the precise repos. Also a vanilla 3.10.18 and 3.10.28 based on the 3.2.0-27-generic config file. I tried these ubuntu packages for qemu: saucy (1.5.0+dfsg-3ubuntu5.3) and trusty (1.7.0+dfsg-3ubuntu5). Also the plain qemu from http://wiki.qemu-project.org/download/qemu-1.5.3.tar.bz2

I debugged this issue further. I got the freebsd Images from a friend. They are modified with MSFBSD(http://mfsbsd.vx.sk/). Plain FreeBSD is also working fine (sorry for the wrong information in the above messages). I notifed the responsible developer Martin Matuška and waiting for his reply.

Serge Hallyn (serge-hallyn) wrote :

If this is still an issue, please try to reproduce it with the lastest upstream daily build from https://launchpad.net/~ubuntu-virt/+archive/ubuntu/virt-daily-upstream

Changed in qemu-kvm (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for qemu-kvm (Ubuntu) because there has been no activity for 60 days.]

Changed in qemu-kvm (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers