llseek bug in amd64 host

Bug #721801 reported by Gustavo Niemeyer on 2011-02-19
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro QEMU
Fix Released
Medium
Unassigned
qemu-kvm (Ubuntu)
Medium
Serge Hallyn
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
qemu-linaro (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned

Bug Description

======================================================
SRU justification:
1. Impact: llseek fails on amd64 host emulating arm
2. How addressed: a patch from upstream to address this bug is cherrypicked.
3. Patch: see the patch in comment #1
4. To reproduce: call llseek on arm emulated guest on amd64 host
5. Regression potential: this only touches llseek64 emulation on x86-64 host.
======================================================

Binary package hint: qemu-kvm

It's been reported in the Go mailing list that llseek is failing on an amd64 host when emulating arm.

The attached patch was recommended as a possible fix for the problem.

The full conversation may be found in the following thread:

http://groups.google.com/group/golang-dev/t/ab503dc63abe5dfd

description: updated
description: updated
tags: added: patch
summary: - lseek bug in amd64 host
+ llseek bug in amd64 host
Gustavo Niemeyer (niemeyer) wrote :

There are packages available for testing in my PPA:

sudo add-apt-repository ppa:niemeyer/ppa
sudo apt-get upgrade

Peter Maydell (pmaydell) wrote :

Suggested patch sent upstream: http://patchwork.ozlabs.org/patch/83964/

I'll put this in qemu-linaro 2011.03 one way or another.

Changed in qemu-linaro:
status: New → In Progress
importance: Undecided → Medium
milestone: none → 2011.03
Gustavo Niemeyer (niemeyer) wrote :

That's awesome, thanks Peter.

Serge Hallyn (serge-hallyn) wrote :

Thanks for the patch, Gustavo.

qemu-kvm no longer ships an arm emulator in natty. So if I understand the SRU process right, I'll need to wait until this is fixed in qemu-linaro, then request an SRU to qemu-kvm for lucid and maverick?

In the mean time I'll link source branches for both of those to this bug so we're ready.

Serge Hallyn (serge-hallyn) wrote :

.debs for lucid and maverick have been built (not yet tested). I will upload them when I've got a wider pipe.

Changed in qemu-kvm (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Serge Hallyn (serge-hallyn)
Serge Hallyn (serge-hallyn) wrote :
Serge Hallyn (serge-hallyn) wrote :

@Gustavo,

do the packages in comment #7 fix the problem for you?

Martin Capitanio (capnm) wrote :

I can confirm that Gustavo's Maverick amd64 ppa packages
https://launchpad.net/~niemeyer/+archive/ppa/+packages

fixed the go os test issue that I filled here
http://code.google.com/p/go/issues/detail?id=1508#c1

=== RUN os_test.TestSeek
--- PASS: os_test.TestSeek (0.0 seconds)

Thanks for pushing this upstream,
Martin

Peter Maydell (pmaydell) on 2011-02-24
Changed in qemu-linaro:
status: In Progress → Fix Committed
Peter Maydell (pmaydell) on 2011-03-08
Changed in qemu-linaro:
status: Fix Committed → Fix Released
Serge Hallyn (serge-hallyn) wrote :

I believe comment #9 can be seen as verifying the fix, as Gustavo's tree just added the exact same patch as mine. Can we therefore mark this bug as 'verification-done'?

description: updated
tags: added: verification-needed
Changed in qemu-kvm (Ubuntu):
status: Confirmed → Fix Released
Changed in qemu-linaro (Ubuntu):
status: New → Invalid
Steve Langasek (vorlon) on 2011-03-14
Changed in qemu-linaro (Ubuntu Lucid):
status: New → Invalid
Changed in qemu-linaro (Ubuntu):
status: Invalid → Fix Released
Changed in qemu-linaro (Ubuntu Maverick):
status: New → Invalid
Rolf Leggewie (r0lf) wrote :

Maverick has long since stopped to receive any updates. Marking the Maverick task for this ticket as "Won't Fix".

Changed in qemu-kvm (Ubuntu Maverick):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in qemu-kvm (Ubuntu Lucid):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.