kill -9 kvm crashes ssh daemon

Bug #671021 reported by Jeff Kowalczyk on 2010-11-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: qemu-kvm

On Ubuntu 10.10 amd64, I have a Window 2003 guest that is using non-acpi HAL. When shutdown, it needs to have the kvm process kill -9'd. This interrupts the ssh daemon on the server. I need to restart the ssh service to connect to the server again.

Clint Byrum (clint-fewbar) wrote :

Hi Jeff, thank you for taking the time to file this bug report and help us make Ubuntu better.

I just tried to reproduce this, albeit running a Linux vm since I don't have win2k3. kill -9 on the kvm process just resulted in kvm's death, but my ssh session worked fine.

I used these steps:

qemu-img create -f hardy.img 20G
kvm --name hardy -m 384 -hda hardy.img -cdrom isos/hardy-mini.iso -nographic
kill -9 pidof kvm

Nothing crashes.

Can you look in /var/log/auth.log and see if sshd prints any messages before dying?

Marking Incomplete pending response from Jeff.

Changed in qemu-kvm (Ubuntu):
status: New → Incomplete
Jeff Kowalczyk (jfkw) wrote :

I have an additional data point: the ssh daemon does not actually crash, it just stops responding for a few minutes. The connection was left intact during today's experiment, but no input was processed. It looks like a frozen connection, but it did come back into an active state eventually.

Here is the auth.log tail. I usually have resolved the problem by going to webmin and restarting the ssh daemon, but today I was slower to initiate that webmin login, when I noticed the SSH connection was actively accepting input again:

Nov 6 18:08:02 server1 sudo: myuser : TTY=pts/0 ; PWD=/home/myuser ; USER=root ; COMMAND=/usr/bin/aptitude upgrade
Nov 6 18:10:02 server1 sshd[20626]: Received disconnect from XXX.XXX.XXX.XXX: 11: disconnected by user
Nov 6 18:10:02 server1 sshd[20610]: pam_unix(sshd:session): session closed for user myuser
Nov 6 18:10:18 server1 sudo: myuser : TTY=pts/0 ; PWD=/home/myuser ; USER=root ; COMMAND=/bin/ps ax
Nov 6 18:10:26 server1 sudo: myuser : TTY=pts/0 ; PWD=/home/myuser ; USER=root ; COMMAND=/bin/kill -9 1354
Nov 6 18:15:08 server1 perl[21100]: pam_unix(webmin:session): session opened for user myuser by (uid=0)
Nov 6 18:15:08 server1 sudo: myuser : TTY=pts/1 ; PWD=/usr/share/webmin ; USER=root ; COMMAND=list
Nov 6 18:15:08 server1 webmin[21100]: Successful login as myuser from XXX.XXX.XXX.XXX
Nov 6 18:15:42 server1 sudo: myuser : TTY=pts/0 ; PWD=/home/myuser@ ; USER=root ; COMMAND=/bin/ps ax
Nov 6 18:17:01 server1 CRON[21239]: pam_unix(cron:session): session opened for user root by (uid=0)
Nov 6 18:17:01 server1 CRON[21239]: pam_unix(cron:session): session closed for user root

This test is still with the Windows 2003 VM, BTW.

Serge Hallyn (serge-hallyn) wrote :

That sounds like a potential problem with the bridge. Can you send the results of

ls /etc/libvirt/qemu/networks
ls /etc/libvirt/qemu/networks/autostart
cat /etc/libvirt/qemu/networks/default.xml

ifconfig -a
brctl show

Launchpad Janitor (janitor) wrote :

[Expired for qemu-kvm (Ubuntu) because there has been no activity for 60 days.]

Changed in qemu-kvm (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers