hardy2lucid upgrade: qemu-common should replace qemu as well as qemu-kvm / package qemu-common (not installed) failed to install/upgrade: trying to overwrite '/usr/share/qemu/keymaps/fr', which is also in package qemu 0:0.9.1-1ubuntu1

Bug #592010 reported by Will Taff on 2010-06-10
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Medium
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: qemu-kvm

============================================
SRU Justification
1. Impact: upgrades from hardy to lucid break
2. Development fix: N/A (qemu package as of lucid is a meta-package)
3. Stable fix: mark qemu-common as replacing qemu to force /usr/share/qemu/keymaps/fr to be removed
4. Test case: install qemu-kvm in a hardy distribution, then upgrade to lucid.
5. Regression potential: none
============================================

this probably isn't a bug - I'm probably doing this to myself - my Lucid upgrade from Hardy broke my working qemu setup, running a win98 image. This is referred to in bug # 521994. To get the qemu working again, I removed (with aptitude) package qemu and package bochsbios from the lucid install, went back to the hardy archives, got those packages, and installed them. That way, I have a working qemu install. So, when updates came down the pipe per above, I tried to unselect all that I thought might break my working qemu setup, but I think I missed bochsbios; not sure. But, that's why I got the error above. The good news is, I was able to fix by # aptitude remove qemu-kvm, then
The following packages will be REMOVED: bochsbios{u} qemu-kvm seabios{u} vgabios{u}
And actually, I went back and installed package qemu with all of it's dependencies, but unfortunately, the lucid qemu install still misbehaves per bug # 521994.

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: qemu-common (not installed)
ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Wed Jun 9 18:20:19 2010
ErrorMessage: trying to overwrite '/usr/share/qemu/keymaps/fr', which is also in package qemu 0:0.9.1-1ubuntu1
SourcePackage: qemu-kvm
Title: package qemu-common (not installed) failed to install/upgrade: trying to overwrite '/usr/share/qemu/keymaps/fr', which is also in package qemu 0:0.9.1-1ubuntu1

Will Taff (wrtaff) wrote :
Mathias Gug (mathiaz) wrote :

I confirm the bug. /usr/share/qemu/keymaps/fr was part of qemu in hardy but moved to qemu-common in lucid. However qemu-common doesn't replace qemu:

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/lucid/qemu-kvm/lucid/annotate/head:/debian/control#L59

qemu-common should also replace qemu in order to properly support hardy to lucid upgrades.

Changed in qemu-kvm (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
summary: - package qemu-common (not installed) failed to install/upgrade: trying to
- overwrite '/usr/share/qemu/keymaps/fr', which is also in package qemu
+ hardy2lucid upgrade: qemu-common should replace qemu as well as qemu-kvm
+ / package qemu-common (not installed) failed to install/upgrade: trying
+ to overwrite '/usr/share/qemu/keymaps/fr', which is also in package qemu
0:0.9.1-1ubuntu1
tags: added: package-conflict
Serge Hallyn (serge-hallyn) wrote :

I'm curious why this was not ever done. Was there a glitch when it was attempted?

I'm not sure I follow your question - what was not ever done?

-will

On Tue, 2011-10-04 at 18:43 +0000, Serge Hallyn wrote:
> I'm curious why this was not ever done. Was there a glitch when it
> was
> attempted?
>
> --
> You received this bug notification because you are subscribed to the
> bug
> report.
> https://bugs.launchpad.net/bugs/592010
>
> Title:
> hardy2lucid upgrade: qemu-common should replace qemu as well as
> qemu-
> kvm / package qemu-common (not installed) failed to install/upgrade:
> trying to overwrite '/usr/share/qemu/keymaps/fr', which is also in
> package qemu 0:0.9.1-1ubuntu1
>
> Status in “qemu-kvm” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: qemu-kvm
>
> this probably isn't a bug - I'm probably doing this to myself - my
> Lucid upgrade from Hardy broke my working qemu setup, running a win98
> image. This is referred to in bug # 521994. To get the qemu working
> again, I removed (with aptitude) package qemu and package bochsbios
> from the lucid install, went back to the hardy archives, got those
> packages, and installed them. That way, I have a working qemu
> install. So, when updates came down the pipe per above, I tried to
> unselect all that I thought might break my working qemu setup, but I
> think I missed bochsbios; not sure. But, that's why I got the error
> above. The good news is, I was able to fix by # aptitude remove
> qemu-kvm, then
> The following packages will be REMOVED: bochsbios{u} qemu-kvm
> seabios{u} vgabios{u}
> And actually, I went back and installed package qemu with all of
> it's dependencies, but unfortunately, the lucid qemu install still
> misbehaves per bug # 521994.
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.04
> Package: qemu-common (not installed)
> ProcVersionSignature: Ubuntu 2.6.32-22.36-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-22-generic i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> Date: Wed Jun 9 18:20:19 2010
> ErrorMessage: trying to overwrite '/usr/share/qemu/keymaps/fr',
> which is also in package qemu 0:0.9.1-1ubuntu1
> SourcePackage: qemu-kvm
> Title: package qemu-common (not installed) failed to
> install/upgrade: trying to overwrite '/usr/share/qemu/keymaps/fr',
> which is also in package qemu 0:0.9.1-1ubuntu1
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/qemu-kvm/+bug/592010/+subscriptions

Serge Hallyn (serge-hallyn) wrote :

@Will,

marking qemu-common as replacing qemu.

Changed in qemu-kvm (Ubuntu):
status: Triaged → Fix Released
description: updated
Changed in qemu-kvm (Ubuntu):
status: Fix Released → Invalid
Changed in qemu-kvm (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → Medium
Clint Byrum (clint-fewbar) wrote :

Raising to High as a bug that blocks users' migration to a supported release from one that will relatively soon (little over 1 year) be unsupported is a High priority.

Changed in qemu-kvm (Ubuntu Lucid):
importance: Medium → High
Serge Hallyn (serge-hallyn) wrote :

Clint,

can you explain why the submission to lucid-proposed was rejected?

Martin Pitt (pitti) wrote :

I pinged on IRC. There were two (totally different) qemu-kvm uploads in lucid-proposed with the same version number. Please merge and reupload. Thanks!

You can get them from https://launchpad.net/ubuntu/lucid/+queue?queue_state=4&queue_text=qemu-kvm if needed.

Serge Hallyn (serge-hallyn) wrote :

Ah, I see - thanks, Martin.

Hello Will, or anyone else affected,

Accepted qemu-kvm into lucid-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in qemu-kvm (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Jeff Snider (jeff-launchpad) wrote :

I'm starting on testing this. Results in a little while.

Jeff Snider (jeff-launchpad) wrote :

Ok so I spent a while at this and it does not appear to be fixed to me. I'm not really familiar with release upgrades so it might just be my unfamiliarity, if so someone with more understanding of what is going on will need to verify this instead. Here's what I did.

I installed hardy server amd64, upgraded it, installed qemu and kvm and made a snapshot of it. From there I tried several different things, rolling back each time.

1) do-release-upgrade. Worked fine, resulting system had qemu and kvm related packages installed normally. I did see the error below in the log. This is the recommended way to do a release upgrade as far as I understand it, so probably why this was not caught before now is that it is just a warning in the log but the resulting system is fine.

 Unpacking qemu-common (from .../qemu-common_0.12.3+noroms-0ubuntu9.17_all.deb) ...
 dpkg: warning: overriding problem because --force enabled:
  trying to overwrite '/etc/qemu-ifup', which is also in package qemu 0:0.12.3+noroms-0ubuntu9.17

2) add lucid-proposed to apt sources, pinned proposed/* at 400, proposed/qemu,qemu-common,qemu-kvm,kvm at 600, do-release-upgrade. Same result, similar error in the log:

 Unpacking qemu-common (from .../qemu-common_0.12.3+noroms-0ubuntu9.18_all.deb) ...
 dpkg: warning: overriding problem because --force enabled:
  trying to overwrite '/etc/qemu-ifup', which is also in package qemu 0:0.12.3+noroms-0ubuntu9.18

3) replaced apt sources with lucid, lucid-updates, update, dist-upgrade. Fails with:

 ...
 ...
 Unpacking qemu-common (from .../qemu-common_0.12.3+noroms-0ubuntu9.17_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/qemu-common_0.12.3+noroms-0ubuntu9.17_all.deb (--unpack):
  trying to overwrite '/etc/qemu-ifup', which is also in package qemu 0:0.12.3+noroms-0ubuntu9.17
 ...
 ...
 Errors were encountered while processing:
  /var/cache/apt/archives/qemu-common_0.12.3+noroms-0ubuntu9.17_all.deb
 E: Sub-process /usr/bin/dpkg returned an error code (1)

4) replaced apt sources with lucid, lucid-updates, lucid-proposed, pin as in #2, update, dist-upgrade. Fails with:

 ...
 ...
 Unpacking qemu-common (from .../qemu-common_0.12.3+noroms-0ubuntu9.18_all.deb) ...
 dpkg: error processing /var/cache/apt/archives/qemu-common_0.12.3+noroms-0ubuntu9.18_all.deb (--unpack):
  trying to overwrite '/etc/qemu-ifup', which is also in package qemu 0:0.12.3+noroms-0ubuntu9.18
 ...
 ...
 Errors were encountered while processing:
  /var/cache/apt/archives/qemu-common_0.12.3+noroms-0ubuntu9.18_all.deb
 E: Sub-process /usr/bin/dpkg returned an error code (1)

The changed package in proposed does not appear to make any noticible difference unless I'm doing something wrong which, again, is entirely possible. I'd appreciate some guidance here.

Jeff Snider (jeff-launchpad) wrote :

Could somebody tell me if I tested that correctly or not? I'd like to get this either working or rolled back soon. Thanks.

Serge Hallyn (serge-hallyn) wrote :

My observations:

1. the test case is insufficient (as Jeff points out) because the do-release-upgrade doesn't use -proposed

2. although there is an error in the logs, it does not cause upgrades to fail as originally indicated in the description.

3. the fix doesn't break anything.

So my two suggestions (on order of preference) are to

1. accept the fix on the basis that it doesn't break the package
2. reject the fix, pull it out of lucid-proposed, so that the other bugfix (which has been verified) can be accepted. Then mark this bug wishlist and leave it be.

Serge Hallyn (serge-hallyn) wrote :

@Clint,

I meant to say, the ball is in your court :)

Clint Byrum (clint-fewbar) wrote :

Thanks Serge for the excellent write up o fthe situation. I'll push this forward, as the verification did not fail and there have been no reported regressions.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 0.12.3+noroms-0ubuntu9.18

---------------
qemu-kvm (0.12.3+noroms-0ubuntu9.18) lucid-proposed; urgency=low

  [ Michael Tokarev ]
  * QEMUFileBuffered:-indicate-that-were-ready-when-the-underlying-file-is-ready.diff
   (patch from upstream to speed up migration dramatically)
   (closes: #597517) (LP: #524447)

  [ Serge Hallyn ]
  * debian/control: make qemu-common replace qemu (<< 0.12.3+noroms-0ubuntu9.17)
    (LP: #592010)
 -- Serge Hallyn <email address hidden> Mon, 13 Feb 2012 11:24:18 -0600

Changed in qemu-kvm (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers