kvm with -vga std is broken since karmic

Bug #513273 reported by Daniele Cruciani on 2010-01-27
94
This bug affects 17 people
Affects Status Importance Assigned to Milestone
QEMU
Undecided
Anthony Liguori
qemu-kvm (Ubuntu)
Low
Unassigned
Lucid
Low
Unassigned
seabios (Ubuntu)
High
Unassigned
Lucid
High
Unassigned
vgabios (Ubuntu)
High
morleyfl
Lucid
High
morleyfl

Bug Description

Binary package hint: qemu-kvm

it works with -vga cirrus, with -vga std I got:

BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters

And driver do not work properly (I can not set screen resolution) ...
virtual machine almost works, only screen problem in winxp guest

ProblemType: Bug
Architecture: amd64
Date: Wed Jan 27 15:15:49 2010
DistroRelease: Ubuntu 10.04
KvmCmdLine: Error: command ['ps', '-C', 'kvm', '-F'] failed with exit code 1: UID PID PPID C SZ RSS PSR STIME TTY TIME CMD
MachineType: Acer Aspire 9300
NonfreeKernelModules: nvidia
Package: qemu-kvm 0.12.2-0ubuntu1
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-11-generic root=UUID=793246ac-c5ff-421b-a508-052d57cca90c ro rootfstype=ext4 quiet splash
ProcEnviron:
 LANGUAGE=it_IT.UTF-8
 PATH=(custom, user)
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-11.15-generic
SourcePackage: qemu-kvm
Uname: Linux 2.6.32-11-generic x86_64
dmi.bios.date: 12/13/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.14
dmi.board.name: Myallm
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.asset.tag: None
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.14:bd12/13/2006:svnAcer:pnAspire9300:pvr0100:rvnAcer:rnMyallm:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: Aspire 9300
dmi.product.version: 0100
dmi.sys.vendor: Acer

Changed in qemu-kvm (Ubuntu):
status: New → Confirmed
importance: Undecided → Low

With -std vga we can only get 800x600 16 colors, which is a fallback, while -vga cirrus works well. KVM 0.11.0 from karmic works well, since this bug only affects 0.12 and above.

Quite annoying, since one can only obtain resolutions like 1280x768 from -vga std.

I propose to move up the bug importance to Medium.

Torsten Spindler (tspindler) wrote :

On Lucid Alpha3 I don't get console error messages, but a

error: unknown command 'terminal'.
unaligned pointer 0x8ecc0002
Aborted. Press any key to exit.

Dustin Kirkland  (kirkland) wrote :

Marking high, assigning myself, and targeting at beta1.

I'll try to work on this tomorrow with Anthony.

I suspect it might be a problem with our vga bios roms, possibly. Worth looking at.

Changed in qemu-kvm (Ubuntu):
importance: Low → High
assignee: nobody → Dustin Kirkland (kirkland)
milestone: none → ubuntu-10.04-beta-1
Changed in qemu:
assignee: nobody → Anthony Liguori (anthony-codemonkey)
Dustin Kirkland  (kirkland) wrote :

Hi Anthony-

Can you test this on upstream qemu 0.12.3 and let us know if you can get -vga std to work there? Also, please confirm which vga bios you're using there, as there may be a mismatch with what we've got in Ubuntu at the moment.

with qemu 0.12.3 error messages are not shown, but still got 800x600x4color

Michael Jeanson (mjeanson) wrote :

Using" -vga std" with the default bios files, it won't boot and I get :

unaligned pointer 0x8ecc0002
Aborted. Press any key to exit.

I built the bios files from the qemu-kvm package source and using those with the "-L" switch it works.

Dustin Kirkland  (kirkland) wrote :

Triaging, *definitely* a problem with our vgabios.bin, which is provided by the vgabios package.

Can anyone spot what's wrong there?

Changed in qemu:
status: New → Invalid
Changed in qemu-kvm (Ubuntu):
status: Confirmed → Triaged
Changed in vgabios (Ubuntu):
status: New → Triaged
milestone: none → ubuntu-10.04-beta-1
importance: Undecided → High
Dustin Kirkland  (kirkland) wrote :

Okay, there's two parts to this bug ...

First, the vgabios that we're using in Lucid right now (0.6c-2) is newer than what upstream qemu-kvm ships and is known to work well with (0.6b).

Upstream recommends that we either use the vgabios source in the qemu-kvm package, or downgrade the vgabios in Lucid.

I'll need to get approval to do that.

summary: - kvm with -vga std give error and do not works
+ kvm with -vga std is broken since karmic
Thierry Carrez (ttx) on 2010-03-04
Changed in vgabios (Ubuntu Lucid):
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Adding a task against seabios. Per discussion with mjt in IRC, the problem appears to him to be in bios.bin in the seabios package.

Changed in qemu-kvm (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → none
Changed in vgabios (Ubuntu Lucid):
milestone: ubuntu-10.04-beta-1 → none
Changed in seabios (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

So one very viable approach would be to use the vgabios.bin and bios.bin that's built/shipped with the qemu-kvm source package.

These are the versions of those bios files "blessed" by upstream and known to work. It's what upstream would prefer that we used, as these are tested with the qemu-kvm 0.12.3 release. As of the 0.12.3 release tarball, it contains all of the source files necessary to rebuild the bios bins. When I packaged and added seabios to Ubuntu, this was not the case (qemu-kvm 0.12.0).

I think I'll do this in the short term, barring any objections.

For Lucid + 1, I'm working with mjt and lool and hoping to get in sync with Debian, and use a common set of packaging between Debian and Ubuntu, which would ideally use the separate vgabios and seabios packages.

Dustin Kirkland  (kirkland) wrote :

I uploaded qemu-kvm_0.12.3-0ubuntu5~ppa1_source.changes to my PPA at:
 * https://edge.launchpad.net/~kirkland/+archive/ppa/+packages

If anyone affected by this bug could try that package and post their results, that would be very helpful.

Thanks,
:-Dustin

C de-Avillez (hggdh2) wrote :

Will test it, as soon as the package is built.

C de-Avillez (hggdh2) wrote :

OK. Just installed it. Please be aware that there is a conflict with current vgabios seabios, which have to be uninstalled (which cause qemu to be uninstalled also). But a bit of a dance around apt-get and dpkg gets it done.

Will test tomorrow, gotta go now.

The bios files are missing from the package, instead there is still a
link pointing nowhere:

lrwxrwxrwx 1 root root 22 2010-03-05 08:26 vgabios.bin
-> ../vgabios/vgabios.bin
lrwxrwxrwx 1 root root 29 2010-03-05 08:26 vgabios-cirrus.bin
-> ../vgabios/vgabios.cirrus.bin

When the two links are removed from debian/links the new BIOS are placed
in /usr/share/qemu. Attached is a debdiff for the change.

tags: added: patch
Dustin Kirkland  (kirkland) wrote :

Doh! Thanks for the patch, Torsten. That's perfect.

Pushed another build to my PPA.

Torsten Spindler (tspindler) wrote :

I just tried 0.12.3-0ubuntu5~ppa2 and I don't get any errors when launching
$ kvm -vga std -hda ./lucid.qcow2

C de-Avillez (hggdh2) wrote :

works on a testdrive call:

 kvm -vga std -m 512 -cdrom /srv/vBox/iso/lucid-server-amd64.iso -drive file=/srv/vBox/img/testdrive-disk-BoYURX.img,if=virtio,index=0,boot=on -usb -usbdevice tablet -net nic,model=virtio -net user -soundhw es1370

Michael Jeanson (mjeanson) wrote :

Tested 0.12.3-0ubuntu5~ppa3 with libvirt using :

    <video>
      <model type='vga' vram='9216' heads='1'/>
    </video>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 0.12.3-0ubuntu5

---------------
qemu-kvm (0.12.3-0ubuntu5) lucid; urgency=low

  * debian/install, debian/control: use the bios bin's shipped with
    qemu-kvm, rather than those provided by vgabios and seabios (for now);
    we're seeing issues building and using the versions of vgabios and
    seabios in the archive; the ones shipped with qemu-kvm are those
    "recommended" and known to work by upstream; when we converge on a
    new package with debian for lucid+1, we should revisit this.
    LP: #513273
 -- Dustin Kirkland <email address hidden> Thu, 04 Mar 2010 16:53:17 -0600

Changed in qemu-kvm (Ubuntu Lucid):
status: Triaged → Fix Released
Changed in seabios (Ubuntu Lucid):
assignee: Dustin Kirkland (kirkland) → nobody
Changed in vgabios (Ubuntu Lucid):
assignee: Dustin Kirkland (kirkland) → nobody
Changed in qemu-kvm (Ubuntu Lucid):
importance: High → Low

Unfortunately, today vgabios and seabios have been reintroduced, and the problem reappeared.

Dustin Kirkland  (kirkland) wrote :

Yes, it has. Sorry about that.

Upstream QEMU recommends that we use the bundled vgabios.bin and bios.bin in their tarball.

However, these binary blobs are generated by GPLv2 code that is not part of the release tarball.

Per Ubuntu policy, we are not allowed to ship binary blobs without the associated source code.

For this reason, we're back to depending on the vgabios and seabios provided by those two packages.

If someone could help track down *what* particular difference in the Ubuntu packaged versions of vgabios and seabios is causing this error, I'm happy to review and upload a fix to one or both of those packages.

Thanks,
:-Dustin

Changed in qemu-kvm (Ubuntu Lucid):
status: Fix Released → Triaged

for what I recall bios in qemu package is just an older version, a downgrade should work or a versioned vgabios package ...

Dustin Kirkland  (kirkland) wrote :

Daniele-

If you can verify that you can build and install a particular vgabios
version that works, please let me know what version that is. I'll
take a look at the diff between the two versions, and look into a
uploading a downgrade version into Lucid.

I actually do not upgrade to new package, I see Francisco comment ...
doing `less /usr/share/qemu/vgabios.bin` I see:
current-cvs 23 Dec 2008
I hope there are no commit in that day ..

Changed in qemu-kvm (Ubuntu Lucid):
assignee: Dustin Kirkland (kirkland) → nobody

Let me tell you what I have done:

  I have updraded qemu to the noroms version. The problem was reintroduced.

  Then, in the directory where I hold my images (.local/share/kvm):

  > mkdir bios
  > cd bios
  > ln -s /usr/share/qemu/* .
  > rm vgabios.bin bios.bin

  > copied vgabios.bin and bios.bin from the qemu source
  > finally, called qemu -L $KVM_IMAGES_DIR/bios/ ...

  bios.bin and vgabios.bin are read from the qemu source directory version, and works.

  Now, there are two different problems, independent. If I load bios.bin from seabios, I get the kvm error messages; if from qemu source, I do not see those messages. On the other hand, the reduction of resolution depends solely of the vgabios.bin one uses. I have tried several bios.bin/vgabios.bin to establish the independence of the effects.

  I had before one way to access the non-standard vga modes, like 1280x768, but now, even with vgabios.bin from the source distribution, I can only access 1024x768. Does anyone know why?

Jamie Strandboge (jdstrand) wrote :

Dustin,

You said: "Upstream QEMU recommends that we use the bundled vgabios.bin and bios.bin in their tarball.

However, these binary blobs are generated by GPLv2 code that is not part of the release tarball.

Per Ubuntu policy, we are not allowed to ship binary blobs without the associated source code."

Obviously, we must comply with our own policy, but removing these blobs cripples our qemu packages to supporting only a very small subset of architectures for the qemu binaries we ship, not to mention not fixing this bug. Would it not be possible to create two new source packages using the same versions of bios sources and compilation options that upstream uses? Eg, we obtain the upstream sources that the qemu team has blessed and put appropriately licensed sources in qemu-kvm-roms for main and the rest in qemu-kvm-roms-extras in multiverse. Then talk to upstream qemu on how they generated their blessed versions and do the same. This would fix this bug, bring us into compliance with our own policy and restore full functionality to qemu.

Dustin Kirkland  (kirkland) wrote :

Jamie-

Yes, your proposal is sound.

Basically, all I think we need to do is "downgrade" the versions of
seabios and/or vgabios that we have in Ubuntu to precisely match those
that upstream QEMU generated to produce their version. We could do
that by using an epoch-hack, or by cherry picking off each of the
commits in our slightly newer version of these packages.

Honestly, I wish someone who's motivated to help fix -vga std would
step up and identify the one (or more) commits to vgabios or seabios
that causes this regression, and then we'd just revert that one commit
against the upstream code. Unfortunately, that person is probably not
me, as I only ever use the default -vga driver which is cirrus, or I
use something like Eucalyptus or virsh and run my VMs headless. In
this sense, this bug is very low priority as compared to the dozens of
others that I need to solve before Lucid releases.

Thanks,
:-Dustin

Dustin, I see a commit in cvs in 2008-12-04 and next in 2009-01-24 I say included bios is 23 Dec 2008
it is ok to downgrade to 2008-12-04 version and report to qemu developer or vgabios developer
the problem.

However qemu developer sudjest to use provided vgabios, thus the problem seems to be known ...

ok, what is missing is to test if cvs 2008-12-04 vgabios commit works with -vga std switch

Dustin Kirkland  (kirkland) wrote :

Daniele-

Can you test the vgabios I just posted in my PPA at:
 * https://edge.launchpad.net/~kirkland/+archive/ppa

This one reverts all of the changes and backs vgabios down to the
exact code that is in qemu's 0.12.3 release, but built against the
Ubuntu toolchain.

If you can confirm that this solves the issue for you, we can ask the
release team to grant an exception to accept an upload that
"downgrades" the vgabios version in the Lucid Archive.

Dustin, that version works, but I got
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
...
as reported originally, but now with working resolution and color depth in emulated os

Using vgabios.bin from qemu package cause the same messages tough

Petter Abrahamsson (petter) wrote :

I also can report success with vgabios from Dustin's PPA when using -vga std. While with vgabios from main I'll get 4 bit graphics.

Dustin Kirkland  (kirkland) wrote :

Okay, two confirmations thanks. I'll push this up now.

Dustin Kirkland  (kirkland) wrote :

Not entirely sure this will make it into Lucid, though. That will be
up to the Ubuntu Release Team.

Changed in qemu-kvm (Ubuntu Lucid):
status: Triaged → Invalid
Changed in vgabios (Ubuntu Lucid):
status: Triaged → Fix Committed
Changed in seabios (Ubuntu Lucid):
status: Triaged → Invalid
Steve Langasek (vorlon) wrote :

Dustin,

What is the risk of regression here by downgrading? Is use of vgabios entirely broken today for all users to where things can only get better, or are there some cases where it works?

vgabios has two reverse-dependencies in lucid: qemu-common and bochs. Has anyone regression-tested this for bochs?

Julien Aubin (gojulgarbmail) wrote :

Hi,

I encounter the problem when the guest OS is Windows 7, however with a Windows XP guest the bug does not occur. Anyway this is a regression from Karmic.

"-".

Dustin Kirkland  (kirkland) wrote :

On Fri, Apr 2, 2010 at 10:20 PM, Steve Langasek
<email address hidden> wrote:
> What is the risk of regression here by downgrading?  Is use of vgabios
> entirely broken today for all users to where things can only get better,
> or are there some cases where it works?

The only users positively affected by the new upload are those that
want to use kvm or qemu with the -vga std option. This VGA mode adds
higher resolutions to the SDL window than the default cirrus driver
(which only allows up to 1024x768). I can confirm that the current
vgabios is broken for -vga std, and is working with the pending
upload.

Most users of kvm/qemu either don't use SDL at all (ie, they are using
virt-manager, virsh, or Eucalyptus to launch VMs), and of the
remaining users that do launch KVM from the command line and SDL, most
of those are probably just using the default cirrus driver. Thus, I
suspect that the affect users of this problem are a vocal minority.

That said, I would love to see this fixed for them. Anyone who
launches KVM directly from the command line, and toys around with the
obscure QEMU options are a friend to me, as they're helping test the
dark corners of qemu-kvm.

I have seen no negative effects thus far of "downgrading" vgabios.
And I really, really, really like the idea of being code-identical
with the vgabios that upstream QEMU released with qemu 0.12.3, as our
support burden is shared.

That said, if we upload this, and the "majority" of qemu/kvm users
(those not using -vga std) are negatively affect, I'm perfectly fine
with reverting this change in a heartbeat, and asking someone to track
down the precise part of the diff that causes/fixes the current issue.

> vgabios has two reverse-dependencies in lucid: qemu-common and bochs.
> Has anyone regression-tested this for bochs?

I suspect that the bochs package can possibly be dropped from the
archive. I think qemu was the only user of bochs previously, and
upstream QEMU has switched away from bochs to seabios and vgabios
instead. This needs to be investigated a bit more (perhaps a post on
ubuntu-devel, in case anyone else knows of what in Lucid might still
require bochs.

:-Dustin

Soren Hansen (soren) wrote :

On Sat, Apr 03, 2010 at 07:26:50PM -0000, Dustin Kirkland wrote:
> The only users positively affected by the new upload are those that
> want to use kvm or qemu with the -vga std option. This VGA mode adds
> higher resolutions to the SDL window than the default cirrus driver
> (which only allows up to 1024x768). I can confirm that the current
> vgabios is broken for -vga std, and is working with the pending
> upload.
>
> Most users of kvm/qemu either don't use SDL at all (ie, they are using
> virt-manager, virsh, or Eucalyptus to launch VMs), and of the
> remaining users that do launch KVM from the command line and SDL, most
> of those are probably just using the default cirrus driver. Thus, I
> suspect that the affect users of this problem are a vocal minority.

The emulated video card and the output type are orthogonal. You can just
as easily be using VNC with -vga std as you can use SDL with the default
cirrus. Any of combination of output type (sdl, vnc, or none) and
emulated video card (cirrus (default), vmware and "std-vga") is
possible. Indeed, libvirt allows any of these combinations.

>> vgabios has two reverse-dependencies in lucid: qemu-common and bochs.
>> Has anyone regression-tested this for bochs?
> I suspect that the bochs package can possibly be dropped from the
> archive. I think qemu was the only user of bochs previously, and
> upstream QEMU has switched away from bochs to seabios and vgabios
> instead. This needs to be investigated a bit more (perhaps a post on
> ubuntu-devel, in case anyone else knows of what in Lucid might still
> require bochs.

I see no reason to drop bochs. It's a project in its own right.

--
Soren Hansen
Ubuntu Developer
http://www.ubuntu.com/

Steve Langasek (vorlon) wrote :

> The only users positively affected by the new upload are those that
> want to use kvm or qemu with the -vga std option.

Does this mean that if you aren't using the -vga option this change has no effect; and that if you are using the -vga option, it doesn't work today?

> I suspect that the bochs package can possibly be dropped from the
> archive. I think qemu was the only user of bochs previously, and
> upstream QEMU has switched away from bochs to seabios and vgabios
> instead. This needs to be investigated a bit more (perhaps a post on
> ubuntu-devel, in case anyone else knows of what in Lucid might still
> require bochs.

As Soren notes, bochs is its own project. I don't think it's too much to ask for a simple regression-test before and after this vgabios change.

Rejecting the vgabios upload from the freeze queue, since beta freeze is over and this shouldn't be accidentally accepted.

Dustin Kirkland  (kirkland) wrote :

On Thu, Apr 8, 2010 at 5:26 PM, Steve Langasek
<email address hidden> wrote:
>> The only users positively affected by the new upload are those that
>> want to use kvm or qemu with the -vga std option.
>
> Does this mean that if you aren't using the -vga option this change has
> no effect; and that if you are using the -vga option, it doesn't work
> today?

Correct.

> As Soren notes, bochs is its own project.  I don't think it's too much
> to ask for a simple regression-test before and after this vgabios
> change.

Would one of the commenters asking for this upload care to validate it
against bochs? I'm overtasked with higher priority items right now.

> Rejecting the vgabios upload from the freeze queue, since beta freeze is
> over and this shouldn't be accidentally accepted.

Agreed, thanks.

:-Dustin

Thierry Carrez (ttx) on 2010-04-09
Changed in vgabios (Ubuntu Lucid):
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Does anyone care enough about this bug to test vgabios with bochs?

I care about this bug and I can test against bochs within 24 hours. I should be using vgabios 0.6b and whatever bochs is current in Ubuntu, right?

Dustin Kirkland  (kirkland) wrote :

Please use the vgabios in my PPA, and the bochs in Ubuntu.

My ppa:
 * https://edge.launchpad.net/~kirkland/+archive/ppa

Using the vgabios from Dustin's PPA, bochs from Ubuntu (I'm running a 10.4 beta, so that's 2.4.2-1ubuntu1), and the guest OS is a Debian 3.0 image from Bochs' Sourceforge page. I can run X11 at 1024x768, 24-bit color. Can't get any higher, but that's as likely a guest-OS limitation as anything (anyone trying to run GUI systems in Bochs is a severe masochist). Mode switching, grayscale modes, text->graphics mode all worked smoothly.

Also, kvm-qemu (from the command-line) is back to working (guest OS here is Win7). I can get up to 1600x1200 there, switched between all modes from 800x600 to 1600x1200 with no problems.

If there are any specific tests that need to be run I'd be glad to give 'em a whack.

Changed in vgabios (Ubuntu Lucid):
status: Fix Committed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vgabios - 0.6c-2ubuntu1

---------------
vgabios (0.6c-2ubuntu1) lucid; urgency=low

  * debian/roll-back-to-qemu_0.12.3-snapshot.patch: this patch
    brings vgabios back to the version released in qemu-0.12.3, which
    is recommended specifically by qemu and qemu-kvm upstream, LP: #513273
 -- Dustin Kirkland <email address hidden> Fri, 16 Apr 2010 10:24:40 -0500

Changed in vgabios (Ubuntu Lucid):
status: In Progress → Fix Released
Bob Smith (porjo38) wrote :

I've just upgraded to 10.04 (LTS) from 9.10. I can't get 1680x1050 resolution any more with my WinXP VM. The best I can do is 1600x1200 then stretch/squash to fit which looks terrible. I'm using the '-vga std' option. I also get a series of errors at launch (like the parent post):

BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
...

Bob Smith (porjo38) wrote :

Compiling vgabios from qemu-kvm 0.12.3 source fixed my issue. There appears to be a bunch of video modes missing from the VBE tables in vgabios distributed with 10.04!?

sotirovlyu (sotirovlyu) wrote :

I'm using qemu-kvm 0.12.3 with "-vga std" and with res like 1680x1050, 1440x900 and a few other it crashes/quits immediately with message "Could not open SDL display". It happens for me both when switching with ctrl-alt-f or with cmd line option -full-screen. With 1024x768 for example it does not happen, may be other. I'm using the package provided with Ubuntu 10.4

We discussed on #kvm@freenode with a guy nicknamed "mjt" (said he's debian qemu-kvm package maintainer) that this is for sure a bug after testing it by himself and according to him is present also in the current qemu-kvm 0.12.4., but easy to spot and hopefully to fix.

By the way, should I open new bug report ot posting it here is enough?

P.S. I'm particularly interested to know how can I track the progress of fixing of this bug, as I'm currently researching a solution to implement KVM as a virtualization platfrom for desktops using the resolutions mentioned in the beginning. Unfortunately the way KVM quits and closes the whole machine while encoutering this bug scares me a bit about the stability of "-vga std".

sotirovlyu (sotirovlyu) wrote :

Forgot to mention that I'm also getting constantly the error message:

BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters
BUG: kvm_dirty_pages_log_enable_slot: invalid parameters
BUG: kvm_dirty_pages_log_disable_slot: invalid parameters

um. Can't you just take approach used in Debian, namely, to provide the sources for the bios files and compile them at build time? That is somewhat ugly, but at least it works...

Claus Frein (cfrein) wrote :

Still getting "BUG: kvm_dirty_pages_log_enable_slot: invalid parameters" with "-vga std"-parameter on lucid.

I would suggest to set the bug-status to confirmed instead of fix-released.
---
dpkg -l |egrep -e "kvm|vgabios"
ii kvm 1:84+dfsg-0ubuntu16+0.12.3+noroms+0ubuntu9 dummy transitional pacakge from kvm to qemu-
ii kvm-pxe 5.4.4-1ubuntu1 PXE ROM's for KVM
ii qemu-kvm 0.12.3+noroms-0ubuntu9 Full virtualization on i386 and amd64 hardwa
ii vgabios 0.6c-2ubuntu1 VGA BIOS software for the Bochs and Qemu emu

Dustin Kirkland  (kirkland) wrote :

@Claus-

Other than the error message, are you seeing incorrect behavior? If
so, what specifically?

Claus Frein (cfrein) wrote :

Hi Dustin,

behavior seems ok. No issues there. Just the error message.

Anything you want me to try/test?

Claus

2010/6/15 Dustin Kirkland <email address hidden>:
> @Claus-
>
> Other than the error message, are you seeing incorrect behavior?  If
> so, what specifically?
>
> --
> kvm with -vga std is broken since karmic
> https://bugs.launchpad.net/bugs/513273
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Compared with the vgabios.bin supplied by upstream in qemu-kvm-0.12.4.tar.gz, the current Lucid vgabios regresses support for a number of vga modes (e.g. 1920x1200).

Victor Ashik (vashik+) wrote :

vgabios-0.6c-2ubuntu1 does not fix the bug for me.
Building vgabios.bin from qemu-kvm-0.12.4.tar.gz sources helps.

morleyfl (morleyfl) on 2010-12-23
Changed in vgabios (Ubuntu):
assignee: Dustin Kirkland (kirkland) → morleyfl (morleyfl)
Changed in vgabios (Ubuntu Lucid):
assignee: Dustin Kirkland (kirkland) → morleyfl (morleyfl)
Theo Nolte (theo-nolte) wrote :

Building vgabios from source as described above added the missing modes for me too. But still the vga driver does not work properly - it builds the screen very slowly line by line and takes 20 seconds or more just for the login-screen.

After some hours I gave up on vga and switched to the vmware-driver - now everything works great.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers