qemu-kvm must depend on udev

Bug #1080912 reported by Jared Brown on 2012-11-19
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qemu-kvm (Ubuntu)
Critical
Serge Hallyn
Precise
Critical
Unassigned
Quantal
Critical
Unassigned
Raring
Critical
Serge Hallyn

Bug Description

=========================================
SRU Justification:
1. Impact: install/upgrade of qemu-kvm alongside udev can fail.
2. Development fix: make qemu-kvm depend on udev
3. Stable fix: same as development fix
4. Test case:
 sudo apt-get install udev qemu-kvm
 sudo dpkg -i /var/cache/apt/archive/udev_* /var/cache/apt/archive/qemu-kvm*
 sudo dpkg -i /var/cache/apt/archive/qemu-kvm* /var/cache/apt/archive/udev_*
 (one of those will fail)
5. Regression potential: none.
=========================================
Error occurred during standard sudo apt-get upgrade action

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: qemu-kvm 1.0+noroms-0ubuntu14.4
ProcVersionSignature: Ubuntu 3.2.0-32.51-generic-pae 3.2.30
Uname: Linux 3.2.0-32-generic-pae i686
ApportVersion: 2.0.1-0ubuntu15
Architecture: i386
Date: Mon Nov 19 21:30:54 2012
DuplicateSignature:
 Setting up qemu-kvm (1.0+noroms-0ubuntu14.4) ...
 Installing new version of config file /etc/init/qemu-kvm.conf ...
 udevadm trigger is not permitted while udev is unconfigured.
 dpkg: error processing qemu-kvm (--configure):
  subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu-Server 11.10 "Oneiric Ocelot" - Release i386 (20111011)
KvmCmdLine: Error: command ['ps', '-C', 'kvm', '-F'] failed with exit code 1: UID PID PPID C SZ RSS PSR STIME TTY TIME CMD
MachineType: Hewlett-Packard HP Pavilion dv6000 (RP283UA#ABA)
MarkForUpload: True
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-32-generic-pae root=UUID=7e50890a-964b-49c5-a629-5d03c1ef9cd4 ro
SourcePackage: qemu-kvm
Title: package qemu-kvm 1.0+noroms-0ubuntu14.4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-05-02 (201 days ago)
dmi.bios.date: 03/22/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.2E
dmi.board.name: 30BB
dmi.board.vendor: Quanta
dmi.board.version: 66.42
dmi.chassis.type: 10
dmi.chassis.vendor: Quanta
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.2E:bd03/22/2010:svnHewlett-Packard:pnHPPaviliondv6000(RP283UA#ABA):pvrRev1:rvnQuanta:rn30BB:rvr66.42:cvnQuanta:ct10:cvrN/A:
dmi.product.name: HP Pavilion dv6000 (RP283UA#ABA)
dmi.product.version: Rev 1
dmi.sys.vendor: Hewlett-Packard

Jared Brown (jared-brown) wrote :
tags: removed: need-duplicate-check
Changed in qemu-kvm (Ubuntu):
importance: Undecided → High
Serge Hallyn (serge-hallyn) wrote :

Thanks for submitting this bug.

I can't reproduce it here, but it sounds like it would be worthwhile to do the udevadm trigger only if udev is running.

Serge Hallyn (serge-hallyn) wrote :

Can you tell us if you did anything manually to affect udev before the upgrade?

Changed in qemu-kvm (Ubuntu):
status: New → Incomplete
Serge Hallyn (serge-hallyn) wrote :

Sorry, reproduced it now.

Changed in qemu-kvm (Ubuntu):
status: Incomplete → Confirmed
assignee: nobody → Serge Hallyn (serge-hallyn)
status: Confirmed → In Progress
Changed in qemu-kvm (Ubuntu Raring):
importance: High → Critical
Steve Langasek (vorlon) wrote :

qemu-kvm needs to depend on the udev package, to ensure the udev package is configured first before the qemu-kvm package's maintainer script is called.

summary: - package qemu-kvm 1.0+noroms-0ubuntu14.4 failed to install/upgrade:
- subprocess installed post-installation script returned error exit status
- 1
+ qemu-kvm must depend on udev
description: updated
Changed in qemu-kvm (Ubuntu Precise):
importance: Undecided → Critical
status: New → In Progress
Changed in qemu-kvm (Ubuntu Quantal):
importance: Undecided → Critical
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 1.2.0+noroms-0ubuntu5

---------------
qemu-kvm (1.2.0+noroms-0ubuntu5) raring; urgency=low

  * add udev to qemu-kvm Depends to ensure that postinst succeeds.
    (LP: #1080912)
 -- Serge Hallyn <email address hidden> Tue, 20 Nov 2012 09:51:40 -0600

Changed in qemu-kvm (Ubuntu Raring):
status: In Progress → Fix Released

Hello Jared, or anyone else affected,

Accepted qemu-kvm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/qemu-kvm/1.0+noroms-0ubuntu14.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in qemu-kvm (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in qemu-kvm (Ubuntu Quantal):
status: In Progress → Fix Committed
Adam Conrad (adconrad) wrote :

Hello Jared, or anyone else affected,

Accepted qemu-kvm into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/qemu-kvm/1.2.0+noroms-0ubuntu2.12.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Serge Hallyn (serge-hallyn) wrote :

Verified in precise.

Serge Hallyn (serge-hallyn) wrote :

Verified in quantal.

tags: added: verification-done
removed: verification-needed
Adam Conrad (adconrad) wrote :

Hello Jared, or anyone else affected,

Accepted qemu-kvm into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/qemu-kvm/1.0+noroms-0ubuntu14.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
tags: added: verification-needed
removed: verification-done
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 1.2.0+noroms-0ubuntu2.12.10.1

---------------
qemu-kvm (1.2.0+noroms-0ubuntu2.12.10.1) quantal-proposed; urgency=low

  [ Serge Hallyn ]
  * debian/qemu-kvm.postinst: use udevadm trigger to change /dev/kvm perms as
    recommended by Steve Langasek (LP: #1057024)
  * apply debian/patches/nbd-fixes-to-read-only-handling.patch from upstream to
    make read-write mount after read-only mount work. (LP: #1077838)
  * make qemu-kvm depend on udev (LP: #1080912)

  [ Robert Collins ]
  * Fix upstart job to succeed if ksm settings can't be altered in the same way
    other settings are handled. (LP: #1078530)
 -- Serge Hallyn <email address hidden> Mon, 19 Nov 2012 09:15:42 -0600

Changed in qemu-kvm (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qemu-kvm - 1.0+noroms-0ubuntu14.6

---------------
qemu-kvm (1.0+noroms-0ubuntu14.6) precise-proposed; urgency=low

  * Fix qemu-kvm.upstart: just don't run in a container. Otherwise we'll
    still try to load/unload kernel modules. Also undo the || true after
    sysfs writes. Since setting those is a part of configuring qemu-kvm
    on the host, failing when they fail makes sense.

qemu-kvm (1.0+noroms-0ubuntu14.5) precise-proposed; urgency=low

  * add udev to qemu-kvm Depends to ensure that postinst succeeds.
    (LP: #1080912)

qemu-kvm (1.0+noroms-0ubuntu14.4) precise-proposed; urgency=low

  [ Serge Hallyn ]
  * debian/qemu-kvm.postinst: use udevadm trigger to change /dev/kvm perms as
    recommended by Steve Langasek (LP: #1057024)
  * apply debian/patches/nbd-fixes-to-read-only-handling.patch from upstream to
    make read-write mount after read-only mount work. (LP: #1077838)

  [ Robert Collins ]
  * Fix upstart job to succeed if ksm settings can't be altered in the same way
    other settings are handled. (LP: #1078530)
 -- Serge Hallyn <email address hidden> Thu, 20 Dec 2012 12:34:52 -0600

Changed in qemu-kvm (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers