[22.10 FEAT] qclib: Add Support for new IBM Z Hardware (z16)

Bug #1982332 reported by bugproxy
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu on IBM z Systems
Fix Released
High
Skipper Bug Screeners
qclib (Ubuntu)
Status tracked in Kinetic
Jammy
Fix Released
High
Unassigned
Kinetic
Fix Released
High
Unassigned

Bug Description

SRU Justification:
==================

[Impact]

 * This is a hardware enablement SRU that adds support for IBM z16.

 * It just adds a single code line to the qc_mtype struct
   that maps from type '3931' to the (real) IBM zSystems name 'IBM z16'.

[Test Plan]

 * Install an Ubuntu 22.04 or 22.10 daily on an IBM z16 LPAR, z/VM guest
   or KVM vm and install the qclib test package:
   sudo apt install qclib-test
   that will also pull in libqc2, too.

 * Then execute the test program 'qc_test' and look for the qc_type_name.
   The updated package will be able to identify 'IBM z16' like this:
   $ qc_test | grep qc_type_name
                          qc_type_name [S ]: IBM z16

[Where problems could occur]

 * Problems can occur in case the type '3931' is not the correct
   one for IBM z16,

 * the qc_type_name is not correct,

 * or the qc_mtype struct is not expanded correctly.

 * All this can be verified by either a test build, available here:
   https://launchpad.net/~fheimes/+archive/ubuntu/lp1982332/+packages
   or by the test described above:
   qc_test | grep -B 1 qc_type_name

[Other Info]

 * Even if only 22.10 is mentioned in the title, it is very useful
   to have that hardware enablement patch in 22.04 as well,
   since 22.04 is the first Ubuntu Server release with IBM z16 support.
__________

Add support for new IBM Z Hardware in qclib

bugproxy (bugproxy)
tags: added: architecture-s39064 bugnameltc-199023 severity-high targetmilestone-inin2210
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → linux (Ubuntu)
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2022-07-20 07:36 EDT-------
Patches are included in qclib 2.3.1 as available from
https://github.com/ibm-s390-linux/qclib/releases/tag/2.3.1
where the readme file says
"
* __v2.3.1 (2022-04-05)__

_Changes_:
- Recognize IBM z16
"

Frank Heimes (fheimes)
affects: linux (Ubuntu) → qclib (Ubuntu)
Changed in ubuntu-z-systems:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
Changed in qclib (Ubuntu):
assignee: Skipper Bug Screeners (skipper-screen-team) → Frank Heimes (fheimes)
importance: Undecided → High
Changed in ubuntu-z-systems:
importance: Undecided → High
Changed in qclib (Ubuntu):
status: New → In Progress
Changed in ubuntu-z-systems:
status: New → In Progress
Revision history for this message
Frank Heimes (fheimes) wrote :

Test package for kinetic is build in PPA:
https://launchpad.net/~fheimes/+archive/ubuntu/lp1982332

Revision history for this message
Frank Heimes (fheimes) wrote :
Changed in qclib (Ubuntu):
assignee: Frank Heimes (fheimes) → nobody
Revision history for this message
Frank Heimes (fheimes) wrote :

No API changes, no symbols file update needed.

Frank Heimes (fheimes)
tags: added: kinetic
Revision history for this message
Frank Heimes (fheimes) wrote :

Another debdiff for the jammy version of the qclib.

Changed in qclib (Ubuntu Jammy):
importance: Undecided → High
status: New → In Progress
information type: Private → Public
Frank Heimes (fheimes)
description: updated
description: updated
tags: added: jammy
Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2022-07-25 09:51 EDT-------
Patch looks good, but why not just switch to qclib v2.3.1? Or am I mis-interpreting the attached diffs?!

Revision history for this message
Frank Heimes (fheimes) wrote :

Well, for kinetic/22.10 (which is the version that is still in development) we indeed plan to version bump to latest 2.3.1:
https://bugs.launchpad.net/ubuntu/+source/qclib/+bug/1982332/+attachment/5604361/+files/debdiff_qclib_kinetic_2.3.0-0ubuntu1_to_2.3.1-0ubuntu1.diff

But version bumps are not allowed for Ubuntu releases that are already out and in service, like jammy/22.04, hence I could only SRU and cherry pick 'Recognize IBM z16' for jammy, hence the minor version increase to v2.3.0-0ubuntu1.1:
https://bugs.launchpad.net/ubuntu/+source/qclib/+bug/1982332/+attachment/5604439/+files/debdiff_qclib_jammy_2.3.0-0ubuntu1_to_2.3.0-0ubuntu1.1.diff

Revision history for this message
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2022-07-25 11:47 EDT-------
Ah, OK - I was wondering if this might be a bump for 22.04, indeed. But this BZs summary mentioned 22.10, hence my confusion.
Thx!

Revision history for this message
Lukas Märdian (slyon) wrote :

Thank you very much for those very clean debdiffs, using proper patch headers and the PPA test builds!

LGTM. sponsored into Kinetic and into Jammy's SRU (unapproved) queue: https://launchpad.net/ubuntu/jammy/+queue?queue_state=1&queue_text=qclib

FYI: I fixed a minor typo in the jammy "Origin: upstream, https://..." patch header github URL.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qclib - 2.3.1-0ubuntu1

---------------
qclib (2.3.1-0ubuntu1) kinetic; urgency=medium

  * New upstream release 2.3.1 LP: #1982332
  * Remove the only existing quilt patch 'fix-readme-install.diff',
    since the fix is now upstream.
  * Add debian/watch file (in version 4).

 -- Frank Heimes <email address hidden> Wed, 20 Jul 2022 13:55:44 +0200

Changed in qclib (Ubuntu Kinetic):
status: In Progress → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello bugproxy, or anyone else affected,

Accepted qclib into jammy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/qclib/2.3.0-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-jammy to verification-done-jammy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-jammy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in qclib (Ubuntu Jammy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-jammy
Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed
Revision history for this message
bugproxy (bugproxy) wrote : Comment bridged from LTC Bugzilla

------- Comment From <email address hidden> 2022-09-13 10:47 EDT-------
I've installed qclib_2.3.0-0ubuntu1.1_s390x.deb on jammy on a IBM z16 and indeed 'zname' dumps IBM z16. -> Verified

Revision history for this message
Frank Heimes (fheimes) wrote :

Thx Andreas for the verification - I'll adjust the tags accordingly ...

tags: added: verification-done verification-done-jammy
removed: verification-needed verification-needed-jammy
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qclib - 2.3.0-0ubuntu1.1

---------------
qclib (2.3.0-0ubuntu1.1) jammy; urgency=medium

  * Add d/p/lp-1982332-Recognize-IBM-z16.patch (based on upstream commit
    6e8a1b6) to introduce support for new IBM z16 hardware. LP: #1982332

 -- Frank Heimes <email address hidden> Wed, 20 Jul 2022 19:49:33 +0200

Changed in qclib (Ubuntu Jammy):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for qclib has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Frank Heimes (fheimes)
Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers