printing hatches to PostScript produces spurious lines

Bug #74358 reported by Arno Peters on 2006-12-04
4
Affects Status Importance Assigned to Milestone
qcad (Ubuntu)
Medium
Unassigned

Bug Description

I will attach a sample DXF file and the corresponding PostScript output

How to reproduce:
1. open qcad.dxf in QCad
2. print the drawing to file
3. look at the generated PostScript file, between the hatch elements are spurious lines that are not in the DXF drawing.

These artefacts are also visible when using the vec2web tool from Ribbonsoft. This means the bug is probably located in either the dxflib or the qcadlib.

Arno Peters (awpeters) wrote :
Arno Peters (awpeters) wrote :
Arno Peters (awpeters) wrote :

I am using QCad version 2.0.5.0-1-1

Arno Peters (awpeters) wrote :

Further investigation seems to indicate the problem is located in the Qt libraries. The generated PostScript says:

%!PS-Adobe-1.0
%%BoundingBox: 0 0 594 842
%%Creator: Qt 3.3.6
%%CreationDate: ma dec 4 10:14:57 2006
%%Orientation: Landscape
%%Pages: 1

Maybe this problem is resolved with a newer version of the Qt libraries?

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 alpha?

Changed in qcad:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in qcad:
status: Incomplete → Invalid
Arno Peters (awpeters) wrote :

I have tested the DXF with Ubuntu Intrepid. The problem is still present.

Changed in qcad:
status: Invalid → New
Gaetan Nadon (memsize) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

BugSquad

Changed in qcad:
status: New → Confirmed
LaserJock (laserjock) wrote :

Here's something I found that may help:
http://tech.groups.yahoo.com/group/qcad-user/message/1613

Changed in qcad:
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers