Koffice requires newer libqca2-plugins-ossl to open encrypted documents

Bug #382691 reported by Jon Severinsson on 2009-06-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
qca2-plugin-ossl (Debian)
Fix Released
Unknown
qca2-plugin-ossl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: libqca2-plugin-ossl

Using the version of libqca2-plugins-ossl from jaunty will cause Koffice (both version 1.9.99.9 and 2.0.0) to fail to open encrypted odf documents with an error about missing hash funtions.

After updating libqca2-plugin-ossl to the latest version ( 2.0.0-beta3 ) availible upstream ( http://delta.affinix.com/qca/ ) it works just fine.
I've uploaded the debs to my ppa ( https://launchpad.net/~jon-severinsson/+archive/ppa ) if anyone else wants to test.

Changed in qca2-plugin-ossl (Debian):
status: Unknown → New
Felix Geyer (debfx) on 2011-02-12
Changed in qca2-plugin-ossl (Ubuntu):
assignee: nobody → Felix Geyer (debfx)
status: New → In Progress
Felix Geyer (debfx) wrote :

Even with a more recent qca2-plugins-ossl version that supports the required hash functions, kword is not able to open encrypted odf files.

Changed in qca2-plugin-ossl (Ubuntu):
assignee: Felix Geyer (debfx) → nobody
status: In Progress → Confirmed

As of today, kspread from both lucid and lucid-backports can open an encrypted ods files using libqca2-plugin-ossl from my PPA. I have previously used kspread from jaunty and karmic to open encrypted ods files using libqca2-plugin-ossl from my PPA.

Since lucid I get a second password prompt which I must cancel to get to the document, but it still works.

I don't have a maverick or natty install to test, nor do I have any encrypted odt files to test with kword.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qca2-plugin-ossl - 2.0.0~beta3-1

---------------
qca2-plugin-ossl (2.0.0~beta3-1) unstable; urgency=low

  * New upstream release.
    - Supports the pbkdf2(sha1) algorithm. (Closes: #514880; LP: #382691)

  [ Matthew Rosewarne ]
  * Tweak package description.
  * Add Homepage: to control.
  * Add watch file.

  [ Felix Geyer ]
  * Switch to source format 3.0 (quilt).
    - Turn changes from the last revision into a proper patch:
      remove_whirlpool_algo.diff
  * Switch debian/rules engine to dhmk.
  * Enable support for MD2 only when available in OpenSSL. (Closes: #622017)
    - Add detect_md2_available.diff
  * Enable support for SSL2 only when available in OpenSSL.
    - Add detect_ssl2_available.diff
  * Don't install the TODO file.
  * Drop libqca2-plugin-ossl.install as we only build a single binary package.
  * Switch to debhelper compat level 7.
  * Bump Standards-Version to 3.9.2, no changes needed.
  * Add myself to uploaders.
  * Fix lintian warning copyright-with-old-dh-make-debian-copyright.
  * Add Vcs-* fields.
 -- Ubuntu Archive Auto-Sync <email address hidden> Tue, 31 May 2011 08:54:08 +0000

Changed in qca2-plugin-ossl (Ubuntu):
status: Confirmed → Fix Released
Changed in qca2-plugin-ossl (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.