[natty] Qbzr not found by bzr/bzr-explorer

Bug #699713 reported by Aaron Peachey on 2011-01-07
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
qbzr (Ubuntu)
High
Andrew Starr-Bochicchio
Natty
High
Andrew Starr-Bochicchio

Bug Description

Binary package hint: bzr-explorer

Natty Alpha 1 with updates applied.
bzr 2.3.0~beta3-1ubuntu3
bzr-explorer 1.1.0-0ubuntu1
qbzr 0.20~bzr1344-1

Starting Bazaar explorer (command: bzr explorer) results in Bazaar Explorer not starting as expected.
Instead, terminal outputs a message: bzr: ERROR: Bazaar Explorer requires QBzr. Please install QBzr (https://launchpad.net/qbzr).

QBzr is already installed.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: bzr-explorer 1.1.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-11.25-generic 2.6.37-rc7
Uname: Linux 2.6.37-11-generic i686
Architecture: i386
Date: Fri Jan 7 16:00:32 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101202)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: bzr-explorer

Aaron Peachey (aaronp) wrote :
Hans Joachim Desserud (hjd) wrote :

Confirmed on Natty. I got the same error even though qbzr was installed.

Changed in bzr-explorer (Ubuntu):
status: New → Confirmed

Thanks for reporting!

Could you post the output of "bzr plugins" and "dpkg -L qbzr"

Changed in bzr-explorer (Ubuntu):
importance: Undecided → High
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
status: Confirmed → In Progress
status: In Progress → Incomplete
Aaron Peachey (aaronp) wrote :
Aaron Peachey (aaronp) wrote :

OK, this is a bit stange. Qbzr doesn't seem to be found at all by bzr even though it is fully installed. I've confirmed this myself on Natty, but can not reproduce using the same versions of bzr-explorer and qbzr in Debian Sid or Ubuntu Maverick. Reassigning to qbzr as all qbzr commands are broken in Natty, bot just bzr-explorer.

I'll have to look into this closer, but my initial guess is that this has something to do with the python 2.7 transition.

Changed in bzr-explorer (Ubuntu):
assignee: Andrew Starr-Bochicchio (andrewsomething) → nobody
status: Incomplete → Confirmed
affects: bzr-explorer (Ubuntu) → qbzr (Ubuntu)
Changed in qbzr (Ubuntu):
assignee: nobody → Andrew Starr-Bochicchio (andrewsomething)
summary: - bazaar explorer requires Qbzr even though already installed
+ Qbzr not found by bzr/bzr-explorer
summary: - Qbzr not found by bzr/bzr-explorer
+ [natty] Qbzr not found by bzr/bzr-explorer
tags: added: python27
tags: removed: running-unity

Since bzr 2.3.0~beta5 hit natty, I can no longer reproduce this issue. Can anyone else confirm that this has been resolved?

andrew@andrew-testing:~$ policy bzr
bzr:
  Installed: 2.3.0~beta5-1
  Candidate: 2.3.0~beta5-1
  Version table:
 *** 2.3.0~beta5-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status
andrew@andrew-testing:~$ policy qbzr
qbzr:
  Installed: 0.20~bzr1344-1
  Candidate: 0.20~bzr1344-1
  Version table:
 *** 0.20~bzr1344-1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
        100 /var/lib/dpkg/status

Changed in qbzr (Ubuntu Natty):
status: Confirmed → Incomplete

Yes, I can now open bazaar explorer. Many thanks.

Thanks for the follow up Aaron!

Changed in qbzr (Ubuntu Natty):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers