Qalculate SIGABRTs with exp($large_number)

Bug #234398 reported by Alexander Jones on 2008-05-23
Affects Status Importance Assigned to Milestone
libqalculate (Ubuntu)
qalculate-gtk (Ubuntu)

Bug Description

Binary package hint: qalculate

alex@fizz:~$ qalc
> exp(1)

  exp(1) = approx. 2.7182818

> exp(1E10)
terminate called after throwing an instance of 'cln::runtime_exception'
  what(): Out of virtual memory.
alex@fizz:~$ qalc
> exp(-1E10)
terminate called after throwing an instance of 'cln::runtime_exception'
  what(): Not a 32-bit integer: 14426950664

Also affects the GTK version.

ProblemType: Bug
Architecture: amd64
Date: Fri May 23 18:13:13 2008

DistroRelease: Ubuntu 8.04
NonfreeKernelModules: ath_hal nvidia
Package: qalculate None [modified: /var/lib/dpkg/info/qalculate.list]
PackageArchitecture: all
SourcePackage: qalculate-gtk
Uname: Linux 2.6.24-17-generic x86_64

Confirming this for the current version (0.9.6-2). Although I get different error messages on my 32 bit system:

terminate called after throwing an instance of 'cln::floating_point_overflow_exception'
  what(): floating point overflow.

for exp(1e10) and the same with "underflow" for exp(-1e10).
As this problem also occurs with qalculate from the developer homepage, I forwarded this bug upstream.

Changed in qalculate-gtk:
status: New → Confirmed
  • unnamed Edit (82 bytes, text/html; charset=ISO-8859-1)

Thanks for that, Marcel. I'm too lazy to report stuff upstream myself. :P

Dave Gilbert (ubuntu-treblig) wrote :

Confirmed on 0.9.7-3ubuntu1 on Quantal.

The -ve one still aborts/core dumps with the Not a 32-bit integer.

The exp(1E10) sits there using vast amounts of memory, and I gave up waiting.
(I wouldn't want to limit the upper size it could work at on a suitably capable machine, so I'm not sure I regard the postiive case as a bug).

Changed in qalculate-gtk (Ubuntu):
importance: Undecided → Low
Changed in qalculate (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Logan Rosen (logan) on 2013-05-19
affects: qalculate (Ubuntu) → libqalculate (Ubuntu)
Lyn Perrine (walterorlin) wrote :

I still get this same result trying to calculate this with 16 GB of ram.

tags: added: wily
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.