Merge pyxdg 0.17-0.1 (main) from Debian testing (main)

Bug #497538 reported by Artur Rona
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyxdg (Ubuntu)
Undecided
Unassigned

Bug Description

 pyxdg (0.17-0.1) unstable; urgency=low

   * Non-maintainer upload.
   * New upstream version (closes: #508885).
   * Bump Standards-Version to 3.8.3 (no changes needed).
   * Add patch fixing README from Jakub Wilk (closes: #535840).
   * Add patch fixing menu filename handling (closes: #407747).
   * debian/control:
     + Remove XB-Python-Version field.
     + Remove ${shlibs:Depends}.
     + Add Homepage field (closes: #542474).
     + s/python/Python/ in description (closes: #542471).
     + Add new supported specifications in description.
   * debian/copyright:
     + Add copyright notice.
     + Point to LGPL-2.
   * debian/rules:
     + Fix encoding (ISO-8859-1 to UTF-8).
   * Add debian/watch.

 -- Piotr Lewandowski <email address hidden> Wed, 23 Sep 2009 13:01:50 +0200

Related branches

Artur Rona (ari-tczew)
Changed in pyxdg (Ubuntu):
status: New → Confirmed
Revision history for this message
Artur Rona (ari-tczew) wrote :
Revision history for this message
Daniel Holbach (dholbach) wrote :

The indenting of your gettext-support patch is wrong, it results in this:
daniel@bert:~/1/usr/share/pyshared$ python -tt xdg/IniFile.py
  File "xdg/IniFile.py", line 85
    e = self.content.get('Desktop Entry', {})
                                            ^
IndentationError: unindent does not match any outer indentation level
daniel@bert:~/1/usr/share/pyshared$

Whta happened to all the other patches we carried?
daniel@bert:~$ debdiff pyxdg_0.15-1.1.dsc pyxdg_0.15-1.1ubuntu5.dsc | diffstat
 debian/patches/fix-reversed-definition.patch | 13 ----
 debian/patches/gettext-support.patch | 44 +++++++++++++++
 debian/patches/ignore-ioerror.patch | 15 +++++
 debian/patches/ignore-unicore-error.patch | 21 +++++++
 debian/patches/interpreter-names.patch | 24 ++++++++
 pyxdg-0.15/debian/changelog | 76 +++++++++++++++++++++++++++
 pyxdg-0.15/debian/control | 5 +
 7 files changed, 183 insertions(+), 15 deletions(-)
daniel@bert:~$

Revision history for this message
Artur Rona (ari-tczew) wrote :

Daniel, gettext-support is needed rewrite. Other patches were fixed/applied upstream. If gettext-support patch isn't important, we can drop this patch and sync pyxdg.

Revision history for this message
Daniel Holbach (dholbach) wrote :

If you apply the current patch to xdg/IniFile.py it will not work because the indentation is broken.

Revision history for this message
Artur Rona (ari-tczew) wrote :

So this merge request needs convert to a sync request, right? Because patch will be drop.

Revision history for this message
Daniel Holbach (dholbach) wrote :

No. You need to carefully check that the patch is really not needed any more. It might need to be rewritten.

Revision history for this message
Artur Rona (ari-tczew) wrote :

I did test the command "python -tt xdg/IniFile.py" based on already version 0.15-1.1ubuntu5 and I got error. So I subscribed Martin Pitt because he is a last uploader of changed gettext-support.patch.
Martin, could you review this patch, please?

Revision history for this message
Martin Pitt (pitti) wrote :

I fixed the whitespacing in the patch and also fixed the patch description in the changelog. Will upload now, thanks!

Changed in pyxdg (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyxdg - 0.17-0.1ubuntu1

---------------
pyxdg (0.17-0.1ubuntu1) lucid; urgency=low

  * Merge from debian testing, remaining changes (LP: #497538):
    - gettext-support.patch: Support X-GNOME-Gettext-Domain and
      X-Ubuntu-Gettext-Domain fields in .desktop files, for dynamic
      translation support (corresponding to our glib change).
  * debian/patches/fix-reversed-definition.patch:
    - Removed, fixed upstream

pyxdg (0.17-0.1) unstable; urgency=low

  * Non-maintainer upload.
  * New upstream version (closes: #508885).
  * Bump Standards-Version to 3.8.3 (no changes needed).
  * Add patch fixing README from Jakub Wilk (closes: #535840).
  * Add patch fixing menu filename handling (closes: #407747).
  * debian/control:
    + Remove XB-Python-Version field.
    + Remove ${shlibs:Depends}.
    + Add Homepage field (closes: #542474).
    + s/python/Python/ in description (closes: #542471).
    + Add new supported specifications in description.
  * debian/copyright:
    + Add copyright notice.
    + Point to LGPL-2.
  * debian/rules:
    + Fix encoding (ISO-8859-1 to UTF-8).
  * Add debian/watch.
 -- Artur Rona <email address hidden> Wed, 16 Dec 2009 21:37:53 +0100

Changed in pyxdg (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers