Please sponsor pywebkitgtk-1.1.8-0ubuntu2 in main

Bug #624976 reported by Christophe Sauthier
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pywebkitgtk (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sponsor pywebkitgtk-1.1.8-0ubuntu2 in main

Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote :
Changed in pywebkitgtk (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for the work Christophe

Changed in pywebkitgtk (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Steve Langasek (vorlon) wrote :

Accepted into the archive past beta freeze, but this is not a very elegant way to solve the problem:

--- pywebkitgtk-1.1.8/debian/rules 2010-08-11 21:31:53.000000000 +0100
+++ pywebkitgtk-1.1.8/debian/rules 2010-08-26 23:13:12.000000000 +0100
@@ -11,3 +11,8 @@

 GNOME_DOWNLOAD_URL = http://pywebkitgtk.googlecode.com/files/$(GNOME_TARBALL)
 DEB_COMPRESS_EXCLUDE += .py
+
+build/python-webkit-dev::
+ #pkg-config file
+ mkdir -p debian/tmp/usr/lib/pkgconfig
+ cp debian/build/pywebkitgtk-1.0.pc debian/tmp/usr/lib/pkgconfig/

Why does writing 'debian/build/pywebkitgkt-1.0.pc usr/lib/pkgconfig' in debian/python-webkit-dev.install not suffice?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pywebkitgtk - 1.1.8-0ubuntu2

---------------
pywebkitgtk (1.1.8-0ubuntu2) maverick; urgency=low

  * Fix the FTBFS (LP: #624976)
    - debian/rules : add the manual handling of the .pc file.
 -- Christophe Sauthier <email address hidden> Fri, 27 Aug 2010 00:03:09 +0200

Changed in pywebkitgtk (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Christophe Sauthier (christophe.sauthier) wrote : Re: [Bug 624976] Re: Please sponsor pywebkitgtk-1.1.8-0ubuntu2 in main

Hi Steve,

Indeed it was a really nasty way to do it, I have just used the code
that I had modified to handle many python versions... and it was
clearly not the best way...

Thanks for your remark,

         Christophe
---
Christophe Sauthier   -  06 16 98 63 96

On Fri, Aug 27, 2010 at 2:03 AM, Steve Langasek
<email address hidden> wrote:
> Accepted into the archive past beta freeze, but this is not a very
> elegant way to solve the problem:
>
> --- pywebkitgtk-1.1.8/debian/rules      2010-08-11 21:31:53.000000000 +0100
> +++ pywebkitgtk-1.1.8/debian/rules      2010-08-26 23:13:12.000000000 +0100
> @@ -11,3 +11,8 @@
>
>  GNOME_DOWNLOAD_URL = http://pywebkitgtk.googlecode.com/files/$(GNOME_TARBALL)
>  DEB_COMPRESS_EXCLUDE += .py
> +
> +build/python-webkit-dev::
> +       #pkg-config file
> +       mkdir -p debian/tmp/usr/lib/pkgconfig
> +       cp debian/build/pywebkitgtk-1.0.pc debian/tmp/usr/lib/pkgconfig/
>
> Why does writing 'debian/build/pywebkitgkt-1.0.pc usr/lib/pkgconfig' in
> debian/python-webkit-dev.install not suffice?
>
> --
> Please sponsor pywebkitgtk-1.1.8-0ubuntu2 in main
> https://bugs.launchpad.net/bugs/624976
> You received this bug notification because you are a direct subscriber
> of the bug.
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers