py3compile: NameError: name 'quiet' is not defined

Bug #1887732 reported by John Strand on 2020-07-16
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
eric (Ubuntu)
Undecided
Unassigned
python3-defaults (Ubuntu)
Undecided
Unassigned
python3.8 (Debian)
New
Unknown
python3.8 (Ubuntu)
Undecided
Unassigned

Bug Description

I was upgrading from 18.04 LTS to 20.04 LTS and this popped up. Not sure what else to say.

ProblemType: Package
DistroRelease: Ubuntu 20.04
Package: python3 3.8.2-0ubuntu2
ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
Uname: Linux 5.4.0-40-generic x86_64
ApportVersion: 2.20.11-0ubuntu27.3
Architecture: amd64
CasperMD5CheckResult: skip
Date: Wed Jul 15 17:38:05 2020
ErrorMessage: installed python3 package post-installation script subprocess returned error exit status 4
InstallationDate: Installed on 2019-06-26 (385 days ago)
InstallationMedia: Ubuntu 18.04.2 LTS "Bionic Beaver" - Release amd64 (20190210)
Python3Details: /usr/bin/python3.8, Python 3.8.2, python3-minimal, 3.8.2-0ubuntu2
PythonDetails: /usr/bin/python2.7, Python 2.7.18rc1, python-is-python2, 2.7.17-4
RelatedPackageVersions:
 dpkg 1.19.7ubuntu3
 apt 2.0.2ubuntu0.1
SourcePackage: python3-defaults
Title: package python3 3.8.2-0ubuntu2 failed to install/upgrade: installed python3 package post-installation script subprocess returned error exit status 4
UpgradeStatus: Upgraded to focal on 2020-07-16 (0 days ago)

John Strand (john.strand) wrote :
tags: removed: need-duplicate-check
Kai Kasurinen (kai-kasurinen) wrote :
Changed in eric (Ubuntu):
status: New → Fix Released
Changed in python3.8 (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python3-defaults (Ubuntu):
status: New → Confirmed
Changed in python3.8 (Ubuntu):
status: New → Confirmed
summary: - package python3 3.8.2-0ubuntu2 failed to install/upgrade: installed
- python3 package post-installation script subprocess returned error exit
- status 4
+ py3compile: NameError: name 'quiet' is not defined
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.