Have many "/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used" on simple APT usage

Bug #1863414 reported by Norbert
182
This bug affects 40 people
Affects Status Importance Assigned to Milestone
python3-defaults (Debian)
Fix Released
Unknown
python3-defaults (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned
python3.8 (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

Steps to reproduce:
1. Have Ubuntu 20.04 LTS installed
2. Run regular APT task such as `sudo apt dist-upgrade`
3. Wait it to finish

Expected results:
* APT runs without any warnings and/or errors

Actual results:
* APT runs with many python-related warnings like

>```
>/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported >in binary mode, the default buffer size will be used
> self.stdin = io.open(p2cwrite, 'wb', bufsize)
>
>```

Full output below:

```
$ sudo apt dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  ruby-json ruby-pg ruby-sequel ruby-sequel-pg
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  kdevelop55-libs libxentoolcore1 ubuntu-mate-wallpapers-focal
The following packages will be upgraded:
  atril atril-common debootstrap dmeventd dmsetup dnsmasq-base engrampa engrampa-common fwupd fwupd-signed gir1.2-atrildocument-1.5.0
  gir1.2-atrilview-1.5.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-pluma-1.0 initramfs-tools initramfs-tools-bin initramfs-tools-core
  iproute2 isc-dhcp-client isc-dhcp-common jekyll k3b k3b-data k3b-i18n kdevelop kdevelop-data libatrildocument-dev libatrildocument3
  libatrilview-dev libatrilview3 libdevmapper-event1.02.1 libdevmapper1.02.1 libdistro-info-perl libfwupd2 libfwupdplugin1
  libgirepository-1.0-1 libk3b7 libk3b7-extracodecs liblvm2cmd2.03 libmate-sensors-applet-plugin-dev libmate-sensors-applet-plugin0
  libmate-slab0 libmate-window-settings-dev libmate-window-settings1 libmatedict-dev libmatedict6 libmysqlclient21 libmysqlclient21:i386
  libvirt-clients libvirt-daemon libvirt-daemon-driver-qemu libvirt-daemon-driver-storage-rbd libvirt-daemon-system
  libvirt-daemon-system-systemd libvirt0 libxenstore3.0 libxmlgraphics-commons-java lvm2 mate-applets mate-applets-common mate-common
  mate-control-center mate-control-center-common mate-core mate-desktop-environment mate-desktop-environment-core
  mate-desktop-environment-extra mate-desktop-environment-extras mate-dock-applet mate-media mate-media-common mate-netbook
  mate-netbook-common mate-notification-daemon mate-notification-daemon-common mate-power-manager mate-power-manager-common
  mate-screensaver mate-screensaver-common mate-sensors-applet mate-sensors-applet-common mate-sensors-applet-nvidia mate-system-monitor
  mate-system-monitor-common mate-terminal mate-terminal-common mate-user-share mate-user-share-common mate-utils mate-utils-common maxima
  maxima-doc maxima-share mozo nano pluma pluma-common pluma-dev pluma-doc plymouth-theme-ubuntu-mate-logo plymouth-theme-ubuntu-mate-text
  python-caja-common python3-caja python3-distro-info python3-macaroonbakery qemu-block-extra qemu-kvm qemu-system-common qemu-system-data
  qemu-system-gui qemu-system-x86 qemu-utils ubuntu-mate-artwork ubuntu-mate-default-settings ubuntu-mate-icon-themes
  ubuntu-mate-lightdm-theme ubuntu-mate-live-settings ubuntu-mate-themes ubuntu-mate-wallpapers ubuntu-mate-wallpapers-artful
  ubuntu-mate-wallpapers-bionic ubuntu-mate-wallpapers-common ubuntu-mate-wallpapers-complete ubuntu-mate-wallpapers-cosmic
  ubuntu-mate-wallpapers-disco ubuntu-mate-wallpapers-eoan ubuntu-mate-wallpapers-legacy ubuntu-mate-wallpapers-photos
  ubuntu-mate-wallpapers-utopic ubuntu-mate-wallpapers-vivid ubuntu-mate-wallpapers-wily ubuntu-mate-wallpapers-xenial
  ubuntu-mate-wallpapers-yakkety ubuntu-mate-wallpapers-zesty umbrello
136 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 215 MB of archives.
After this operation, 12,8 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-common all 1.24.0-1ubuntu1 [17,0 kB]
...
Get:139 http://archive.ubuntu.com/ubuntu focal/universe amd64 mate-dock-applet amd64 20.04.0-0ubuntu1 [91,8 kB]
Fetched 215 MB in 4min 4s (882 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 961594 files and directories currently installed.)
Preparing to unpack .../000-mate-common_1.24.0-1ubuntu1_all.deb ...
Unpacking mate-common (1.24.0-1ubuntu1) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../001-libdevmapper1.02.1_2%3a1.02.167-1ubuntu1_amd64.deb ...
Unpacking libdevmapper1.02.1:amd64 (2:1.02.167-1ubuntu1) over (2:1.02.155-2ubuntu8) ...
Preparing to unpack .../002-dmsetup_2%3a1.02.167-1ubuntu1_amd64.deb ...
Unpacking dmsetup (2:1.02.167-1ubuntu1) over (2:1.02.155-2ubuntu8) ...
Preparing to unpack .../003-gir1.2-freedesktop_1.62.0-5ubuntu1_amd64.deb ...
Unpacking gir1.2-freedesktop:amd64 (1.62.0-5ubuntu1) over (1.62.0-4ubuntu3) ...
Preparing to unpack .../004-libgirepository-1.0-1_1.62.0-5ubuntu1_amd64.deb ...
Unpacking libgirepository-1.0-1:amd64 (1.62.0-5ubuntu1) over (1.62.0-4ubuntu3) ...
Preparing to unpack .../005-gir1.2-glib-2.0_1.62.0-5ubuntu1_amd64.deb ...
Unpacking gir1.2-glib-2.0:amd64 (1.62.0-5ubuntu1) over (1.62.0-4ubuntu3) ...
Preparing to unpack .../006-iproute2_5.5.0-1ubuntu1_amd64.deb ...
Unpacking iproute2 (5.5.0-1ubuntu1) over (5.2.0-1ubuntu3) ...
Preparing to unpack .../007-initramfs-tools_0.133ubuntu15_all.deb ...
Unpacking initramfs-tools (0.133ubuntu15) over (0.133ubuntu14) ...
Preparing to unpack .../008-initramfs-tools-core_0.133ubuntu15_all.deb ...
Unpacking initramfs-tools-core (0.133ubuntu15) over (0.133ubuntu14) ...
Preparing to unpack .../009-initramfs-tools-bin_0.133ubuntu15_amd64.deb ...
Unpacking initramfs-tools-bin (0.133ubuntu15) over (0.133ubuntu14) ...
Preparing to unpack .../010-isc-dhcp-client_4.4.1-2.1ubuntu1_amd64.deb ...
Unpacking isc-dhcp-client (4.4.1-2.1ubuntu1) over (4.4.1-2ubuntu6) ...
Preparing to unpack .../011-isc-dhcp-common_4.4.1-2.1ubuntu1_amd64.deb ...
Unpacking isc-dhcp-common (4.4.1-2.1ubuntu1) over (4.4.1-2ubuntu6) ...
Preparing to unpack .../012-nano_4.8-1_amd64.deb ...
Unpacking nano (4.8-1) over (4.7-2) ...
Preparing to unpack .../013-python3-distro-info_0.23ubuntu1_all.deb ...
Unpacking python3-distro-info (0.23ubuntu1) over (0.22ubuntu1) ...
Preparing to unpack .../014-atril-common_1.24.0-0ubuntu1_all.deb ...
Unpacking atril-common (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../015-libatrildocument-dev_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libatrildocument-dev (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../016-libatrilview-dev_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libatrilview-dev (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../017-gir1.2-atrilview-1.5.0_1.24.0-0ubuntu1_amd64.deb ...
Unpacking gir1.2-atrilview-1.5.0 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../018-gir1.2-atrildocument-1.5.0_1.24.0-0ubuntu1_amd64.deb ...
Unpacking gir1.2-atrildocument-1.5.0 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../019-atril_1.24.0-0ubuntu1_amd64.deb ...
Unpacking atril (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../020-libatrilview3_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libatrilview3 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../021-libatrildocument3_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libatrildocument3 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../022-libdevmapper-event1.02.1_2%3a1.02.167-1ubuntu1_amd64.deb ...
Unpacking libdevmapper-event1.02.1:amd64 (2:1.02.167-1ubuntu1) over (2:1.02.155-2ubuntu8) ...
Preparing to unpack .../023-liblvm2cmd2.03_2.03.07-1ubuntu1_amd64.deb ...
Unpacking liblvm2cmd2.03:amd64 (2.03.07-1ubuntu1) over (2.03.02-2ubuntu8) ...
Preparing to unpack .../024-dmeventd_2%3a1.02.167-1ubuntu1_amd64.deb ...
Unpacking dmeventd (2:1.02.167-1ubuntu1) over (2:1.02.155-2ubuntu8) ...
Preparing to unpack .../025-dnsmasq-base_2.80-1.1ubuntu1_amd64.deb ...
Unpacking dnsmasq-base (2.80-1.1ubuntu1) over (2.80-1ubuntu4) ...
Preparing to unpack .../026-engrampa_1.24.0-0ubuntu1_amd64.deb ...
Unpacking engrampa (1.24.0-0ubuntu1) over (1.22.3-1) ...
Preparing to unpack .../027-engrampa-common_1.24.0-0ubuntu1_all.deb ...
Unpacking engrampa-common (1.24.0-0ubuntu1) over (1.22.3-1) ...
Preparing to unpack .../028-fwupd-signed_1.21+1.3.8-1_amd64.deb ...
Unpacking fwupd-signed (1.21+1.3.8-1) over (1.20+1.3.7-3) ...
Preparing to unpack .../029-libfwupd2_1.3.8-1_amd64.deb ...
Unpacking libfwupd2:amd64 (1.3.8-1) over (1.3.7-3) ...
Preparing to unpack .../030-libfwupdplugin1_1.3.8-1_amd64.deb ...
Unpacking libfwupdplugin1:amd64 (1.3.8-1) over (1.3.7-3) ...
Preparing to unpack .../031-fwupd_1.3.8-1_amd64.deb ...
Unpacking fwupd (1.3.8-1) over (1.3.7-3) ...
Preparing to unpack .../032-pluma-common_1.24.0-0ubuntu1_all.deb ...
Unpacking pluma-common (1.24.0-0ubuntu1) over (1.22.2-1ubuntu2) ...
Preparing to unpack .../033-pluma_1.24.0-0ubuntu1_amd64.deb ...
Unpacking pluma (1.24.0-0ubuntu1) over (1.22.2-1ubuntu2) ...
Preparing to unpack .../034-gir1.2-pluma-1.0_1.24.0-0ubuntu1_amd64.deb ...
Unpacking gir1.2-pluma-1.0 (1.24.0-0ubuntu1) over (1.22.2-1ubuntu2) ...
Preparing to unpack .../035-pluma-dev_1.24.0-0ubuntu1_amd64.deb ...
Unpacking pluma-dev (1.24.0-0ubuntu1) over (1.22.2-1ubuntu2) ...
Preparing to unpack .../036-jekyll_3.8.3+dfsg-8_all.deb ...
Unpacking jekyll (3.8.3+dfsg-8) over (3.8.3+dfsg-6) ...
Preparing to unpack .../037-k3b_19.12.2-2ubuntu1_amd64.deb ...
Unpacking k3b (19.12.2-2ubuntu1) over (19.12.2-0ubuntu1) ...
Preparing to unpack .../038-libk3b7-extracodecs_19.12.2-2ubuntu1_amd64.deb ...
Unpacking libk3b7-extracodecs (19.12.2-2ubuntu1) over (19.12.2-0ubuntu1) ...
Preparing to unpack .../039-k3b-data_19.12.2-2ubuntu1_all.deb ...
Unpacking k3b-data (19.12.2-2ubuntu1) over (19.12.2-0ubuntu1) ...
Preparing to unpack .../040-libk3b7_19.12.2-2ubuntu1_amd64.deb ...
Unpacking libk3b7 (19.12.2-2ubuntu1) over (19.12.2-0ubuntu1) ...
Preparing to unpack .../041-k3b-i18n_19.12.2-2ubuntu1_all.deb ...
Unpacking k3b-i18n (19.12.2-2ubuntu1) over (19.12.2-0ubuntu1) ...
Preparing to unpack .../042-kdevelop-data_4%3a5.5.0-2_all.deb ...
Unpacking kdevelop-data (4:5.5.0-2) over (4:5.4.6-2) ...
Selecting previously unselected package kdevelop55-libs.
Preparing to unpack .../043-kdevelop55-libs_4%3a5.5.0-2_amd64.deb ...
Unpacking kdevelop55-libs (4:5.5.0-2) ...
Preparing to unpack .../044-kdevelop_4%3a5.5.0-2_amd64.deb ...
Unpacking kdevelop (4:5.5.0-2) over (4:5.4.6-2) ...
Preparing to unpack .../045-libdistro-info-perl_0.23ubuntu1_all.deb ...
Unpacking libdistro-info-perl (0.23ubuntu1) over (0.22ubuntu1) ...
Preparing to unpack .../046-mate-sensors-applet-nvidia_1.24.0-0ubuntu2_amd64.deb ...
Unpacking mate-sensors-applet-nvidia (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../047-mate-sensors-applet_1.24.0-0ubuntu2_amd64.deb ...
Unpacking mate-sensors-applet (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../048-mate-sensors-applet-common_1.24.0-0ubuntu2_all.deb ...
Unpacking mate-sensors-applet-common (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../049-libmate-sensors-applet-plugin-dev_1.24.0-0ubuntu2_amd64.deb ...
Unpacking libmate-sensors-applet-plugin-dev (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../050-libmate-sensors-applet-plugin0_1.24.0-0ubuntu2_amd64.deb ...
Unpacking libmate-sensors-applet-plugin0 (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../051-mate-control-center-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-control-center-common (1.24.0-0ubuntu1) over (1.22.2-0ubuntu3) ...
Preparing to unpack .../052-libmate-window-settings-dev_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libmate-window-settings-dev:amd64 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu3) ...
Preparing to unpack .../053-mate-control-center_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-control-center (1.24.0-0ubuntu1) over (1.22.2-0ubuntu3) ...
Preparing to unpack .../054-libmate-window-settings1_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libmate-window-settings1:amd64 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu3) ...
Preparing to unpack .../055-libmate-slab0_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libmate-slab0:amd64 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu3) ...
Preparing to unpack .../056-mate-utils-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-utils-common (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../057-libmatedict-dev_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libmatedict-dev (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../058-libmatedict6_1.24.0-0ubuntu1_amd64.deb ...
Unpacking libmatedict6 (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../059-mate-utils_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-utils (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../060-libmysqlclient21_8.0.19-0ubuntu3_i386.deb ...
De-configuring libmysqlclient21:amd64 (8.0.19-0ubuntu2) ...
Unpacking libmysqlclient21:i386 (8.0.19-0ubuntu3) over (8.0.19-0ubuntu2) ...
Preparing to unpack .../061-libmysqlclient21_8.0.19-0ubuntu3_amd64.deb ...
Unpacking libmysqlclient21:amd64 (8.0.19-0ubuntu3) over (8.0.19-0ubuntu2) ...
Preparing to unpack .../062-libvirt-daemon-driver-qemu_6.0.0-0ubuntu3_amd64.deb ...
Unpacking libvirt-daemon-driver-qemu (6.0.0-0ubuntu3) over (6.0.0-0ubuntu2) ...
Preparing to unpack .../063-libvirt-daemon-driver-storage-rbd_6.0.0-0ubuntu3_amd64.deb ...
Unpacking libvirt-daemon-driver-storage-rbd (6.0.0-0ubuntu3) over (6.0.0-0ubuntu2) ...
Preparing to unpack .../064-libvirt-daemon-system_6.0.0-0ubuntu3_amd64.deb ...
Unpacking libvirt-daemon-system (6.0.0-0ubuntu3) over (6.0.0-0ubuntu2) ...
Preparing to unpack .../065-libvirt-clients_6.0.0-0ubuntu3_amd64.deb ...
Unpacking libvirt-clients (6.0.0-0ubuntu3) over (6.0.0-0ubuntu2) ...
Preparing to unpack .../066-libvirt0_6.0.0-0ubuntu3_amd64.deb ...
Unpacking libvirt0:amd64 (6.0.0-0ubuntu3) over (6.0.0-0ubuntu2) ...
Preparing to unpack .../067-libvirt-daemon_6.0.0-0ubuntu3_amd64.deb ...
Unpacking libvirt-daemon (6.0.0-0ubuntu3) over (6.0.0-0ubuntu2) ...
Preparing to unpack .../068-libvirt-daemon-system-systemd_6.0.0-0ubuntu3_amd64.deb ...
Unpacking libvirt-daemon-system-systemd (6.0.0-0ubuntu3) over (6.0.0-0ubuntu2) ...
Selecting previously unselected package libxentoolcore1:amd64.
Preparing to unpack .../069-libxentoolcore1_4.11.3+24-g14b62ab3e5-1ubuntu1_amd64.deb ...
Unpacking libxentoolcore1:amd64 (4.11.3+24-g14b62ab3e5-1ubuntu1) ...
Preparing to unpack .../070-libxenstore3.0_4.11.3+24-g14b62ab3e5-1ubuntu1_amd64.deb ...
Unpacking libxenstore3.0:amd64 (4.11.3+24-g14b62ab3e5-1ubuntu1) over (4.9.2-0ubuntu7) ...
Preparing to unpack .../071-libxmlgraphics-commons-java_2.4-1_all.deb ...
Unpacking libxmlgraphics-commons-java (2.4-1) over (2.3-1) ...
Preparing to unpack .../072-lvm2_2.03.07-1ubuntu1_amd64.deb ...
Failed to stop lvm2-lvmetad.service: Unit lvm2-lvmetad.service not loaded.
invoke-rc.d: initscript lvm2-lvmetad, action "stop" failed.
Unpacking lvm2 (2.03.07-1ubuntu1) over (2.03.02-2ubuntu8) ...
Preparing to unpack .../073-mate-applets_1.24.0-0ubuntu2_amd64.deb ...
Unpacking mate-applets (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../074-mate-applets-common_1.24.0-0ubuntu2_all.deb ...
Unpacking mate-applets-common (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../075-mate-desktop-environment-extra_1.24.0+0ubuntu1_all.deb ...
Unpacking mate-desktop-environment-extra (1.24.0+0ubuntu1) over (1.22.0+2ubuntu2) ...
Preparing to unpack .../076-mate-desktop-environment-extras_1.24.0+0ubuntu1_all.deb ...
Unpacking mate-desktop-environment-extras (1.24.0+0ubuntu1) over (1.22.0+2ubuntu2) ...
Preparing to unpack .../077-mate-core_1.24.0+0ubuntu1_all.deb ...
Unpacking mate-core (1.24.0+0ubuntu1) over (1.22.0+2ubuntu2) ...
Preparing to unpack .../078-mate-desktop-environment-core_1.24.0+0ubuntu1_all.deb ...
Unpacking mate-desktop-environment-core (1.24.0+0ubuntu1) over (1.22.0+2ubuntu2) ...
Preparing to unpack .../079-mate-desktop-environment_1.24.0+0ubuntu1_all.deb ...
Unpacking mate-desktop-environment (1.24.0+0ubuntu1) over (1.22.0+2ubuntu2) ...
Preparing to unpack .../080-mate-notification-daemon_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-notification-daemon (1.24.0-0ubuntu1) over (1.22.1-0ubuntu1) ...
Preparing to unpack .../081-mate-notification-daemon-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-notification-daemon-common (1.24.0-0ubuntu1) over (1.22.1-0ubuntu1) ...
Preparing to unpack .../082-mate-terminal_1.24.0-0ubuntu2_amd64.deb ...
Unpacking mate-terminal (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../083-mate-terminal-common_1.24.0-0ubuntu2_all.deb ...
Unpacking mate-terminal-common (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../084-mate-media_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-media (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../085-mate-media-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-media-common (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../086-mate-netbook_1.24.0-0ubuntu2_amd64.deb ...
Unpacking mate-netbook (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../087-mate-netbook-common_1.24.0-0ubuntu2_all.deb ...
Unpacking mate-netbook-common (1.24.0-0ubuntu2) over (1.24.0-0ubuntu1) ...
Preparing to unpack .../088-mate-power-manager_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-power-manager (1.24.0-0ubuntu1) over (1.22.2-0ubuntu2) ...
Preparing to unpack .../089-mate-power-manager-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-power-manager-common (1.24.0-0ubuntu1) over (1.22.2-0ubuntu2) ...
Preparing to unpack .../090-mate-screensaver_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-screensaver (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../091-mate-screensaver-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-screensaver-common (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../092-mate-system-monitor-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-system-monitor-common (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../093-mate-system-monitor_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-system-monitor (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../094-mate-user-share_1.24.0-0ubuntu1_amd64.deb ...
Unpacking mate-user-share (1.24.0-0ubuntu1) over (1.22.1-1.1) ...
Preparing to unpack .../095-mate-user-share-common_1.24.0-0ubuntu1_all.deb ...
Unpacking mate-user-share-common (1.24.0-0ubuntu1) over (1.22.1-1.1) ...
Preparing to unpack .../096-maxima_5.43.2-2_amd64.deb ...
Unpacking maxima (5.43.2-2) over (5.43.0-3) ...
Preparing to unpack .../097-maxima-doc_5.43.2-2_all.deb ...
Unpacking maxima-doc (5.43.2-2) over (5.43.0-3) ...
Preparing to unpack .../098-maxima-share_5.43.2-2_all.deb ...
Unpacking maxima-share (5.43.2-2) over (5.43.0-3) ...
Preparing to unpack .../099-mozo_1.24.0-0ubuntu1_all.deb ...
Unpacking mozo (1.24.0-0ubuntu1) over (1.22.2-0ubuntu1) ...
Preparing to unpack .../100-pluma-doc_1.24.0-0ubuntu1_all.deb ...
Unpacking pluma-doc (1.24.0-0ubuntu1) over (1.22.2-1ubuntu2) ...
Preparing to unpack .../101-plymouth-theme-ubuntu-mate-logo_20.04.0_all.deb ...
Unpacking plymouth-theme-ubuntu-mate-logo (20.04.0) over (19.10.10) ...
Preparing to unpack .../102-plymouth-theme-ubuntu-mate-text_20.04.0_all.deb ...
Unpacking plymouth-theme-ubuntu-mate-text (20.04.0) over (19.10.10) ...
Preparing to unpack .../103-python3-caja_1.24.0-1ubuntu1_amd64.deb ...
Unpacking python3-caja (1.24.0-1ubuntu1) over (1.23.0-1build1) ...
Preparing to unpack .../104-python-caja-common_1.24.0-1ubuntu1_all.deb ...
Unpacking python-caja-common (1.24.0-1ubuntu1) over (1.23.0-1build1) ...
Preparing to unpack .../105-python3-macaroonbakery_1.3.1-1_all.deb ...
Unpacking python3-macaroonbakery (1.3.1-1) over (1.3.0-1) ...
Preparing to unpack .../106-qemu-system-common_1%3a4.2-3ubuntu1_amd64.deb ...
Unpacking qemu-system-common (1:4.2-3ubuntu1) over (1:4.2-1ubuntu2) ...
Preparing to unpack .../107-qemu-utils_1%3a4.2-3ubuntu1_amd64.deb ...
Unpacking qemu-utils (1:4.2-3ubuntu1) over (1:4.2-1ubuntu2) ...
Preparing to unpack .../108-qemu-block-extra_1%3a4.2-3ubuntu1_amd64.deb ...
Unpacking qemu-block-extra:amd64 (1:4.2-3ubuntu1) over (1:4.2-1ubuntu2) ...
Preparing to unpack .../109-qemu-system-data_1%3a4.2-3ubuntu1_all.deb ...
Unpacking qemu-system-data (1:4.2-3ubuntu1) over (1:4.2-1ubuntu2) ...
Preparing to unpack .../110-qemu-kvm_1%3a4.2-3ubuntu1_amd64.deb ...
Unpacking qemu-kvm (1:4.2-3ubuntu1) over (1:4.2-1ubuntu2) ...
Preparing to unpack .../111-qemu-system-x86_1%3a4.2-3ubuntu1_amd64.deb ...
Unpacking qemu-system-x86 (1:4.2-3ubuntu1) over (1:4.2-1ubuntu2) ...
Preparing to unpack .../112-qemu-system-gui_1%3a4.2-3ubuntu1_amd64.deb ...
Unpacking qemu-system-gui (1:4.2-3ubuntu1) over (1:4.2-1ubuntu2) ...
Preparing to unpack .../113-ubuntu-mate-icon-themes_20.04.0_all.deb ...
Unpacking ubuntu-mate-icon-themes (20.04.0) over (19.10.10) ...
Preparing to unpack .../114-ubuntu-mate-themes_20.04.0_all.deb ...
Unpacking ubuntu-mate-themes (20.04.0) over (19.10.10) ...
Preparing to unpack .../115-ubuntu-mate-wallpapers-common_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-common (20.04.0) over (19.10.10) ...
Selecting previously unselected package ubuntu-mate-wallpapers-focal.
Preparing to unpack .../116-ubuntu-mate-wallpapers-focal_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-focal (20.04.0) ...
Preparing to unpack .../117-ubuntu-mate-wallpapers-photos_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-photos (20.04.0) over (19.10.10) ...
Preparing to unpack .../118-ubuntu-mate-wallpapers_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers (20.04.0) over (19.10.10) ...
Preparing to unpack .../119-ubuntu-mate-artwork_20.04.0_all.deb ...
Unpacking ubuntu-mate-artwork (20.04.0) over (19.10.10) ...
Preparing to unpack .../120-ubuntu-mate-default-settings_20.04.0_amd64.deb ...
Unpacking ubuntu-mate-default-settings (20.04.0) over (19.10.7) ...
Preparing to unpack .../121-ubuntu-mate-lightdm-theme_20.04.0_all.deb ...
Unpacking ubuntu-mate-lightdm-theme (20.04.0) over (19.10.10) ...
Preparing to unpack .../122-ubuntu-mate-live-settings_20.04.0_all.deb ...
Leaving 'diversion of /usr/share/ubiquity/pixmaps/ubuntu_installed.png to /usr/share/ubiquity/pixmaps/ubuntu_installed.png.distrib by ubuntu
-mate-live-settings'
Unpacking ubuntu-mate-live-settings (20.04.0) over (19.10.7) ...
Preparing to unpack .../123-ubuntu-mate-wallpapers-artful_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-artful (20.04.0) over (19.10.10) ...
Preparing to unpack .../124-ubuntu-mate-wallpapers-bionic_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-bionic (20.04.0) over (19.10.10) ...
Preparing to unpack .../125-ubuntu-mate-wallpapers-legacy_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-legacy (20.04.0) over (19.10.10) ...
Preparing to unpack .../126-ubuntu-mate-wallpapers-cosmic_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-cosmic (20.04.0) over (19.10.10) ...
Preparing to unpack .../127-ubuntu-mate-wallpapers-disco_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-disco (20.04.0) over (19.10.10) ...
Preparing to unpack .../128-ubuntu-mate-wallpapers-eoan_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-eoan (20.04.0) over (19.10.10) ...
Preparing to unpack .../129-ubuntu-mate-wallpapers-utopic_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-utopic (20.04.0) over (19.10.10) ...
Preparing to unpack .../130-ubuntu-mate-wallpapers-vivid_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-vivid (20.04.0) over (19.10.10) ...
Preparing to unpack .../131-ubuntu-mate-wallpapers-wily_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-wily (20.04.0) over (19.10.10) ...
Preparing to unpack .../132-ubuntu-mate-wallpapers-xenial_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-xenial (20.04.0) over (19.10.10) ...
Preparing to unpack .../133-ubuntu-mate-wallpapers-yakkety_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-yakkety (20.04.0) over (19.10.10) ...
Preparing to unpack .../134-ubuntu-mate-wallpapers-zesty_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-zesty (20.04.0) over (19.10.10) ...
Preparing to unpack .../135-ubuntu-mate-wallpapers-complete_20.04.0_all.deb ...
Unpacking ubuntu-mate-wallpapers-complete (20.04.0) over (19.10.10) ...
Preparing to unpack .../136-umbrello_4%3a19.12.2-0ubuntu2_amd64.deb ...
Unpacking umbrello (4:19.12.2-0ubuntu2) over (4:19.12.2-0ubuntu1) ...
Preparing to unpack .../137-debootstrap_1.0.117ubuntu1_all.deb ...
Unpacking debootstrap (1.0.117ubuntu1) over (1.0.116ubuntu2) ...
Preparing to unpack .../138-mate-dock-applet_20.04.0-0ubuntu1_amd64.deb ...
Unpacking mate-dock-applet (20.04.0-0ubuntu1) over (19.10.0-1ubuntu1) ...
Setting up k3b-i18n (19.12.2-2ubuntu1) ...
Setting up maxima-doc (5.43.2-2) ...
Setting up ubuntu-mate-wallpapers-artful (20.04.0) ...
Setting up libmate-sensors-applet-plugin0 (1.24.0-0ubuntu2) ...
Setting up ubuntu-mate-wallpapers-disco (20.04.0) ...
Setting up mate-common (1.24.0-1ubuntu1) ...
Setting up libmysqlclient21:amd64 (8.0.19-0ubuntu3) ...
Setting up libmysqlclient21:i386 (8.0.19-0ubuntu3) ...
Setting up debootstrap (1.0.117ubuntu1) ...
Setting up libxentoolcore1:amd64 (4.11.3+24-g14b62ab3e5-1ubuntu1) ...
Setting up gir1.2-pluma-1.0 (1.24.0-0ubuntu1) ...
Setting up k3b-data (19.12.2-2ubuntu1) ...
Setting up plymouth-theme-ubuntu-mate-logo (20.04.0) ...
FRAMEBUFFER=y
update-initramfs: deferring update (trigger activated)
Setting up ubuntu-mate-wallpapers-yakkety (20.04.0) ...
Setting up libdistro-info-perl (0.23ubuntu1) ...
Setting up mate-media-common (1.24.0-0ubuntu1) ...
Setting up qemu-system-gui (1:4.2-3ubuntu1) ...
Setting up iproute2 (5.5.0-1ubuntu1) ...
Setting up ubuntu-mate-wallpapers-zesty (20.04.0) ...
Setting up ubuntu-mate-default-settings (20.04.0) ...
Setting up libfwupd2:amd64 (1.3.8-1) ...
Setting up pluma-doc (1.24.0-0ubuntu1) ...
Setting up mate-control-center-common (1.24.0-0ubuntu1) ...
Setting up isc-dhcp-client (4.4.1-2.1ubuntu1) ...
Setting up mate-notification-daemon-common (1.24.0-0ubuntu1) ...
Setting up mate-user-share-common (1.24.0-0ubuntu1) ...
Setting up libxmlgraphics-commons-java (2.4-1) ...
Setting up kdevelop-data (4:5.5.0-2) ...
Setting up mate-power-manager-common (1.24.0-0ubuntu1) ...
Setting up ubuntu-mate-wallpapers-wily (20.04.0) ...
Setting up ubuntu-mate-live-settings (20.04.0) ...
Setting up libmatedict6 (1.24.0-0ubuntu1) ...
Setting up dnsmasq-base (2.80-1.1ubuntu1) ...
Setting up libatrildocument3 (1.24.0-0ubuntu1) ...
Setting up ubuntu-mate-wallpapers-photos (20.04.0) ...
Setting up mate-system-monitor-common (1.24.0-0ubuntu1) ...
Setting up engrampa-common (1.24.0-0ubuntu1) ...
Setting up python-caja-common (1.24.0-1ubuntu1) ...
Setting up ubuntu-mate-icon-themes (20.04.0) ...
Setting up ubuntu-mate-wallpapers-utopic (20.04.0) ...
Setting up libmate-window-settings1:amd64 (1.24.0-0ubuntu1) ...
Setting up ubuntu-mate-wallpapers-focal (20.04.0) ...
Setting up plymouth-theme-ubuntu-mate-text (20.04.0) ...
update-initramfs: deferring update (trigger activated)
Setting up ubuntu-mate-wallpapers-bionic (20.04.0) ...
Setting up mate-netbook-common (1.24.0-0ubuntu2) ...
Setting up ubuntu-mate-wallpapers-legacy (20.04.0) ...
Setting up libxenstore3.0:amd64 (4.11.3+24-g14b62ab3e5-1ubuntu1) ...
Setting up libmate-sensors-applet-plugin-dev (1.24.0-0ubuntu2) ...
Setting up libfwupdplugin1:amd64 (1.3.8-1) ...
Setting up kdevelop55-libs (4:5.5.0-2) ...
Setting up libvirt-daemon-system-systemd (6.0.0-0ubuntu3) ...
Setting up kdevelop (4:5.5.0-2) ...
Setting up maxima (5.43.2-2) ...
Setting up libatrilview3 (1.24.0-0ubuntu1) ...
Setting up qemu-system-data (1:4.2-3ubuntu1) ...
Setting up libk3b7 (19.12.2-2ubuntu1) ...
Setting up mate-utils-common (1.24.0-0ubuntu1) ...
Setting up nano (4.8-1) ...
Installing new version of config file /etc/nanorc ...
Setting up libdevmapper1.02.1:amd64 (2:1.02.167-1ubuntu1) ...
Setting up mate-sensors-applet-common (1.24.0-0ubuntu2) ...
Setting up libvirt0:amd64 (6.0.0-0ubuntu3) ...
Setting up ubuntu-mate-wallpapers-common (20.04.0) ...
Setting up mate-screensaver-common (1.24.0-0ubuntu1) ...
Installing new version of config file /etc/xdg/autostart/mate-screensaver.desktop ...
Setting up dmsetup (2:1.02.167-1ubuntu1) ...
update-initramfs: deferring update (trigger activated)
Setting up libmate-slab0:amd64 (1.24.0-0ubuntu1) ...
Setting up atril-common (1.24.0-0ubuntu1) ...
Setting up jekyll (3.8.3+dfsg-8) ...
Setting up ubuntu-mate-wallpapers-eoan (20.04.0) ...
Setting up libmatedict-dev (1.24.0-0ubuntu1) ...
Setting up libgirepository-1.0-1:amd64 (1.62.0-5ubuntu1) ...
Setting up pluma-common (1.24.0-0ubuntu1) ...
Setting up isc-dhcp-common (4.4.1-2.1ubuntu1) ...
Setting up ubuntu-mate-wallpapers-vivid (20.04.0) ...
Setting up python3-macaroonbakery (1.3.1-1) ...
/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size w
ill be used
  self.stdin = io.open(p2cwrite, 'wb', bufsize)
Setting up mate-media (1.24.0-0ubuntu1) ...
Setting up ubuntu-mate-wallpapers-cosmic (20.04.0) ...
Setting up ubuntu-mate-wallpapers-xenial (20.04.0) ...
Setting up mate-applets-common (1.24.0-0ubuntu2) ...
Setting up python3-distro-info (0.23ubuntu1) ...
/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size w
ill be used
  self.stdin = io.open(p2cwrite, 'wb', bufsize)
Setting up qemu-block-extra:amd64 (1:4.2-3ubuntu1) ...
Setting up fwupd (1.3.8-1) ...
fwupd-offline-update.service is a disabled or a static unit not running, not starting it.
fwupd-refresh.service is a disabled or a static unit not running, not starting it.
fwupd.service is a disabled or a static unit not running, not starting it.
Setting up mate-terminal-common (1.24.0-0ubuntu2) ...
Setting up initramfs-tools-bin (0.133ubuntu15) ...
Setting up ubuntu-mate-wallpapers (20.04.0) ...
Setting up qemu-system-common (1:4.2-3ubuntu1) ...
Setting up ubuntu-mate-wallpapers-complete (20.04.0) ...
Setting up libdevmapper-event1.02.1:amd64 (2:1.02.167-1ubuntu1) ...
Setting up ubuntu-mate-themes (20.04.0) ...
Setting up libmate-window-settings-dev:amd64 (1.24.0-0ubuntu1) ...
Setting up libvirt-clients (6.0.0-0ubuntu3) ...
Setting up qemu-system-x86 (1:4.2-3ubuntu1) ...
Setting up fwupd-signed (1.21+1.3.8-1) ...
Setting up python3-caja (1.24.0-1ubuntu1) ...
Setting up umbrello (4:19.12.2-0ubuntu2) ...
Setting up maxima-share (5.43.2-2) ...
Setting up k3b (19.12.2-2ubuntu1) ...
Setting up libk3b7-extracodecs (19.12.2-2ubuntu1) ...
Setting up atril (1.24.0-0ubuntu1) ...
Setting up gir1.2-glib-2.0:amd64 (1.62.0-5ubuntu1) ...
Setting up qemu-utils (1:4.2-3ubuntu1) ...
Setting up initramfs-tools-core (0.133ubuntu15) ...
Setting up ubuntu-mate-lightdm-theme (20.04.0) ...
Setting up mate-dock-applet (20.04.0-0ubuntu1) ...
Setting up gir1.2-freedesktop:amd64 (1.62.0-5ubuntu1) ...
Setting up mozo (1.24.0-0ubuntu1) ...
/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size w
ill be used
  self.stdin = io.open(p2cwrite, 'wb', bufsize)
Setting up initramfs-tools (0.133ubuntu15) ...
update-initramfs: deferring update (trigger activated)
Setting up ubuntu-mate-artwork (20.04.0) ...
Setting up qemu-kvm (1:4.2-3ubuntu1) ...
Setting up gir1.2-atrildocument-1.5.0 (1.24.0-0ubuntu1) ...
Setting up gir1.2-atrilview-1.5.0 (1.24.0-0ubuntu1) ...
Setting up libatrildocument-dev (1.24.0-0ubuntu1) ...
Setting up libatrilview-dev (1.24.0-0ubuntu1) ...
Setting up liblvm2cmd2.03:amd64 (2.03.07-1ubuntu1) ...
Setting up dmeventd (2:1.02.167-1ubuntu1) ...
dm-event.service is a disabled or a static unit not running, not starting it.
Setting up libvirt-daemon (6.0.0-0ubuntu3) ...
Setting up libvirt-daemon-driver-storage-rbd (6.0.0-0ubuntu3) ...
Setting up lvm2 (2.03.07-1ubuntu1) ...
Installing new version of config file /etc/lvm/lvm.conf ...
Installing new version of config file /etc/lvm/profile/vdo-small.profile ...
update-initramfs: deferring update (trigger activated)
Setting up libvirt-daemon-driver-qemu (6.0.0-0ubuntu3) ...
Setting up libvirt-daemon-system (6.0.0-0ubuntu3) ...
Installing new version of config file /etc/apparmor.d/usr.sbin.libvirtd ...
Job failed. See "journalctl -xe" for details.
virtlockd.service is a disabled or a static unit, not starting it.
virtlogd.service is a disabled or a static unit, not starting it.
Setting up libvirt-daemon dnsmasq configuration.
Processing triggers for install-info (6.7.0.dfsg.2-5) ...
Processing triggers for bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.24-1ubuntu1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for libglib2.0-0:i386 (2.63.3-3) ...
Processing triggers for libglib2.0-0:amd64 (2.63.3-3) ...
Setting up mate-netbook (1.24.0-0ubuntu2) ...
Processing triggers for libc-bin (2.30-0ubuntu3) ...
Processing triggers for systemd (244.2-1ubuntu1) ...
Setting up pluma (1.24.0-0ubuntu1) ...
Processing triggers for man-db (2.9.0-2) ...
Setting up pluma-dev (1.24.0-0ubuntu1) ...
Setting up mate-sensors-applet (1.24.0-0ubuntu2) ...
Setting up mate-control-center (1.24.0-0ubuntu1) ...
Processing triggers for dbus (1.12.16-2ubuntu2) ...
Processing triggers for shared-mime-info (1.10-1) ...
Setting up mate-power-manager (1.24.0-0ubuntu1) ...
Installing new version of config file /etc/xdg/autostart/mate-power-manager.desktop ...
Setting up mate-utils (1.24.0-0ubuntu1) ...
Setting up mate-system-monitor (1.24.0-0ubuntu1) ...
Setting up mate-notification-daemon (1.24.0-0ubuntu1) ...
Setting up mate-screensaver (1.24.0-0ubuntu1) ...
Setting up mate-user-share (1.24.0-0ubuntu1) ...
Installing new version of config file /etc/xdg/autostart/mate-user-share-obexftp.desktop ...
Installing new version of config file /etc/xdg/autostart/mate-user-share-obexpush.desktop ...
Installing new version of config file /etc/xdg/autostart/mate-user-share-webdav.desktop ...
Setting up mate-applets (1.24.0-0ubuntu2) ...
Setting up engrampa (1.24.0-0ubuntu1) ...
Setting up mate-terminal (1.24.0-0ubuntu2) ...
Setting up mate-sensors-applet-nvidia (1.24.0-0ubuntu2) ...
Setting up mate-desktop-environment-core (1.24.0+0ubuntu1) ...
Setting up mate-desktop-environment (1.24.0+0ubuntu1) ...
Setting up mate-core (1.24.0+0ubuntu1) ...
Setting up mate-desktop-environment-extras (1.24.0+0ubuntu1) ...
Setting up mate-desktop-environment-extra (1.24.0+0ubuntu1) ...
Processing triggers for initramfs-tools (0.133ubuntu15) ...
update-initramfs: Generating /boot/initrd.img-5.4.0-14-generic
$
```

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: libpython3.8-minimal 3.8.2~rc1-1ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-14.17-generic 5.4.18
Uname: Linux 5.4.0-14-generic x86_64
ApportVersion: 2.20.11-0ubuntu16
Architecture: amd64
CurrentDesktop: MATE
Date: Sat Feb 15 14:35:42 2020
InstallationDate: Installed on 2019-11-09 (97 days ago)
InstallationMedia: Ubuntu-MATE 19.10 "Eoan Ermine" - Release amd64 (20191017)
SourcePackage: python3.8
UpgradeStatus: Upgraded to focal on 2019-11-09 (97 days ago)

Revision history for this message
Norbert (nrbrtx) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in aptdaemon (Ubuntu):
status: New → Confirmed
Changed in python-apt (Ubuntu):
status: New → Confirmed
Changed in python3.8 (Ubuntu):
status: New → Confirmed
Revision history for this message
Julian Andres Klode (juliank) wrote :

Deleting unrelated tasks.

no longer affects: python-apt (Ubuntu)
no longer affects: aptdaemon (Ubuntu)
Revision history for this message
Сидоренко Михаил Павлович (Sidorenko Mikhail Pavlovich) (sg-muwa) wrote :

My pip does not work.

$ pip --version
Traceback (most recent call last):
  File "/home/sgmuwa/.local/bin/pip", line 6, in <module>
    from pip._internal.main import main
ModuleNotFoundError: No module named 'pip._internal.main'
$ sudo dpkg-reconfigure python3-pip
/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdin = io.open(p2cwrite, 'wb', bufsize)

I found instruction: https://qastack.ru/ubuntu/1025189/pip-is-not-working-importerror-no-module-named-pip-internal

$ curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py
$ python3 get-pip.py --force-reinstall

And pip work nice:

$ pip --version
pip 20.0.2 from /home/sgmuwa/.local/lib/python3.8/site-packages/pip (python 3.8)

But bug is still exist:
$ sudo dpkg-reconfigure python3-pip
/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdin = io.open(p2cwrite, 'wb', bufsize)

Revision history for this message
Frank Heimes (fheimes) wrote :

This bug has an "amd64" tag, but this affects other platforms, too (like ppc64el and s390x).

Revision history for this message
Matthias Klose (doko) wrote :

this should be fixed in the packages producing that warning

Changed in python3.8 (Ubuntu):
status: Confirmed → Won't Fix
Revision history for this message
Khairul Aizat Kamarudzzaman (fenris) wrote :

I can confirmed this bug too in focal fresh installed

Revision history for this message
Anaggh S (anaggh) wrote :

Occurs for `drawing` package too.

```
$ sudo apt install drawing
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  drawing
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,129 kB of archives.
After this operation, 1,786 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu focal/universe amd64 drawing amd64 0.4.2-1 [1,129 kB]
Fetched 1,129 kB in 2s (699 kB/s)
Selecting previously unselected package drawing.
(Reading database ... 325026 files and directories currently installed.)
Preparing to unpack .../drawing_0.4.2-1_amd64.deb ...
Unpacking drawing (0.4.2-1) ...
Setting up drawing (0.4.2-1) ...
/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdin = io.open(p2cwrite, 'wb', bufsize)
/usr/lib/python3/dist-packages/drawing/options_manager.py:48: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if action.get_state_type().dup_string() is 's':
/usr/lib/python3/dist-packages/drawing/properties.py:91: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if cairo_format is 'ARGB32':
/usr/lib/python3/dist-packages/drawing/properties.py:120: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if (self.set_format_label() is not 'ARGB32') or (not visible):
/usr/lib/python3/dist-packages/drawing/selection_manager.py:71: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if pts[1] is not ():
/usr/lib/python3/dist-packages/drawing/selection_manager.py:139: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if pts[1] is not ():
/usr/lib/python3/dist-packages/drawing/selection_manager.py:203: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if pts[1] is not ():
/usr/lib/python3/dist-packages/drawing/selection_manager.py:265: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if pts[1] is not ():
/usr/lib/python3/dist-packages/drawing/tool_experiment.py:285: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if pts[1] is ():
/usr/lib/python3/dist-packages/drawing/tool_experiment.py:324: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if pts[1] is ():
/usr/lib/python3/dist-packages/drawing/tool_experiment.py:372: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if pts[1] is ():
/usr/lib/python3/dist-packages/drawing/tool_select.py:276: SyntaxWarning: "is not" with a literal. Did you mean "!="?
  if pts[1] is not ():
/usr/lib/python3/dist-packages/drawing/utilities.py:195: SyntaxWarning: "is" with a literal. Did you mean "=="?
  if pts[1] is ():
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.63.3-3) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu1) ...
$
```

Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

We can reproduce following command:

$ sudo py3compile -p python3-apport -V 3.0-
/usr/lib/python3.8/subprocess.py:838: RuntimeWarning: line buffering (buffering=1) isn't supported in binary mode, the default buffer size will be used
  self.stdin = io.open(p2cwrite, 'wb', bufsize)

py3comipe set "bufsize=1" for subprocess.Popen(): https://salsa.debian.org/cpython-team/python3-defaults/blob/master/py3compile#L132-133

    process = Popen(cmd, bufsize=1, shell=True,
                    stdin=PIPE, close_fds=True)

However newer python (from 3.8?) warn on buffering=1.

* https://github.com/python/cpython/commit/a2670565d8f5c502388378aba1fe73023fd8c8d4
* https://bugs.python.org/issue32236

Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

sorry, i commented to wrong ticket.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python3-defaults (Ubuntu):
status: New → Confirmed
Eric Desrochers (slashd)
tags: added: champagne
Steve Langasek (vorlon)
tags: removed: champagne
tags: added: id-5e6a590e09cc81526b48641d
Revision history for this message
Matthias Klose (doko) wrote :

stuck in -proposed

Changed in python3.8 (Ubuntu Focal):
status: Won't Fix → In Progress
Changed in python3-defaults (Ubuntu Focal):
status: Confirmed → In Progress
Changed in python3.8 (Ubuntu Focal):
status: In Progress → Invalid
Changed in python3-defaults (Debian):
status: Unknown → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3-defaults - 3.8.2-0ubuntu2

---------------
python3-defaults (3.8.2-0ubuntu2) focal; urgency=medium

  [ Dimitri John Ledkov ]
  * Correct command-not-found XB-Cnf headers LP: #1867157:
    - Drop Extra-Commands headers not needed
    - Add XB- to ensure Visible-Pkgname actually is included in the binary
      package heders

  [ Stuart Prescott ]
  * Use unbuffered IO to pass filenames to py_compile (Closes: #953056)
    LP: #1863414

 -- Dimitri John Ledkov <email address hidden> Fri, 13 Mar 2020 12:20:20 +0000

Changed in python3-defaults (Ubuntu Focal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.