SRU: backport Python 3.8 to bionic

Bug #1835737 reported by Matthias Klose on 2019-07-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3-stdlib-extensions (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
python3.8 (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned

Bug Description

SRU: backport Python 3.8 to bionic. This is done to get a wider audience for 3.8 testing, helping to prepare the transition of the default Python3 to 3.8 in Ubuntu 20.04 LTS.

The new packages are not used, so there is no regression potential for the new packages.

Changed packages are the binary packages built from the python3-stdlib-extensions source package, where the 3.8 files are added. No change for the files shipped for 3.6 and 3.7. The only downside is that the packages sizes increase by ~50% by adding the files. However these packages are not part of any minimal setup, so this seems to be bearable.

The python3.8-doc package isn't built, because a newer sphinx version that the one in bionic is required.

Matthias Klose (doko) on 2019-07-09
no longer affects: python-docs-theme (Ubuntu)
description: updated
Matthias Klose (doko) wrote :

and we should do that for disco as well, replacing the alpha3 there

Changed in python3.8 (Ubuntu):
status: New → Fix Released
Changed in python3-stdlib-extensions (Ubuntu):
status: New → Fix Committed
Changed in python3-stdlib-extensions (Ubuntu):
status: Fix Committed → Fix Released

Hello Matthias, or anyone else affected,

Accepted python3.8 into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.8/3.8.0-1~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python3.8 (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
Łukasz Zemczak (sil2100) wrote :

Hello Matthias, or anyone else affected,

Accepted python3-stdlib-extensions into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3-stdlib-extensions/3.7.5-1~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python3-stdlib-extensions (Ubuntu Disco):
status: New → Fix Committed

All autopkgtests for the newly accepted python3-stdlib-extensions (3.7.5-1~19.04) for disco have finished running.
The following regressions have been reported in tests triggered by the package:

thonny/3.1.1-1 (s390x)
python3.8/3.8.0~a3-2 (amd64, arm64, s390x, i386, armhf, ppc64el)
pandas/unknown (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/disco/update_excuses.html#python3-stdlib-extensions

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Hello Matthias, or anyone else affected,

Accepted python3.8 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.8/3.8.0-3~18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python3.8 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Matthias, or anyone else affected,

Accepted python3-stdlib-extensions into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3-stdlib-extensions/3.6.9-1~18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python3-stdlib-extensions (Ubuntu Bionic):
status: New → Fix Committed

All autopkgtests for the newly accepted python3-stdlib-extensions (3.6.9-1~18.04) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

yapf/0.20.1-1ubuntu1 (ppc64el)
python-virtualenv/unknown (armhf)
python-future/unknown (armhf)
pyfai/0.15.0+dfsg1-1 (i386)
python-ltfatpy/1.0.12-1 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#python3-stdlib-extensions

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Hello Matthias, or anyone else affected,

Accepted python3.8 into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.8/3.8.0-3~19.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python3.8 (Ubuntu Eoan):
status: New → Fix Committed
tags: added: verification-needed-eoan
Łukasz Zemczak (sil2100) wrote :

Hello Matthias, or anyone else affected,

Accepted python3.8 into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.8/3.8.0-3~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Matthias Klose (doko) wrote :

the packages for disco and eoan pass all their autopkg tests, testsuites look fine.

tags: added: verification-done-disco verification-done-eoan
removed: verification-needed-disco verification-needed-eoan
Matthias Klose (doko) wrote :

for bionic, the pyfai/i386 test failure is related to python2.7, which is not touched for this SRU.

Matthias Klose (doko) on 2019-11-06
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3.8 - 3.8.0-3~19.10

---------------
python3.8 (3.8.0-3~19.10) eoan-proposed; urgency=medium

  * SRU: LP: #1835737. Backport the final Python 3.8.0 release.

python3.8 (3.8.0-3) unstable; urgency=medium

  * python3.8-dev: Depend on zlib1g-dev, needed to link as an
    embedded interpreter.

python3.8 (3.8.0-2) unstable; urgency=medium

  * Fix a symlink to the shared debug library.
  * Install the python3.8d-embed pkg-config file.
  * Don't ship the python3-embed pkg-config file.

 -- Matthias Klose <email address hidden> Mon, 28 Oct 2019 17:14:01 +0100

Changed in python3.8 (Ubuntu Eoan):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for python3.8 has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package python3.8 - 3.8.0-3~19.04

---------------
python3.8 (3.8.0-3~19.04) disco-proposed; urgency=medium

  * SRU: LP: #1835737. Backport the final Python 3.8.0 release.

python3.8 (3.8.0-3) unstable; urgency=medium

  * python3.8-dev: Depend on zlib1g-dev, needed to link as an
    embedded interpreter.

python3.8 (3.8.0-2) unstable; urgency=medium

  * Fix a symlink to the shared debug library.
  * Install the python3.8d-embed pkg-config file.
  * Don't ship the python3-embed pkg-config file.

python3.8 (3.8.0-1) unstable; urgency=medium

  * Python 3.8.0 release.

python3.8 (3.8.0~rc1-3) unstable; urgency=medium

  * Apply proposed patch for issue 38368. LP: #1847036. Addresses: #941650.

python3.8 (3.8.0~rc1-2) unstable; urgency=medium

  * Python 3.8.0 release candidate 1.
  * Refresh patches.
  * Update symbols files.
  * Bump standards version.

python3.8 (3.8.0~b4-1) unstable; urgency=medium

  * Python 3.8.0 beta 4 release.

python3.8 (3.8.0~b3-1) unstable; urgency=medium

  * Python 3.8.0 beta 3 release.
  * Fix FTCBFS: (Helmut Grohne). Closes: #932077.
    + Build-Depends, when cross compiling we need python3.8.
    + Export CC, because dtrace needs it.
    + Honour DEB_BUILD_OPTIONS=nocheck more thoroughly.
    + Fix up sysconfigdata-name.diff.
  * Implement the native thread ids for the Hurd and KFreeBSD (Samuel
    Thibault). Closes: #931624.
  * Enable pgo/lto builds on arm64. Addresses: #934812.
  * Update symbols files.
  * Don't propagate lto flags to the _sysconfigdata module. Addresses: #934771.
  * d/patches/issue35998.diff: Disable TLS1.3 in the client on all platforms
    rather than just reducing the payload size (Michael Hudson-Doyle).

python3.8 (3.8.0~b2-5) unstable; urgency=high

  * Bump standards version.
  * Revert the KFreeBSD and Hurd fix for PyThread_get_thread_native_id,
    and use the implementation from Python3.7. Mark the symbol as linux only.
  * Don't encode the MACHDEP into the _sysconfigdata file name.

python3.8 (3.8.0~b2-4) unstable; urgency=medium

  * Fix the LTO build.

python3.8 (3.8.0~b2-3) unstable; urgency=medium

  * Define PY_HAVE_THREAD_NATIVE_ID for KFreeBSD and Hurd builds.
  * Fix issue #37504, building the texinfo docs (Dmitry Shachnev).
  * Enable LTO/PGO builds on some architectures.

python3.8 (3.8.0~b2-1) experimental; urgency=medium

  * Python 3.8.0 beta 2 release.
  * Refresh patches.
  * Update the symbols files.
  * Don't build the texinfo documentation, fails. See issue #37504.

python3.8 (3.8.0~b1-2) experimental; urgency=medium

  * Fix include links in python3.8-dbg.

python3.8 (3.8.0~b1-1) experimental; urgency=medium

  * Python 3.8.0 beta 1 release.
  * Refresh patches.
  * Add new importlib dependencies to python3-minimal.
  * Update symbols files.

python3.8 (3.8.0~a4-3) experimental; urgency=medium

  * Update symbols files.

python3.8 (3.8.0~a4-2) experimental; urgency=medium

  * Update to 20190514 from the trunk.
  * Fix interpreter name in the -dbg autopkg tests.
  * Enable dtrace/USDT probe support (--with-dtrace) and build-dep on
    systemtap-sdt-dev (Trent Lloyd). LP: #1818778.

python3.8 (3.8.0~a4-1) experimental; urgency=medium...

Read more...

Changed in python3.8 (Ubuntu Disco):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3.8 - 3.8.0-3~18.04

---------------
python3.8 (3.8.0-3~18.04) bionic-proposed; urgency=medium

  * SRU: LP: #1835737. Backport the final Python 3.8.0 release.
  * Don't build the -doc package, outdated sphinx version in bionic.

 -- Matthias Klose <email address hidden> Mon, 28 Oct 2019 17:14:01 +0100

Changed in python3.8 (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3-stdlib-extensions - 3.6.9-1~18.04

---------------
python3-stdlib-extensions (3.6.9-1~18.04) bionic-proposed; urgency=medium

  * SRU: LP: #1835737. Build extensions for Python 3.8.
  * Update 3.6 extensions and modules to 3.6.9.
  * Update 3.7 extensions and modules to 3.7.5.

 -- Matthias Klose <email address hidden> Mon, 28 Oct 2019 17:30:34 +0100

Changed in python3-stdlib-extensions (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3-stdlib-extensions - 3.7.5-1~19.04

---------------
python3-stdlib-extensions (3.7.5-1~19.04) disco-proposed; urgency=medium

  * SRU: LP: #1835737. Backport the final Python 3.8.0 release.
  * Also update the 3.7 modules to 3.7.5.

python3-stdlib-extensions (3.7.5-1ubuntu1) eoan; urgency=medium

  * SRU: LP: #1835738, to build the final 3.7.5 release for eoan,
    just introducing a delta for the SRU process.

python3-stdlib-extensions (3.7.5-1) unstable; urgency=medium

  * Update 3.7 extensions and modules to 3.7.5 release.
  * Update 3.8 extensions and modules to 3.8.0 release.

python3-stdlib-extensions (3.7.5~rc1-1) unstable; urgency=medium

  * Update 3.7 extensions and modules to 3.7.5 release candidate 1.
  * Update 3.8 extensions and modules to 3.8.0 release candidate 1.
  * Bump standards version.

python3-stdlib-extensions (3.7.4-3) unstable; urgency=medium

  * Don't encode the MACHDEP into the _sysconfigdata file name.
  * Tighten build dependency on python3.8.

python3-stdlib-extensions (3.7.4-1) unstable; urgency=medium

  * Update 3.7 extensions and modules to the 3.7.4 release.
  * Silent some lintian warnings.
  * Bump standards version.

python3-stdlib-extensions (3.7.4~rc2-1) unstable; urgency=medium

  * Update 3.7 extensions and modules to 3.7.4 release candidate 2.
  * Add 3.8 extensions and modules for 3.8.0~b2.
  * Refresh patches.

 -- Matthias Klose <email address hidden> Tue, 15 Oct 2019 18:33:22 +0200

Changed in python3-stdlib-extensions (Ubuntu Disco):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers