Error making unable to install or remove packages

Bug #1619710 reported by Michal Dziczkowski on 2016-09-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Hello. Since some time, when I tryed to install, update or remove packages, I started to recieve given at the end of this message error, with makes me unable to install, update or remove propperly packages. I tryed to reinstall python3.5, but it has added it to the package list with was unable to get fully installed, updated or uninstalled.

== Error message ==

Traceback (most recent call last):
  File "/ usr / bin / py3compile", line 25, in <module>
    import logging
  File "/usr/lib/python3.5/logging/__init__.py", line 26, in <module>
    import sys, os, time, and, traceback, warnings, weakref, collections
  File "/usr/lib/python3.5/traceback.py", line 3, in <module>
    import collections
  File "/usr/lib/python3.5/collections/__init__.py", line 26, in <module>
    from operator import itemgetter as _itemgetter, eq as _eq
ImportError: No module named 'operator'
dpkg: error processing package language-selector-common (--configure):
 subprocess installed post-installation script returned error code 1
Configuring package python3.5 (3.5.2-2 ~ 16.01) ...
Traceback (most recent call last):
  File "/usr/lib/python3.5/py_compile.py", line 6, in <module>
    import importlib._bootstrap_external
  File "/usr/lib/python3.5/importlib/__init__.py", line 57, in <module>
    import types
  File "/usr/lib/python3.5/types.py", line 166, in <module>
    import functools as _functools
  File "/usr/lib/python3.5/functools.py", line 21, in <module>
    from collections import namedtuple
  File "/usr/lib/python3.5/collections/__init__.py", line 26, in <module>
    from operator import itemgetter as _itemgetter, eq as _eq
ImportError: No module named 'operator'
dpkg: error processing package python3.5 (--configure):
 subprocess installed post-installation script returned error code 1
Configuring ufw (0.35-0ubuntu2) ...
Traceback (most recent call last):
  File "/ usr / bin / py3compile", line 25, in <module>
    import logging
  File "/usr/lib/python3.5/logging/__init__.py", line 26, in <module>
    import sys, os, time, and, traceback, warnings, weakref, collections
  File "/usr/lib/python3.5/traceback.py", line 3, in <module>
    import collections
  File "/usr/lib/python3.5/collections/__init__.py", line 26, in <module>
    from operator import itemgetter as _itemgetter, eq as _eq
ImportError: No module named 'operator'
dpkg: error processing package ufw (--configure):
 subprocess installed post-installation script returned error code 1
Configuring gconf2 (3.2.6-3ubuntu6) ...
Traceback (most recent call last):
  File "/ usr / sbin / gconf-schemas", line 8, in <module>
    import sys, os, os.path shutil, tempfile, subprocess, re
  File "/usr/lib/python3.5/shutil.py", line 10, in <module>
    import fnmatch
  File "/usr/lib/python3.5/fnmatch.py", line 15, in <module>
    import functools
  File "/usr/lib/python3.5/functools.py", line 21, in <module>
    from collections import namedtuple
  File "/usr/lib/python3.5/collections/__init__.py", line 26, in <module>
    from operator import itemgetter as _itemgetter, eq as _eq
ImportError: No module named 'operator'
dpkg: error processing package gconf2 (--configure):
 subprocess installed post-installation script returned error code 1
Configuring hplip-data (3.16.3 + repack0-1) ...
Traceback (most recent call last):
  File "/ usr / bin / py3compile", line 25, in <module>
    import logging
  File "/usr/lib/python3.5/logging/__init__.py", line 26, in <module>
    import sys, os, time, and, traceback, warnings, weakref, collections
  File "/usr/lib/python3.5/traceback.py", line 3, in <module>
    import collections
  File "/usr/lib/python3.5/collections/__init__.py", line 26, in <module>
    from operator import itemgetter as _itemgetter, eq as _eq
ImportError: No module named 'operator'
dpkg: error processing package hplip-data (--configure):
 subprocess installed post-installation script returned error code 1
dpkg: dependency problems prevent configuration of package language-selector-gnome:
 language-selector-gnome depends on the language-selector-common (= 0.165.4); however:
  Package language-selector-common is not configured yet.

dpkg: error processing package language-selector-gnome (--configure):
 dependency problems - leaving unconfigured
Configuring python3-xdg (0.25-4) ...
Traceback (most recent call last):
  File "/ usr / bin / py3compile", line 25, in <module>
    import logging
  File "/usr/lib/python3.5/logging/__init__.py", line 26, in <module>
    import sys, os, time, and, traceback, warnings, weakref, collections
  File "/usr/lib/python3.5/traceback.py", line 3, in <module>
    import collections
  File "/usr/lib/python3.5/collections/__init__.py", line 26, in <module>
    from operator import itemgetter as _itemgetter, eq as _eq
ImportError: No module named 'operator'
dpkg: error processing package python3-xdg (--configure):
 subprocess installed post-installation script returned error code 1
dpkg: dependency problems prevent configuration of package unity-tweak-tool:
 unity-tweak-tool depends python3-xdg; however:
  Package python3-xdg is not configured yet.

dpkg: error processing package unity-tweak-tool (--configure):
 dependency problems - leaving unconfigured
Configuring update-manager (1: 16.04.3) ...
Traceback (most recent call last):
  File "/ usr / bin / py3compile", line 25, in <module>
    import logging
  File "/usr/lib/python3.5/logging/__init__.py", line 26, in <module>
    import sys, os, time, and, traceback, warnings, weakref, collections
  File "/usr/lib/python3.5/traceback.py", line 3, in <module>
    import collections
  File "/usr/lib/python3.5/collections/__init__.py", line 26, in <module>
    from operator import itemgetter as _itemgetter, eq as _eq
ImportError: No module named 'operator'
dpkg: error processing package update-manager (--configure):
 subprocess installed post-installation script returned error code 1
dpkg: dependency problems prevent configuration of package update-notifier:
 update-notifier depends on update-manager-gnome | update-manager (> = 1: 0.165); however:
  Package update-manager-gnome is not installed.
  Package update-manager is not configured yet.

dpkg: error processing package update-notifier (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 language-selector-common
 python3.5
 ufw
 gconf2
 hplip-data
 language-selector-gnome
 python3-xdg
 unity-tweak-tool
 update-manager
 update-notifier
In: --force-yes is deprecated, use one of the options starting with --allow instead.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers