SRU: backport python 3.5.2 to 16.04 LTS

Bug #1591887 reported by Matthias Klose on 2016-06-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3.5 (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

SRU: backport python 3.5.2 to 16.04 LTS

The idea is to ship a released version with the first point release of 16.04 LTS. We updated python3.5 from the the 3.5 branch up to the final 3.5.2 release, and then made a test rebuild of the archive using the new python3.5 (and some other toolchain packages).

The test rebuild was done using the release candidate of 3.5.2, however the only changes between the rc and the final release are Windows related, and include one change in the idle lib, plus a fix for a ssl test case which was already present as a local patch in the Ubuntu package. From my point of view we don't need another test rebuild.

The evaluation of the test rebuild is found in LP: #1586673. There are some issues found and/or left:

 - nuitka (a python compiler) fails in the tests, fixed by updating
   to the nuitka version in yakkety, tracked in LP: #1599240.

 - python-websockets fail in the tests. This is now
   https://bugs.debian.org/829726 and
   https://github.com/aaugustin/websockets/issues/123
   From my point of view this looks like an issue with the test case.

 - urwid fails two tests on ppc64el and s390x.

Matthias Klose (doko) on 2016-07-05
description: updated

Hello Matthias, or anyone else affected,

Accepted python3.5 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.5/3.5.2-2~16.01 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python3.5 (Ubuntu):
status: New → Fix Released
Changed in python3.5 (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
Matthias Klose (doko) wrote :

the package builds and the autopkg tests pass. further validation was done in the test rebuild.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :
Download full text (13.6 KiB)

This bug was fixed in the package python3.5 - 3.5.2-2~16.01

---------------
python3.5 (3.5.2-2~16.01) xenial-proposed; urgency=medium

  * SRU: LP: #1591887. Backport 3.5.2 to 16.04 LTS.

python3.5 (3.5.2-2) unstable; urgency=medium

  * asyncio: Fix callbacks race in SelectorLoop.sock_connect, proposed patch
    taken from https://github.com/python/asyncio/pull/366.
  * asyncio: Fix NameError in asyncio.sslproto. Closes: #827453.

python3.5 (3.5.2-1) unstable; urgency=medium

  * Python 3.5.2 release.
    - Issue #26867: Ubuntu's openssl OP_NO_SSLv3 is forced on by default;
      fix test.
    - Issue #27365: Allow non-ascii in idlelib/NEWS.txt.

python3.5 (3.5.2~rc1-3) unstable; urgency=medium

  * Fix building with the wheel files in the source package.

python3.5 (3.5.2~rc1-1) unstable; urgency=medium

  * Python 3.5.2 release candidate 1.
    - Issue #15657: Delete incorrect statement from PyMethodDef documentation.
    - Issue #27289: Prevent test_urllib2net failures due to EOFError raised
      by ftplib.
    - Issue #25455: Clean up reference loops created in tests for recursive.
    - Issue #27190: Raise NotSupportedError if sqlite3 is older than 3.3.1.
    - Issue #27188: Fix various sqlite3 documentation errors.
    - Issue #15476: Make "code object" its own entry in the index.
    - Issue #8491: Add link to Gnu Readline configuration documentation.
    - Issue #24617: Add comment for os.mkdir about mode quirks.
    - Issue #27280: Fix typo in IPv6Network documentation.
    - Issue #17500, and https://github.com/python/pythondotorg/issues/945:
      Remove unused and outdated icons.
    - Issue #20900: distutils register command now decodes HTTP responses
      correctly.
    - Issue #5124: Paste with selection should always replace.
      This is how paste work on Windows, Mac, modern Linux apps, and ttk
      widgets. The exception was X11 tk widgets.
    - Issue #27223: aio: Fix _read_ready and _write_ready to respect _conn_lost.
    - Issue #22970: asyncio: Fix inconsistency cancelling Condition.wait.
    - Issue #22558: Add remaining doc links to source code for Python-coded
      modules.
    - Issue #21386: Implement missing IPv4Address.is_global property.
    - Issue #27194: superfluous truncate calls in tarfile.py slow down
      extraction.
    - Issue #14209: pkgutil.iter_zipimport_modules ignores the prefix for
      packages.
    - Issue #24136: Document generalized unpacking, PEP 448.
    - Issue #27286: Fixed compiling BUILD_MAP_UNPACK_WITH_CALL opcode. Calling
      function with generalized unpacking (PEP 448) and conflicting keyword
      names could cause undefined behavior.
    - Issue #25455: Fixed a crash in repr of ElementTree.Element with recursive
      tag.
  * Extend debian/copyright to the files shipped in the wheel files.

python3.5 (3.5.1-16) unstable; urgency=high

  * Restore the distutils-init patch, only applied on upstream trunk.

python3.5 (3.5.1-15) unstable; urgency=high

  * Fix bad update of the distutils-install-layout patch.

python3.5 (3.5.1-14) unstable; urgency=medium

  * Update to 20160609 from the 3.5 branch.
    - A new version of typing.py provides several new classes and
      f...

Changed in python3.5 (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for python3.5 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.