xargs: invalid number for -s option

Bug #1540353 reported by David Henningsson on 2016-02-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
High
Unassigned
python3.4 (Ubuntu)
High
Unassigned
python3.5 (Debian)
Fix Released
Unknown

Bug Description

I ran "sudo apt-get autoremove" and when python3.4 and libpython3.4-minimal:amd64 were removed, the following error was shown on the screen:

Removing python3.4-minimal (3.4.4-1) ...
Unlinking and removing bytecode for runtime python3.4
Removing libpython3.4-minimal:amd64 (3.4.4-1) ...
xargs: invalid number for -s option
Usage: xargs [OPTION]... COMMAND [INITIAL-ARGS]...
Run COMMAND with arguments INITIAL-ARGS and more arguments read from input.

...followed by instructions on how to use xargs properly.

Probably some maintainer scripting errors?

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: libpython3.4-minimal (not installed)
ProcVersionSignature: Ubuntu 4.3.0-7.18-generic 4.3.3
Uname: Linux 4.3.0-7-generic x86_64
ApportVersion: 2.19.4-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Feb 1 13:46:27 2016
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-11-28 (65 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Alpha amd64 (20151127)
SourcePackage: python3.4
UpgradeStatus: No upgrade log present (probably fresh install)

David Henningsson (diwic) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python3.4 (Ubuntu):
status: New → Confirmed
Changed in python3.4 (Ubuntu):
importance: Undecided → High
Changed in hundredpapercuts:
status: New → Confirmed
importance: Undecided → High
Scott Emmons (lscotte) wrote :

Xenial currently has python 3.5 (not python 3.4) and at a version where the upstream bug[1] should be fixed.

[1] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=809079

Changed in python3.5 (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.