python3.4: test_faulthandler fails on arm64, lets the buildd hang

Bug #1264354 reported by Matthias Klose on 2013-12-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3.4 (Ubuntu)
High
Unassigned

Bug Description

test_register_chain (test.test_faulthandler.FaultHandlerTests) ... FAIL

======================================================================
FAIL: test_register_chain (test.test_faulthandler.FaultHandlerTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/doko/python/python3.4-3.4~b1/Lib/test/test_faulthandler.py", line 592, in test_register_chain
    self.check_register(chain=True)
  File "/home/doko/python/python3.4-3.4~b1/Lib/test/test_faulthandler.py", line 570, in check_register
    self.assertRegex(trace, regex)
AssertionError: Regex didn't match: '^Stack \\(most recent call first\\):\n File "<string>", line 7 in func\n File "<string>", line 28 in <module>$' not found in 'Stack (most recent call first):\n File "<string>", line 7 in func\n File "<string>", line 28 in <module>\nDebug memory block at address p=0x1f767060: API \'\x00\'\n 12693960699257290752 bytes originally requested\n The 7 pad bytes at p-7 are not all FORBIDDENBYTE (0xfb):\n at p-7: 0x00 *** OUCH\n at p-6: 0x00 *** OUCH\n at p-5: 0x00 *** OUCH\n at p-4: 0x00 *** OUCH\n at p-3: 0x00 *** OUCH\n at p-2: 0x00 *** OUCH\n at p-1: 0x00 *** OUCH\n Because memory is corrupted at the start, the count of bytes requested\n may be bogus, and checking the trailing pad bytes may segfault.\n The 8 pad bytes at tail=0xb02a02003f767060 are'

----------------------------------------------------------------------
Ran 31 tests in 20.589s

FAILED (failures=1)
test test_faulthandler failed

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3.4 - 3.4~b1-4ubuntu4

---------------
python3.4 (3.4~b1-4ubuntu4) trusty; urgency=medium

  * Disable test_compileall for the autopkg tests, fails only there.
 -- Matthias Klose <email address hidden> Sat, 28 Dec 2013 01:47:57 +0100

Changed in python3.4 (Ubuntu):
status: Confirmed → Fix Released
Matthias Klose (doko) on 2013-12-28
Changed in python3.4 (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3.4 - 3.4~b1-5ubuntu2

---------------
python3.4 (3.4~b1-5ubuntu2) trusty; urgency=medium

  * Disable the test_dbm autopkg test, failing from time to time ...
 -- Matthias Klose <email address hidden> Fri, 03 Jan 2014 02:25:31 +0100

Changed in python3.4 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers