Slight misleading error message when trying to use tkinter

Bug #1184082 reported by Ma Hsiao-chun
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3.3 (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

By default, python3-tk is not installed.

$ python3 -m tkinter
/usr/bin/python3: No module named '_tkinter', please install the python-tk package; 'tkinter' is a package and cannot be directly executed

The package to install for Python 3 is python3-tk rather than python-tk.

Tags: raring

Related branches

Revision history for this message
Scott Kitterman (kitterman) wrote :

The python3 command is a symlink to the default python3 interpreter, currently python3.3, so this is an issue with python3.3 and not python3-defaults.

affects: python3-defaults (Ubuntu) → python3.3 (Ubuntu)
Changed in python3.3 (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

It is actually provided by upstream, which probably tried to provide a generic message independent of Python packages naming in Debian/Ubuntu.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3.3 - 3.3.2-7ubuntu1

---------------
python3.3 (3.3.2-7ubuntu1) saucy; urgency=low

  * Merge with Debian; remaining changes:
    - Re-generate the control file.

python3.3 (3.3.2-7) unstable; urgency=low

  * Update to 20130918 from the 3.3 branch.
  * Update symbols file.
  * Fail the build if extensions for the minimal package are not in
    the libpython-minimal package. Closes: #723624.
  * Fix indentation in regenerated platform-lsbrelease.diff (Dmitry Shachnev).
    LP: #1220508.
  * Point to the python3-tk (instead of the python-tk) package when missing.
    LP: #1184082.

python3.3 (3.3.2-6) unstable; urgency=medium

  * Update to 20130917 from the 3.3 branch.
    - Fix SSL module to handle NULL bytes inside subjectAltNames general
      names (CVE-2013-4238). Closes: #719567.
  * Don't run the curses autopkg test.
  * Set Multi-Arch attributes for binary packages.
  * Fix multiarch include header for sparc64. Closes: #714802.

python3.3 (3.3.2-5) unstable; urgency=low

  * Update to 20130803 from the 3.3 branch.
    - Fix fcntl test case on KFreeBSD (Petr Salinger).
  * Disable some socket tests on KFreeBSD (Petr Salinger).
  * Fix multiarch include header for sparc64. Closes: #714802.
  * Update package descriptions (Filipus Klutiero). Closes: #715801.

python3.3 (3.3.2-4) unstable; urgency=low

  * Update to 20130612 from the 3.3 branch.
  * Refresh patches.
  * Don't run consistency check for cross builds.
  * Really skip byte compile of non-existing sitecustomize.py.
  * Fix the multiarch header file for mips64 (YunQiang Su). Closes: #710374.
 -- Matthias Klose <email address hidden> Wed, 18 Sep 2013 14:24:38 +0200

Changed in python3.3 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers