SRU: Update Python interpreter to 3.6.10 and 3.7.6

Bug #1856990 reported by Matthias Klose on 2019-12-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3-stdlib-extensions (Ubuntu)
Undecided
Unassigned
python3.6 (Ubuntu)
Undecided
Unassigned
python3.7 (Ubuntu)
Undecided
Unassigned

Bug Description

Update Python interpreter to 3.6.10 and 3.7.6. As done with earlier subminor upstream releases (LP: #1835738).

SRU: update Python 3.7 to the 3.7.6 release, update Python 3.6 to the 3.6.10 release.

python3-stdlib-extensions also updates the modules to the 3.6.10 release for Python 3.6.

Acceptance Criteria: The package builds, and the test suite doesn't show regressions. The test suite passes in the autopkg tests. The new packages don't cause regressions in a test rebuild of the main component.

https://people.canonical.com/~doko/ftbfs-report/test-rebuild-20191018-release-bionic.html
https://people.canonical.com/~doko/ftbfs-report/test-rebuild-20191018-release-tst-bionic.html

The test rebuilds are finished, and don't show any regressions for the main component.

Regression Potential: Python 3.7 isn't used by default, so we don't have many default users.
Regression Potential: Python 3.6 could see some regressions, although we are trying to minimize the risk by doing the test rebuild.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers