Ubuntu

deprecation warnings in py3versions

Reported by Julian Taylor on 2012-05-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3-defaults (Ubuntu)
Low
Unassigned

Bug Description

when building python-simplegeneric in precise/quantal you get a bunch of deprecation warnings from py3versions:

/usr/bin/py3versions:11: DeprecationWarning: The SafeConfigParser class has been renamed to ConfigParser in Python 3.2. This alias will be removed in future versions. Use ConfigParser directly instead.
  config = SafeConfigParser()
/usr/bin/py3versions:12: DeprecationWarning: This method will be removed in future versions. Use 'parser.read_file()' instead.
  config.readfp(open('/usr/share/python3/debian_defaults'))

Julian Taylor (jtaylor) on 2012-05-10
description: updated
Scott Kitterman (kitterman) wrote :

Already fix in (Debian) bzr.

Changed in python3-defaults (Ubuntu):
importance: Undecided → Low
status: New → Fix Committed
Scott Kitterman (kitterman) wrote :

Fixed in Ubuntu now too.

Changed in python3-defaults (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers