package python3 3.2.3~rc1-2ubuntu1 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1

Bug #985062 reported by Juha Siltala on 2012-04-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3-defaults (Ubuntu)
Undecided
Unassigned

Bug Description

Failed to install. Update Manager refused to install updates, got this after upgrading with apt.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: python3 3.2.3~rc1-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
ApportVersion: 2.0.1-0ubuntu3
Architecture: i386
Date: Wed Apr 18 19:25:54 2012
ErrorMessage: subprocess new pre-removal script returned error exit status 1
InstallationMedia: Kubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120211)
PackageArchitecture: all
SourcePackage: python3-defaults
Title: package python3 3.2.3~rc1-2ubuntu1 failed to install/upgrade: subprocess new pre-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Juha Siltala (topyli) wrote :
Scott Kitterman (kitterman) wrote :

In the DpkgTerminalLog.txt is has the line:
dpkg: error processing /var/cache/apt/archives/python3_3.2.3-0ubuntu1_all.deb (--unpack)

This is an indication of either file system corruption on your system or a corrupted package. You can try fixing this by doing the following:

wget https://launchpad.net/ubuntu/+source/python3-defaults/3.2.3-0ubuntu1/+build/3407363/+files/python3_3.2.3-0ubuntu1_all.deb

That should retrieve another copy of the python3 .deb file in the directory from which you ran the command. Then do:

sudo dpkg -i python3_3.2.3-0ubuntu1_all.deb

This problem is not an indication of a bug in the package.

Changed in python3-defaults (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers