valgrind-python.supp is outdated

Bug #1513364 reported by Marius Gedminas on 2015-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3-defaults (Ubuntu)
Undecided
Unassigned

Bug Description

While investigating bug 1512622 I decided to look if there's a /usr/lib/valgrind/python3.supp, and if it suffers from the same problem.

I found it in python3-defaults, and it suffers from worse:

- talks about python2.4
- doesn't have all the suppressions from upstream
- the suppressions it has are for 32-bit systems only

This should be probably forwarded to Debian.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3-defaults - 3.6.5-3

---------------
python3-defaults (3.6.5-3) unstable; urgency=medium

  * Update valgrind support file. LP: #1513364.
  * debian/control.in (Michael Vogt):
    - add Cnf-Visible-Pkgname hint to ensure command-not-found recommends
      installing "python3" instead of "python3-minimal" when it is missing.

 -- Matthias Klose <email address hidden> Tue, 10 Apr 2018 11:48:03 +0200

Changed in python3-defaults (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers