Make Python 3.5 a supported version

Bug #1474882 reported by Barry Warsaw on 2015-07-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3-defaults (Ubuntu)
High
Barry Warsaw

Bug Description

Add Python 3.5 as a supported Python 3 version for wily, keeping Python 3.4 as the default version.

Note that many packages will need new uploads so that they will be built for Python 3.5. See the transition PPA for details, including FTBFS.

https://launchpad.net/~pythoneers/+archive/ubuntu/py35asdefault/+packages

Most of the failures are irrespective of whether 3.5 is default or not, and several of the packages in the PPA have been fixed to work with Python 3.5. In other cases, upstream bugs have been reported. There's still a long tail of failures.

Barry Warsaw (barry) wrote :

debdiff for change I plan to upload

tags: added: patch
Barry Warsaw (barry) on 2015-07-15
Changed in python3-defaults (Ubuntu):
status: New → In Progress
assignee: nobody → Barry Warsaw (barry)
importance: Undecided → High
milestone: none → ubuntu-15.10
Martin Pitt (pitti) wrote :

Temporarily adding block-proposed, as I'm switching autopkgtest infrastructure now. I imported all the relevant test regressions, but just in case..

tags: added: block-proposed
Martin Pitt (pitti) on 2015-08-04
tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3-defaults - 3.4.3-4ubuntu1

---------------
python3-defaults (3.4.3-4ubuntu1) wily; urgency=medium

  * Add python3.5 as a supported Python version. (LP: #1474882)

 -- Barry Warsaw <email address hidden> Wed, 15 Jul 2015 10:36:57 -0400

Changed in python3-defaults (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers