pyvenv-3.4 fails to create a virtual environment in Trusty Tahr

Bug #1306114 reported by michaelfsp on 2014-04-10
72
This bug affects 15 people
Affects Status Importance Assigned to Milestone
python3-defaults (Ubuntu)
Undecided
Unassigned
python3.4 (Ubuntu)
Undecided
Unassigned

Bug Description

When attempting to create a virtual environment using pyvenv-3.4 an error is thrown and the virtual environment is not correctly created:

"Error: Command '['/home/michael/pyvenvs/pyvenv1/bin/python3.4', '-Im', 'ensurepip', '--upgrade', '--default-pip']' returned non-zero exit status 1"

Package version is 3.4.0-1

running pyvenv-3.4 with option --without-pip prevents this error from happening. additionally, python3 -m ensurepip returns "No module named ensurepip", so it seems like this module is lacking...

FYI, I also have package python3-pip installed.

michaelfsp (michael-fsp) on 2014-04-10
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python3-defaults (Ubuntu):
status: New → Confirmed
Changed in python3.4 (Ubuntu):
status: New → Confirmed
Hidden Markov (hidden-markov) wrote :

Temporary workaround that worked for me was to copy `ensurepip` folder from python 3.4 web repository (`Lib` directory) to `/usr/lib/python3.4`.
 The default Trusty Tahr distribution for some reason lacks the `ensurepip` package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers