package python3 3.2.3-5ubuntu1 failed to install/upgrade: trying to overwrite '/usr/bin/py3versions', which is also in package python3-minimal 3.2.3-5ubuntu1

Bug #1167183 reported by Wotan on 2013-04-10
510
This bug affects 117 people
Affects Status Importance Assigned to Milestone
python3-defaults (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Critical
Matthias Klose

Bug Description

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

python3: Depends: python3-minimal (= 3.2.3-5ubuntu1) aber 3.2.3-5ubuntu1.1 ist bereits installiert

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: python3 3.2.3-5ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-27.46-generic 3.5.7.7
Uname: Linux 3.5.0-27-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
Date: Wed Apr 10 09:51:32 2013
DuplicateSignature:
 Unpacking replacement python3 ...
 dpkg: error processing /var/cache/apt/archives/python3_3.2.3-5ubuntu1.1_amd64.deb (--unpack):
  trying to overwrite '/usr/bin/py3versions', which is also in package python3-minimal 3.2.3-5ubuntu1
ErrorMessage: trying to overwrite '/usr/bin/py3versions', which is also in package python3-minimal 3.2.3-5ubuntu1
InstallationDate: Installed on 2011-10-20 (537 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
PackageArchitecture: all
SourcePackage: python3-defaults
Title: package python3 3.2.3-5ubuntu1 failed to install/upgrade: trying to overwrite '/usr/bin/py3versions', which is also in package python3-minimal 3.2.3-5ubuntu1
UpgradeStatus: Upgraded to quantal on 2012-10-11 (180 days ago)

Wotan (ubuntu-freebsd) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python3-defaults (Ubuntu):
status: New → Confirmed
Changed in python3-defaults (Ubuntu):
importance: Undecided → Critical
Changed in python3-defaults (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → Critical
Changed in python3-defaults (Ubuntu):
importance: Critical → Undecided
status: Confirmed → Invalid
Changed in python3-defaults (Ubuntu Quantal):
assignee: nobody → Matthias Klose (doko)
Matthias Klose (doko) wrote :

there's more here to do. py3clean and py3compile should be in python3-minimal too.

Changed in python3-defaults (Ubuntu):
status: Invalid → Confirmed
Changed in python3-defaults (Ubuntu Precise):
status: New → Confirmed
xandie (bridtssander) on 2013-04-10
Changed in python3-defaults (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Steve Langasek (vorlon) wrote :

Matthias, your upload for this appears to include a lot of unrelated changes to debian/rules; I would expect this to be a one-line change. Can you explain why the other changes are needed for this bug fix - or else drop the changes and reupload?

Hello Wotan, or anyone else affected,

Accepted python3-defaults into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python3-defaults/3.2.3-5ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python3-defaults (Ubuntu Quantal):
status: Triaged → Fix Committed
tags: added: verification-needed
Changed in python3-defaults (Ubuntu Precise):
status: Confirmed → Fix Committed
Steve Langasek (vorlon) wrote :

Hello Wotan, or anyone else affected,

Accepted python3-defaults into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python3-defaults/3.2.3-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

omar mohamed (omarmed6) on 2013-04-10
Changed in python3-defaults (Ubuntu Quantal):
status: Fix Committed → Fix Released
Dimitri John Ledkov (xnox) wrote :

@omarmed6

Please, do not change per-series task bug statuses. The fix is not released yet, as it's only in -proposed at the moment. We mark bugs as fix released only once they hit release pocket (for devel series) or -security/-updates pockets (for stable series).

Changed in python3-defaults (Ubuntu Quantal):
status: Fix Released → Fix Committed

As an affected user, I can confirm that the newly-created package python3-defaults in quantal-proposed - installed using sudo apt-get -f install - fixes the problem.

reza (seebord) on 2013-04-11
Changed in python3-defaults (Ubuntu Quantal):
status: Fix Committed → Fix Released
Changed in python3-defaults (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in python3-defaults (Ubuntu):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

@reza, see comment #7

Changed in python3-defaults (Ubuntu Quantal):
status: Fix Released → Fix Committed
Changed in python3-defaults (Ubuntu Precise):
status: Fix Released → Fix Committed
tags: added: verification-precise-needed verification-quantal-done
removed: verification-needed
tags: added: verification-needed
Changed in python3-defaults (Ubuntu Quantal):
status: Fix Committed → Confirmed
status: Confirmed → Fix Released

@7-roger, please read comment #7

Changed in python3-defaults (Ubuntu Quantal):
status: Fix Released → Fix Committed

Understood Thanks

On 14 April 2013 08:54, Jean-Baptiste Lallement <email address hidden>wrote:

> @7-roger, please read comment #7
>
> ** Changed in: python3-defaults (Ubuntu Quantal)
> Status: Fix Released => Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1167259).
> https://bugs.launchpad.net/bugs/1167183
>
> Title:
> package python3 3.2.3-5ubuntu1 failed to install/upgrade: trying to
> overwrite '/usr/bin/py3versions', which is also in package
> python3-minimal 3.2.3-5ubuntu1
>
> Status in “python3-defaults” package in Ubuntu:
> Fix Released
> Status in “python3-defaults” source package in Precise:
> Fix Committed
> Status in “python3-defaults” source package in Quantal:
> Fix Committed
>
> Bug description:
> Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:
>
> python3: Depends: python3-minimal (= 3.2.3-5ubuntu1) aber
> 3.2.3-5ubuntu1.1 ist bereits installiert
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: python3 3.2.3-5ubuntu1
> ProcVersionSignature: Ubuntu 3.5.0-27.46-generic 3.5.7.7
> Uname: Linux 3.5.0-27-generic x86_64
> ApportVersion: 2.6.1-0ubuntu10
> Architecture: amd64
> Date: Wed Apr 10 09:51:32 2013
> DuplicateSignature:
> Unpacking replacement python3 ...
> dpkg: error processing
> /var/cache/apt/archives/python3_3.2.3-5ubuntu1.1_amd64.deb (--unpack):
> trying to overwrite '/usr/bin/py3versions', which is also in package
> python3-minimal 3.2.3-5ubuntu1
> ErrorMessage: trying to overwrite '/usr/bin/py3versions', which is also
> in package python3-minimal 3.2.3-5ubuntu1
> InstallationDate: Installed on 2011-10-20 (537 days ago)
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64
> (20111012)
> MarkForUpload: True
> PackageArchitecture: all
> SourcePackage: python3-defaults
> Title: package python3 3.2.3-5ubuntu1 failed to install/upgrade: trying
> to overwrite '/usr/bin/py3versions', which is also in package
> python3-minimal 3.2.3-5ubuntu1
> UpgradeStatus: Upgraded to quantal on 2012-10-11 (180 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/python3-defaults/+bug/1167183/+subscriptions
>

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of python3-defaults from quantal-proposed was performed and bug 1168537 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1168537 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Matthias Klose (doko) on 2013-04-15
tags: added: bot-stop-nagging
removed: verification-failed
Adam Conrad (adconrad) wrote :

The dpkg log in #1168537 shows that this was happening with python3_3.2.3-5ubuntu1.1, NOT python3_3.2.3-5ubuntu1.2, I'm guessing apport tripped and reported against the wrong package version after it had been successfully upgraded?

Adam Conrad (adconrad) wrote :

And verified that this fix seems to be good for precise as well.

tags: added: verification-done verification-precise-done
removed: verification-needed verification-precise-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3-defaults - 3.2.3-0ubuntu1.2

---------------
python3-defaults (3.2.3-0ubuntu1.2) precise-proposed; urgency=low

  * Move py3versions back to python3-minimal. LP: #1167183.

python3-defaults (3.2.3-0ubuntu1.1) precise-proposed; urgency=low

  * Make python3{,-minimal,-dbg} Multi-Arch: allowed. LP: #1130709.
  * As a prerequisite, build dependency packages as architecture
    dependent packages.
 -- Matthias Klose <email address hidden> Wed, 10 Apr 2013 15:50:15 +0200

Changed in python3-defaults (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3-defaults - 3.2.3-5ubuntu1.2

---------------
python3-defaults (3.2.3-5ubuntu1.2) quantal-proposed; urgency=low

  * Move py3versions back to python3-minimal. LP: #1167183.

python3-defaults (3.2.3-5ubuntu1.1) quantal-proposed; urgency=low

  * Make python3{,-minimal,-dbg} Multi-Arch: allowed. LP: #1130709.
  * As a prerequisite, build dependency packages as architecture
    dependent packages.
 -- Matthias Klose <email address hidden> Wed, 10 Apr 2013 15:26:42 +0200

Changed in python3-defaults (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers