Lucid -> Precise main failed to upgrade: ERROR: pycompile:Requested versions are not installed dpkg: error processing python2.7-minimal installed post-installation script returned error exit status 3

Bug #983981 reported by Jean-Baptiste Lallement on 2012-04-17
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
python2.7 (Ubuntu)
High
Matthias Klose
Precise
High
Matthias Klose

Bug Description

Lucid -> Precise i386 main all automated upgrade test failed
https://jenkins.qa.ubuntu.com/view/Precise%20Upgrade%20Testing%20Dashboard/job/precise-upgrade-lucid-main/ARCH=i386,LTS=lts,PROFILE=main-all,label=upgrade-test/89/

From term.log
Setting up python2.7-minimal (2.7.3-0ubuntu1) ...
ERROR:pycompile:Requested versions are not installed
dpkg: error processing python2.7-minimal (--configure):
 subprocess installed post-installation script returned error exit status 3
dpkg: dependency problems prevent configuration of python2.7:
 python2.7 depends on python2.7-minimal (= 2.7.3-0ubuntu1); however:
  Package python2.7-minimal is not configured yet.
dpkg: error processing python2.7 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python2.7-minimal
 python2.7

Complete upgrade logs attached to the job.

tags: added: rls-mgr-p-tracking
Changed in update-manager (Ubuntu):
importance: Undecided → High
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Matthias Klose (doko) wrote :

python-minimal is not yet unpacked, so the old pycompile is still used, which doesn't know about python2.7

Matthias Klose (doko) wrote :

another issue is that pycompile in lucid still has DEFAULT_VERSION = (2, 5), so changing this to 2.6 and re-running the upgrade would be interesting.

maybe this should be fixed independently.

Matthias Klose (doko) wrote :

update-manager 1:0.156.10 was uploaded on Apr 13 too, when this did start to fail, but the changes don't look that suspicious

Jean-Baptiste Lallement (jibel) wrote :

I changed DEFAULT_VERSION to (2, 6) and upgrade failed again.

Here is the output with PYCOMPILE_DEBUG=1:
"""
Setting up python2.7-minimal (2.7.3-0ubuntu1) ...
DEBUG:pycompile:argv: ['/usr/bin/pycompile', '-V', '2.7', '/usr/lib/python2.7/dist-packages']
DEBUG:pycompile:options: {'regexpr': None, 'version_range': ((2, 7), (2, 7)), 'pyr_mode': False, 'verbose': True, 'package': None}
DEBUG:pycompile:args: ['/usr/lib/python2.7/dist-packages']
DEBUG:pycompile:requested versions: set([])
ERROR:pycompile:Requested versions are not installed
dpkg: error processing python2.7-minimal (--configure):
 subprocess installed post-installation script returned error exit status 3
"""

Jean-Baptiste Lallement (jibel) wrote :
Matthias Klose (doko) wrote :

 - ok, so we need to figure out why python-minimal is not unpacked at this point.
 - or add the new pycompile into python2.7-minimal, and divert it, so that it's available, gross hack ...

Steve Langasek (vorlon) wrote :

> ok, so we need to figure out why python-minimal is not unpacked at this point.

Well, because nothing guarantees that it will be. python2.7-minimal doesn't depend on the newer python-minimal.

tags: added: rls-p-tracking
Steve Langasek (vorlon) on 2012-04-19
affects: update-manager (Ubuntu) → python2.7 (Ubuntu)
Changed in python2.7 (Ubuntu):
assignee: Canonical Foundations Team (canonical-foundations) → Matthias Klose (doko)
status: New → Triaged
Scott Kitterman (kitterman) wrote :

"Well, because nothing guarantees that it will be. python2.7-minimal doesn't depend on the newer python-minimal."

It can't, because python-minimal depends on python2.7-minimal and that would give us a dependency loop, right?

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/983981

tags: added: iso-testing

I tested python 2.7.3-0ubuntu2 and the upgrade test "lucid main all i386" pass again.

Matthias Klose (doko) wrote :

pitti> doko_: if it's upgrade only, a 0-day SRU will do fine

Changed in python2.7 (Ubuntu Precise):
milestone: none → precise-updates
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python2.7 - 2.7.3-0ubuntu2

---------------
python2.7 (2.7.3-0ubuntu2) precise-proposed; urgency=low

  * python2.7-minimal: Conflict with python-minimal (<< 2.7.3). LP: #983981.
 -- Matthias Klose <email address hidden> Thu, 19 Apr 2012 16:07:47 +0200

Changed in python2.7 (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers