pydoc2.7 crashed with SIGSEGV in __find_specmb()

Bug #974807 reported by Taylor "Ripps" LeMasurier-Wren on 2012-04-06
88
This bug affects 11 people
Affects Status Importance Assigned to Milestone
pygobject (Ubuntu)
Undecided
Unassigned
python2.7 (Ubuntu)
Medium
Unassigned

Bug Description

Was looking up some stuff in the graphical pydoc interface when it crashed.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: python2.7 2.7.3~rc2-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic 3.2.14
Uname: Linux 3.2.0-22-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Thu Apr 5 21:48:18 2012
ExecutablePath: /usr/bin/pydoc2.7
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python2.7 /usr/bin/pydoc -g
SegvReason: writing VMA None
Signal: 11
SourcePackage: python2.7
Title: pydoc2.7 crashed with SIGSEGV in g_type_get_qdata()
UpgradeStatus: Upgraded to precise on 2012-01-05 (91 days ago)
UserGroups: adm admin audio cdrom dialout kvm libvirtd lpadmin mythtv plugdev sambashare vboxusers video

Changed in python2.7 (Ubuntu):
importance: Undecided → Medium
summary: - pydoc2.7 crashed with SIGSEGV in g_type_get_qdata()
+ pydoc2.7 crashed with SIGSEGV in __find_specmb()
tags: removed: need-amd64-retrace
Matthias Klose (doko) on 2012-04-20
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python2.7 (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) wrote :

while pydoc shouldn't crash, there seems to be an issue importing some pygtk/pygobject module.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pygobject (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

pydoc -g uses python-tk, not pygobject.

affects: pygobject (Ubuntu) → python-stdlib-extensions (Ubuntu)
Changed in python-stdlib-extensions (Ubuntu):
status: Confirmed → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Matthias Klose (doko) wrote :

Martin, the reassignment is incorrect. There's no tk function showing up.

pydoc probably shouldn't blindly import any module, but by doing so it crashes somewhere in the pygobject extension modules. maybe mark it as invalid for pygobject. I don't want to track this down either.

Changed in pygobject (Ubuntu):
status: New → Confirmed
Matthias Klose (doko) on 2012-09-19
affects: python-stdlib-extensions (Ubuntu) → pygobject (Ubuntu)
Martin Pitt (pitti) wrote :

Ah, I see. Taylor, can you please describe the steps to reproduce this crash? The stack trace is absolutely useless, so I need a reproducer. Thanks!

Changed in pygobject (Ubuntu):
status: New → Incomplete
Changed in python2.7 (Ubuntu):
status: Confirmed → Invalid
Martin Pitt (pitti) wrote :

Oh, I see what's wrong in https://launchpadlibrarian.net/100297867/ProcMaps.txt: It does seem to actually import all the modules into a non-private namespace. With that it loads e. g. gobject/glib/gtk several times, once through all the static bindings (pygtk), and once again through the GI bindings. That's impossible I'm afraid, and will lead to random crashes. That's not something that really can be fixed in these individual libraries. So either pydoc stops importing the modules and executing stuff in them, or this is a case of "don't do that then".

Changed in pygobject (Ubuntu):
status: Incomplete → Invalid
Changed in python2.7 (Ubuntu):
status: Invalid → Won't Fix
status: Won't Fix → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers