python fails to cross-build

Bug #873007 reported by Wookey on 2011-10-12
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
python2.7 (Ubuntu)
Undecided
Unassigned

Bug Description

Python fails to cross-build, with:

make[3]: Entering directory `/home/wookey/testing/build/build/xdeb/python2.7/build-static'
gcc -pthread -c -fno-strict-aliasing -g -O2 -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fprofile-generate -I. -IInclude -I../Include -DPy_BUILD_CORE -o Modules/python.o ../Modules/python.c
In file included from ../Include/Python.h:58:0,
                 from ../Modules/python.c:3:
../Include/pyport.h:849:2: error: #error "LONG_BIT definition appears wrong for platform (bad gcc/glibc config?)."

Background:
The build command is:
xdeb --only-explicit -a armel --prefer-apt --apt-source --debug --force-rebuild python2.7-minimal

The actual build command xdeb issues is:
debuild --no-lintian -eUSER -eCONFIG_SITE=/etc/dpkg-cross/cross-config.armel -eDEB_BUILD_OPTIONS=nocheck -eGTEST_INCLUDEDIR=/usr/arm-linux-gnueabi/include -eGTEST_LIBDIR=/usr/arm-linux-gnueabi/lib -ePKG_CONFIG_LIBDIR=/usr/arm-linux-gnueabi/lib/pkgconfig:/usr/arm-linux-gnueabi/share/pkgconfig:/usr/share/pkgconfig -eDH_VERBOSE=1 -aarmel -b -uc -us -tc

To easily reproduce the build environment in which this bug was discovered follow the HOWTO here:
https://wiki.linaro.org/Platform/DevPlatform/CrossCompile/CrossBuildNano

Wookey (wookey) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python2.7 (Ubuntu):
status: New → Confirmed
Dawid Wróbel (dawidw) wrote :

This only happens when cross compiling for 32 bit on 64 bit host system. There's a good explanation of the issue here: http://www.spinics.net/lists/selinux/msg03546.html

This basically means that the python-dev packages should be packaged architecture dependent for multi-arch support. However I am quite sure the ubuntu python maintainers would have figured this on their own, so I am curious myself what is the potential fix for this issue.

Matthias Klose (doko) wrote :

now cross-builds in raring, checked with targeting armhf

Changed in python2.7 (Ubuntu):
status: Confirmed → Fix Released

Backport (backpackage?) to precise?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments