package python2.7-minimal 2.7.1-1ubuntu1 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 3

Bug #689306 reported by Vladimir Scherbaev on 2010-12-12
140
This bug affects 24 people
Affects Status Importance Assigned to Milestone
python2.7 (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: python2.7

Description: Ubuntu natty (development branch)
Release: 11.04
python2.7:
  Установлен: 2.7.1-1ubuntu1
  Кандидат: 2.7.1-1ubuntu1
  Таблица версий:
 *** 2.7.1-1ubuntu1 0
        500 http://ru.archive.ubuntu.com/ubuntu/ natty/main i386 Packages
        100 /var/lib/dpkg/status

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: python2.7-minimal 2.7.1-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-8.21-generic 2.6.37-rc4
Uname: Linux 2.6.37-8-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat Dec 11 17:59:48 2010
ErrorMessage: ErrorMessage: подпроцесс установлен сценарий post-installation возвратил код ошибки 3
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
SourcePackage: python2.7
Title: package python2.7-minimal 2.7.1-1ubuntu1 failed to install/upgrade: ErrorMessage: подпроцесс установлен сценарий post-installation возвратил код ошибки 3

Vladimir Scherbaev (zemik) wrote :
Matthias Klose (doko) wrote :

please attach the output of the following command:

  dpkg -l python python-minimal

was this an upgrade from an earlier snapshot of natty, or an upgrade from maverick?

Vladimir Scherbaev (zemik) wrote :

ii python 2.7.1-0ubuntu1 interactive high-level object-oriented language (default version)
ii python-minimal 2.7.1-0ubuntu1 minimal subset of the Python language (default version)

This is an upgrade from maverick.

Matthias Klose (doko) wrote :

what happens if you run

  sudo dpkg --configure --pending

do you still see the error?

Vladimir Scherbaev (zemik) wrote :

Настраивается пакет libubuntuone1.0-cil (0.3.8-0ubuntu5) ...
* Installing 1 assembly from libubuntuone1.0-cil into Mono
E: installing Assembly /usr/lib/cli/ubuntuone-sharp-1.0/ubuntuone-sharp.dll failed
E: Installation of libubuntuone1.0-cil with /usr/share/cli-common/runtimes.d/mono failed
dpkg: не удалось обработать параметр libubuntuone1.0-cil (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 9
dpkg: зависимости пакетов не позволяют настроить пакет banshee-extension-ubuntuonemusicstore:
 banshee-extension-ubuntuonemusicstore зависит от libubuntuone1.0-cil (>= 0.3.8), однако:
  Пакет libubuntuone1.0-cil пока не настроен.
dpkg: не удалось обработать параметр banshee-extension-ubuntuonemusicstore (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет libubuntuone1.0-cil-dev:
 libubuntuone1.0-cil-dev зависит от libubuntuone1.0-cil (= 0.3.8-0ubuntu5), однако:
  Пакет libubuntuone1.0-cil пока не настроен.
dpkg: не удалось обработать параметр libubuntuone1.0-cil-dev (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 libubuntuone1.0-cil
 banshee-extension-ubuntuonemusicstore
 libubuntuone1.0-cil-dev

Vladimir Scherbaev (zemik) wrote :

But this is maybe due:

$cat /etc/apt/sources.list | grep banshee
# deb http://ppa.launchpad.net/banshee-team/banshee-unstable/ubuntu natty main # заблокировано при обновлении до natty
# deb-src http://ppa.launchpad.net/banshee-team/banshee-unstable/ubuntu natty main # заблокировано при обновлении до natty

FrancisA (scrutinizer) wrote :

I aslo have this but in natty, when trying to dist-upgrade.
Neither sudo apt-get install -f nor dpkg --configure -a helped.

Barry Warsaw (barry) wrote :

Possibly related: when I do a normal apt-get upgrade on my ppc Maverick machine (i.e. *not* upgrading to Natty), I get:

Selecting previously deselected package python2.7-minimal.
dpkg: considering deconfiguration of python-minimal, which would be broken by installation of python2.7-minimal ...
dpkg: no, python-minimal is essential, will not deconfigure
 it in order to enable installation of python2.7-minimal.
dpkg: error processing /var/cache/apt/archives/python2.7-minimal_2.7.1-1ubuntu2_powerpc.deb (--unpack):
 installing python2.7-minimal would break existing software
Errors were encountered while processing:
 /var/cache/apt/archives/python2.7-minimal_2.7.1-1ubuntu2_powerpc.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Matthias Klose (doko) wrote :

for #8, see bug #689615.

for anything else:

 - run: dpkg -l python-minimal python python-dev
   see which packages are installed (lines starting with ii)
 - get these packages from
   https://launchpad.net/ubuntu/+source/python-defaults
   (search for Natty Nharwhal), select the version and
   follow the build link)
 - get the python2.7-minimal and python2.7 package from
   https://launchpad.net/ubuntu/+source/python2.7
 - use sudo dpkg --unpack to unpack these packages.
   Maybe you need to use dpkg --unpack --force-depends
 - run sudo dpkg --configure --pending
 - finish with an apt-get update && apt-get dist-upgrade

summary: package python2.7-minimal 2.7.1-1ubuntu1 failed to install/upgrade:
- ErrorMessage: подпроцесс установлен сценарий post-installation возвратил
- код ошибки 3
+ ErrorMessage: subprocess installed post-installation script returned
+ error exit status 3
Changed in python2.7 (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Murray Cumming (murrayc) wrote :

Is the advice in comment #9 the last word on this, or will this work eventually by itself?

Matthias Klose (doko) wrote :

> Is the advice in comment #9 the last word on this, or will this work eventually by itself?

You could try replacing /usr/bin/pycompile with the file from natty.

Murray Cumming (murrayc) wrote :

So there's no plan to fix this properly. Isn't someone concerned that upgrading from Maverick to Natty doesn't seem to work? Or is there something odd about just my own installation?

Murray Cumming (murrayc) wrote :

> So there's no plan to fix this properly.

I meant to put a question mark at the end of that.

solved with latest upgrades
Gabriele Vidali

On Sun, Jan 2, 2011 at 11:31 PM, Murray Cumming <email address hidden> wrote:

> > So there's no plan to fix this properly.
>
> I meant to put a question mark at the end of that.
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (690383).
> https://bugs.launchpad.net/bugs/689306
>
> Title:
> package python2.7-minimal 2.7.1-1ubuntu1 failed to install/upgrade:
> ErrorMessage: subprocess installed post-installation script returned error
> exit status 3
>

On 02.01.2011 23:31, Murray Cumming wrote:
> So there's no plan to fix this properly.

I didn't say that.

> Isn't someone concerned that
> upgrading from Maverick to Natty doesn't seem to work? Or is there
> something odd about just my own installation?

see bug #689615. It is fixed for everybody upgrading from an updated maverick,
and update-manager has a proper fix for not updated upgrades.

midenok (midenok) wrote :

Just say that to upgrade to python2.7 one needs to upgrade python2.6. That's it, no more words. Other explanations are too cryptic to understand.

Furinkazan (mathieu-vidalies) wrote :

Thank you very much Matthias Klose. It solve my problem. I know now how to fix this kind of trouble. :)

macada (macadanet) wrote :

Hi,
I had same problem and I solved it with Matthias Klose #9 solution in bug 689306
Thx for you help Matthias.

tags: added: dist-upgrade

LinkedIn
------------

Bug,

Vorrei aggiungerti alla mia rete professionale su LinkedIn.

-gabriele

gabriele vidali
IT helpdesk presso Temera Srl
Firenze, Italia

Conferma che conosci gabriele vidali:
https://www.linkedin.com/e/-lqgmhu-ha2yzemi-5l/isd/9808077870/gfeyokfl/?hs=false&tok=2_gnCg2uIbo5w1

--
Stai ricevendo inviti di collegamento. Clicca per annullare l'iscrizione:
http://www.linkedin.com/e/-lqgmhu-ha2yzemi-5l/ue6bDfCF7Xykwnd6NaHRbrLFKucm9iGVfszvBdO/goo/689306%40bugs%2Elaunchpad%2Enet/20061/I3274261010_1/?hs=false&tok=1718SDB9Ebo5w1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.

Rolf Leggewie (r0lf) wrote :

I'm marking this as fix released, given the comments in the ticket and since maverick and natty are no longer supported anyhow.

Changed in python2.7 (Ubuntu):
status: Confirmed → Fix Released
Rolf Leggewie (r0lf) wrote :

As always, thank you very much for bringing this issue to the atention of the community. Please continue to report bugs. In case this bug was closed in error, feel free to reopen the ticket or report a new one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers