Name error after backports ssl.match_hostname but not ssl.CertificateError

Bug #1166644 reported by Andrey Voronov on 2013-04-09
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
python2.7 (Ubuntu)
Undecided
Unassigned

Bug Description

  File "/usr/lib/python2.7/ssl.py", line 111, in _dnsname_to_pat
    frag = re.escape(frag)
NameError: global name 're' is not defined

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python2.7 (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python2.7 - 2.7.4-1ubuntu3

---------------
python2.7 (2.7.4-1ubuntu3) raring; urgency=low

  * Add the io and _io modules to libpython2.7-minimal. LP: #1165172.
  * Add missing import for the ssl module. LP: #1166644.
 -- Matthias Klose <email address hidden> Tue, 09 Apr 2013 12:11:12 +0200

Changed in python2.7 (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers