upgrade 12.10 -> 13.04 fails : new libpython2.7-minimal used during upgrade while libpython2.7-stdlib is not yet unpacked and configured.

Bug #1165172 reported by svenmeier on 2013-04-05
26
This bug affects 7 people
Affects Status Importance Assigned to Milestone
python2.7 (Ubuntu)
Critical
Canonical Foundations Team
Raring
Critical
Canonical Foundations Team

Bug Description

On upgrading from quantal to rairing the terminal stops with "Error in function:"

Last output:
Running hooks in /etc/ca-certificate/update.d....
Adding debian:Actalis_Authentication_Root_CA.pem
Adding debian:Bypass_Class_2_Root_CA.pem
Adding debian:Bypass_Class_3_Root_CA.pem
Adding debian:EE_Certification_Centre_Root_CA:pem
Adding debian:StartCom_Certification_Authority_G2.pem
Adding debian:Trustis_FPS_Root_CA.pem
Adding debian:T-TeleSec_GlobalRoot_Class_3.pem
done.
done.
Processing triggers for ureadahead ...
Processing triggers for dictionaries-common ...
Processing triggers for libreoffice_common ...
Error in function:

A popup show:
The problem cannot be reported:

The problem happened with the program /usr/lib/i386-linux-gnu/gdk-pixbuf-2.0/gdk-pixbuf-query-loaders which changed since the crash occurred.

svenmeier (sven-meiers) on 2013-04-05
tags: added: dist-upgrade
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Could you please add the log files from '/var/log/dist-upgrade/' to this bug report as separate attachments? Thanks in advance.

affects: update-manager (Ubuntu) → ubuntu-release-upgrader (Ubuntu)
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Incomplete
svenmeier (sven-meiers) wrote :
Jean-Baptiste Lallement (jibel) wrote :

Error from the logs:
= = = = =
Processing triggers for gconf2 ...
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 9, in <module>
    import os,tempfile,shutil,sys
  File "/usr/lib/python2.7/tempfile.py", line 32, in <module>
    import io as _io
ImportError: No module named io
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/apport_python_hook.py", line 64, in apport_excepthook
    from apport.fileutils import likely_packaged, get_recent_crashes
  File "/usr/lib/python2.7/dist-packages/apport/__init__.py", line 4, in <module>
    from apport.report import Report
  File "/usr/lib/python2.7/dist-packages/apport/report.py", line 12, in <module>
    import subprocess, tempfile, os.path, re, pwd, grp, os
  File "/usr/lib/python2.7/tempfile.py", line 32, in <module>
    import io as _io
ImportError: No module named io

Original exception was:
Traceback (most recent call last):
  File "/usr/bin/update-gconf-defaults", line 9, in <module>
    import os,tempfile,shutil,sys
  File "/usr/lib/python2.7/tempfile.py", line 32, in <module>
    import io as _io
ImportError: No module named io
dpkg: error processing gconf2 (--unpack):
 subprocess installed post-installation script returned error exit status 1
= = = = =

Changed in ubuntu-release-upgrader (Ubuntu):
importance: Undecided → Critical
status: Incomplete → Confirmed
Jean-Baptiste Lallement (jibel) wrote :

The problem is that the following events happens:
= = = = =
Selecting previously unselected package libpython2.7-minimal:amd64.
Unpacking libpython2.7-minimal:amd64 (from .../libpython2.7-minimal_2.7.4~rc1-4ubuntu1_amd64.deb) ...
Replacing files in old package python2.7-minimal ...
Preparing to replace python2.7-minimal 2.7.3-5ubuntu4 (using .../python2.7-minimal_2.7.4~rc1-4ubuntu1_amd64.deb) ...
Unpacking replacement python2.7-minimal ...
Processing triggers for gconf2 ...
dpkg: error processing gconf2 (--unpack):
 gconf2
Preparing to replace gconf2-common 3.2.5-0ubuntu4 (using .../gconf2-common_3.2.6-0ubuntu1_all.deb) ...
Unpacking replacement gconf2-common ...
Preparing to replace libgconf2-4:amd64 3.2.5-0ubuntu4 (using .../libgconf2-4_3.2.6-0ubuntu1_amd64.deb) ...
Unpacking replacement libgconf2-4:amd64 ...
Preparing to replace gconf2 3.2.5-0ubuntu4 (using .../gconf2_3.2.6-0ubuntu1_amd64.deb) ...
Unpacking replacement gconf2 ...
Setting up gconf2-common (3.2.6-0ubuntu1) ...
Selecting previously unselected package libpython2.7-stdlib:amd64.
Unpacking libpython2.7-stdlib:amd64 (from .../libpython2.7-stdlib_2.7.4~rc1-4ubuntu1_amd64.deb) ...
= = = = =

So in this case, the trigger for gconf2 will use modules from the new libpython2.7-minimal which requires libpython2.7-stdlib while libpython2.7-stdlib is not yet unpacked and configured. This is not specific to gconf2 and should be reproducible with other pacakges.

tags: added: rls-r-incoming
summary: - upgrade 12.10 -> 13.04 fails with Error in function
+ upgrade 12.10 -> 13.04 fails : new libpython2.7-minimal used during
+ upgrade while libpython2.7-stdlib is not yet unpacked and configured.
affects: ubuntu-release-upgrader (Ubuntu) → python2.7 (Ubuntu)
Changed in python2.7 (Ubuntu):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Changed in python2.7 (Ubuntu Raring):
status: Confirmed → In Progress
tags: removed: rls-r-incoming
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python2.7 - 2.7.4-1ubuntu3

---------------
python2.7 (2.7.4-1ubuntu3) raring; urgency=low

  * Add the io and _io modules to libpython2.7-minimal. LP: #1165172.
  * Add missing import for the ssl module. LP: #1166644.
 -- Matthias Klose <email address hidden> Tue, 09 Apr 2013 12:11:12 +0200

Changed in python2.7 (Ubuntu Raring):
status: In Progress → Fix Released
svenmeier (sven-meiers) wrote :

What can I do complete the upgrade on my system? Is there an option to re-run the upgrade?

On Tue, Apr 09, 2013 at 08:08:01PM -0000, svenmeier wrote:
> What can I do complete the upgrade on my system? Is there an option to
> re-run the upgrade?

A manual run of 'sudo apt-get -f install' followed by 'sudo apt-get
dist-upgrade' from the commandline is your best bet.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers