dangling symlink /usr/lib/pkgconfig/python2.pc

Bug #1088771 reported by Rolf Leggewie on 2012-12-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-defaults (Ubuntu)
Undecided
Unassigned
Precise
Low
Unassigned
python2.7 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

the package python2.7 in precise installs a dangling symlink.

$ ll /usr/lib/pkgconfig/python2.pc
lrwxrwxrwx 1 root root 13 Aug 1 07:46 /usr/lib/pkgconfig/python2.pc -> python-2.7.pc
$ ll /usr/lib/pkgconfig/python-2.7.pc
ls: cannot access /usr/lib/pkgconfig/python-2.7.pc: No such file or directory
$ dpkg -S /usr/lib/pkgconfig/python2.pc
python2.7: /usr/lib/pkgconfig/python2.pc

Matthias Klose (doko) wrote :

fixed in quantal and raring

Changed in python-defaults (Ubuntu Precise):
status: New → In Progress
Changed in python2.7 (Ubuntu Precise):
status: New → In Progress
Changed in python2.7 (Ubuntu):
status: New → Fix Released
Changed in python-defaults (Ubuntu):
status: New → Fix Released
Chris Halse Rogers (raof) wrote :

There are currently two python2.7 uploads for precise-proposed, this one, and the one fixing bug 1130709. Do you want to roll these two into one update?

Matthias Klose (doko) wrote :

merged and rejected the two other uploads

Hello Rolf, or anyone else affected,

Accepted python2.7 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python2.7/2.7.3-0ubuntu3.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python2.7 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Chris Halse Rogers (raof) wrote :

Hello Rolf, or anyone else affected,

Accepted python-defaults into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python-defaults/2.7.3-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-defaults (Ubuntu Precise):
status: In Progress → Fix Committed

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of python-defaults from precise-proposed was performed and bug 1167177 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1167177 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Rolf Leggewie (r0lf) wrote :

reopening the precise task for python-defaults due to the regression introduced by the current fix as reported in bug 1167177

Eyeing the code, I suspect the following patch might do the trick. Untested!

--- python-defaults-2.7.3/debian/control.in 2012-04-17 14:50:47.000000000 +0000
+++ python-defaults-2.7.3/debian/control.in 2013-03-20 17:55:59.000000000 +0000
@@ -54,7 +56,7 @@
 Package: python-dev
 Architecture: any
 Depends: ${misc:Depends}, python (= ${binary:Version}), @PVER@-dev (>= @PREVVER@)
-Replaces: python2.7 (<< 2.7.3), python2.7-dev (<< 2.7.3-0ubuntu3.2)
+Replaces: python2.7 (<< 2.7.3-0ubuntu3.2), python2.7-dev (<< 2.7.3-0ubuntu3.2)
 Description: header files and a static library for Python (default)
  Header files, a static library and development tools for building
  Python modules, extending the Python interpreter or embedding Python

Changed in python-defaults (Ubuntu Precise):
importance: Undecided → Low
status: Fix Committed → Triaged
tags: added: patch
removed: verification-failed verification-needed
Steve Langasek (vorlon) wrote :

> Eyeing the code, I suspect the following patch might do the trick. Untested!

Yes, this will do it.

Matthias, can you please reupload python-defaults to precise-proposed with the additional Replaces:?

Marking this bug verification-failed in the meantime.

tags: added: verification-failed
Barry Warsaw (barry) wrote :

I just uploaded the fix for LP: #1167177

Hello Rolf, or anyone else affected,

Accepted python-defaults into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python-defaults/2.7.3-0ubuntu2.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-defaults (Ubuntu Precise):
status: Triaged → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Steve Langasek (vorlon) wrote :

verified that the symlinks are correct now in the precise-proposed package.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python2.7 - 2.7.3-0ubuntu3.2

---------------
python2.7 (2.7.3-0ubuntu3.2) precise-proposed; urgency=low

  * Backport fix for issue #14308. Fix an exception when a "dummy" thread is
    in the threading module's active list after a fork(). LP: #1100343.
  * Remove dangling symlink in pkgconfig. LP: #1088771.
  * Make python2.7{,-minimal,-dbg} Multi-Arch: allowed. LP: #1130709.
 -- Matthias Klose <email address hidden> Thu, 28 Mar 2013 12:40:39 +0100

Changed in python2.7 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-defaults - 2.7.3-0ubuntu2.2

---------------
python-defaults (2.7.3-0ubuntu2.2) precise-proposed; urgency=low

  * Fix the python-dev Replaces to prevent installation regression.
    LP: #1167177

python-defaults (2.7.3-0ubuntu2.1) precise-proposed; urgency=low

  * Make python{,-minimal,-dbg} Multi-Arch: allowed. LP: #1130709.
  * Provide python2.pc symlinks. LP: #1088771.
 -- Barry Warsaw <email address hidden> Mon, 17 Jun 2013 14:06:09 -0400

Changed in python-defaults (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers