Python 2.6 and several virtual packages are still available in 12.04

Bug #979923 reported by Barry Warsaw on 2012-04-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pygobject-2 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
pymvpa (Debian)
Fix Released
Unknown
pymvpa (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
python-stdlib-extensions (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
python2.6 (Ubuntu)
High
Unassigned
Precise
High
Unassigned
xpyb (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
zope2.12 (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

My recollection is that we were going to remove Python 2.6 from Precise. Python 2.6 is still there, and several virtual packages still reference Python 2.6, even though attempting to install them will only install the Python 2.7 version.

$ aptitude search python2.6
p idle-python2.6 - An IDE for Python (v2.6) using Tkinter
c libpython2.6 - Shared Python runtime library (version 2.6
i A python2.6 - An interactive high-level object-oriented
v python2.6-adodb -
v python2.6-aiml -
v python2.6-at-spi -
v python2.6-bibtex -
v python2.6-bjsonrpc -
v python2.6-bluez -
v python2.6-box2d -
v python2.6-bzutils -
v python2.6-carquinyol-0.84 -
v python2.6-carquinyol-0.86 -
v python2.6-carquinyol-0.88 -
v python2.6-carquinyol-0.90 -
v python2.6-celementtree -
v python2.6-cfflib -
v python2.6-cherrypy -
v python2.6-chm -
v python2.6-cjkcodecs -
v python2.6-clientform -
v python2.6-comedilib -
v python2.6-ctypes -
v python2.6-daap -
v python2.6-dbf -
c python2.6-dbg - Debug Build of the Python Interpreter (ver
v python2.6-debianbts -
p python2.6-dev - Header files and a static library for Pyth
v python2.6-dhm -
v python2.6-dmidecode -
v python2.6-dmidecode-dbg -
p python2.6-doc - Documentation for the high-level object-or
v python2.6-elements -
v python2.6-elementtidy -
v python2.6-elementtree -
v python2.6-empy -
p python2.6-examples - Examples for the Python language (v2.6)
v python2.6-extractor -
v python2.6-facebook -
v python2.6-forgethtml -
v python2.6-forgetsql -
v python2.6-ftputil -
v python2.6-gaphas -
v python2.6-gasp -
v python2.6-gdbm -
v python2.6-gdchart2 -
v python2.6-gobject -
v python2.6-goopy -
v python2.6-gtkmvc -
v python2.6-guppy -
v python2.6-guppy-lib -
v python2.6-guppy-lib-dbg -
v python2.6-ipcalc -
v python2.6-jinja -
v python2.6-jinja-dbg -
v python2.6-jppy -
v python2.6-kerberos -
v python2.6-libpcap -
v python2.6-libsvm -
v python2.6-lightblue -
v python2.6-logilab-constraint -
i A python2.6-minimal - A minimal subset of the Python language (v
v python2.6-mlpy -
v python2.6-mlpy-lib -
v python2.6-moovida -
v python2.6-mvpa -
v python2.6-mvpa-lib -
v python2.6-mygpoclient -
v python2.6-ncrypt -
v python2.6-nibabel -
v python2.6-openopt -
v python2.6-otr -
v python2.6-pisa -
v python2.6-pocketsphinx -
v python2.6-pocketsphinx-dbg -
v python2.6-poker-prizes -
v python2.6-poker-stats -
v python2.6-poker2d -
v python2.6-pqueue -
v python2.6-profiler -
v python2.6-prowlpy -
v python2.6-ptrace -
v python2.6-py -
v python2.6-pyaudio -
v python2.6-pybiggles -
v python2.6-pychart -
v python2.6-pydhcplib -
v python2.6-pyentropy -
v python2.6-pyepl -
v python2.6-pyfits -
v python2.6-pyglet -
v python2.6-pyglew -
v python2.6-pygpu -
v python2.6-pymad -
v python2.6-pymetar -
v python2.6-pyodbc -
v python2.6-pyode -
v python2.6-pyrad -
v python2.6-pysnmp2 -
v python2.6-pytc -
v python2.6-pytc-dbg -
v python2.6-pyvtk -
v python2.6-pyxmpp -
v python2.6-qrencode -
v python2.6-quixote1 -
v python2.6-rabbyt -
v python2.6-rapi2 -
v python2.6-rra -
v python2.6-rtfcomp -
v python2.6-sendfile -
v python2.6-sendfile-dbg -
v python2.6-setuptools -
v python2.6-sfml -
v python2.6-sigmask -
v python2.6-simplegeneric -
v python2.6-simplemediawiki -
v python2.6-simplesettings -
v python2.6-smbpasswd -
v python2.6-soaplib -
v python2.6-sparqlwrapper -
v python2.6-sparse -
v python2.6-sphinxbase -
v python2.6-sphinxbase-dbg -
v python2.6-spread -
v python2.6-sqlitecachec -
v python2.6-statgrab -
v python2.6-sugar-toolkit-0.84 -
v python2.6-sugar-toolkit-0.86 -
v python2.6-sugar-toolkit-0.88 -
v python2.6-sugar-toolkit-0.90 -
v python2.6-swap -
v python2.6-tcpwrap -
v python2.6-templayer -
v python2.6-tk -
v python2.6-tracer -
v python2.6-unac -
v python2.6-utmp -
v python2.6-wsgiref -
v python2.6-xdgapp -
v python2.6-xpyb -
v python2.6-yapgvb -
v python2.6-yappy -
v python2.6-yenc -
v python2.6-zinnia -
v python2.6-zsi -

Matthias Klose (doko) wrote :

forgotten about that for the lts ... this needs

 - a no change rebuild for most of the packages (universe only)
 - removal of zope2.xx, which is not compatible with python2.7
  A new upstream version exists but is not yet packaged.

Changed in python2.6 (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-12.04
status: New → Confirmed
Martin Pitt (pitti) wrote :

This sounds fine to be done over the next weekend, when the builders hopefully will be a bit less crowded. You can self-accept the no-change rebuilds.

Changed in python2.6 (Ubuntu Precise):
status: Confirmed → Triaged
Matthias Klose (doko) wrote :

zope2.12 needs to be removed for precise, http://pypi.python.org/pypi/Zope2/2.13.0
which is compatible with python2.7, is not yet packaged.

Matthias Klose (doko) wrote :

xpyb needs a sync to fix the build failure

Matthias Klose (doko) wrote :

pymvpa ftbfs, details in the debian report

Matthias Klose (doko) wrote :

0.6/2.0 available at http://www.pymvpa.org/

Changed in pymvpa (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pygobject-2 - 2.28.6-10ubuntu1

---------------
pygobject-2 (2.28.6-10ubuntu1) precise; urgency=low

  * python-gobject-2: Don't hard code the python2.6-gobject-2 provides.
    LP: #979923.
 -- Matthias Klose <email address hidden> Sat, 14 Apr 2012 14:05:27 +0200

Changed in pygobject-2 (Ubuntu Precise):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-stdlib-extensions - 2.7.3-1ubuntu1

---------------
python-stdlib-extensions (2.7.3-1ubuntu1) precise; urgency=low

  * Stop providing python2.6-gdbm and python2.6-tk. LP: #979923.
 -- Matthias Klose <email address hidden> Sat, 14 Apr 2012 16:20:30 +0200

Changed in python-stdlib-extensions (Ubuntu Precise):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xpyb - 1.2-2ubuntu1

---------------
xpyb (1.2-2ubuntu1) precise; urgency=low

  * add xcb-api-fix.patch: (LP: #979923, #935494)
    work around an api inconsistency in xcb-proto, becomes
    obsolete with xpyb 1.3.1 and xcb-proto 1.7.1
 -- Julian Taylor <email address hidden> Sun, 15 Apr 2012 22:35:06 +0200

Changed in xpyb (Ubuntu Precise):
status: New → Fix Released
Martin Pitt (pitti) wrote :
Download full text (3.3 KiB)

2012-04-16 09:04:50 INFO Removing candidates:
2012-04-16 09:04:50 INFO python2.6 2.6.7-4ubuntu2 in precise
2012-04-16 09:04:50 INFO idle-python2.6 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO idle-python2.6 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO idle-python2.6 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO idle-python2.6 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO idle-python2.6 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 09:04:50 INFO libpython2.6 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO libpython2.6 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO libpython2.6 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO libpython2.6 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO libpython2.6 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 09:04:50 INFO python2.6 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO python2.6 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO python2.6 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO python2.6 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO python2.6 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 09:04:50 INFO python2.6-dbg 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO python2.6-dbg 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO python2.6-dbg 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO python2.6-dbg 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO python2.6-dbg 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 09:04:50 INFO python2.6-dev 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO python2.6-dev 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO python2.6-dev 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO python2.6-dev 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO python2.6-dev 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 09:04:50 INFO python2.6-doc 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO python2.6-doc 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO python2.6-doc 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO python2.6-doc 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO python2.6-doc 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 09:04:50 INFO python2.6-examples 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO python2.6-examples 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO python2.6-examples 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO python2.6-examples 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO python2.6-examples 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 09:04:50 INFO python2.6-minimal 2.6.7-4ubuntu2 in precise amd64
2012-04-16 09:04:50 INFO python2.6-minimal 2.6.7-4ubuntu2 in precise armel
2012-04-16 09:04:50 INFO python2.6-minimal 2.6.7-4ubuntu2 in precise armhf
2012-04-16 09:04:50 INFO python2.6-minimal 2.6.7-4ubuntu2 in precise i386
2012-04-16 09:04:50 INFO python2.6-minimal 2.6.7-4ubuntu2 in precise powerpc
2012-04-16 ...

Read more...

Changed in python2.6 (Ubuntu Precise):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

2012-04-16 09:06:49 INFO Removing candidates:
2012-04-16 09:06:49 INFO zope2.12 2.12.20-2 in precise
2012-04-16 09:06:49 INFO Removed-by: Martin Pitt
2012-04-16 09:06:49 INFO Comment: incompatible with python2.7, LP#979923

Changed in zope2.12 (Ubuntu Precise):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pymvpa - 0.4.7-2ubuntu1

---------------
pymvpa (0.4.7-2ubuntu1) precise; urgency=low

  * Adjust for API change in Shogun 1.0.0 (LP: #935383, #979923).
 -- Colin Watson <email address hidden> Fri, 20 Apr 2012 17:13:42 +0100

Changed in pymvpa (Ubuntu Precise):
status: New → Fix Released
Colin Watson (cjwatson) wrote :

Unsubscribing ubuntu-archive, as we can't do anything about the remaining Debian bug task. Feel free to resubscribe us if there's another action for us to take here.

Changed in pymvpa (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.