python-websocket-client is a dupe of and conflicts with python-websocket

Bug #1292502 reported by Robie Basak on 2014-03-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-jujuclient (Ubuntu)
Undecided
Unassigned
python-websocket-client (Ubuntu)
Undecided
Unassigned
websocket-client (Ubuntu)
Undecided
Unassigned

Bug Description

[Archive Admin]

Please remove src:python-websocket-client (and then NBS binary python-websocket-client) from the archive.

[Other Stuff]

<jamespage> rbasak, trying to overwrite '/usr/lib/python2.7/dist-packages/websocket.py', which is also in package python-websocket-client 0.11.0-0ubuntu1

python-websocket-client is an Ubuntu only package which is out of date now. python-websocket is packaged in Debian, and is up to date.

python-jujuclient is the only reverse dependency of python-websocket-client.

This should not be duplicated.

src:python-websocket-client needs to be removed from the archive, and python-jujuclient should depend on python-websocket instead.

Revision history for this message
Robie Basak (racb) wrote :

James points out that we need a Breaks/Replaces to make sure the old package gets removed correctly, so adding a task for that, too.

Revision history for this message
Robie Basak (racb) wrote :

12:24 <hazmat> rbasak, should be fine.. i'll double check re changes
12:24 <hazmat> rbasak, yup that's fine.. i use that version already

[...]

12:32 <jamespage> rbasak, I can confirm that python-jujuclient appears functional with python-websocket

Revision history for this message
Robie Basak (racb) wrote :

To clarify this in my own head, the tasks are:

1. src:python-jujuclient: fix depends (with pydist-override?)

2. src:websocket-client: Ubuntu delta for python-websocket binary to break/replace the old binary from src:python-websocket-client (binary python-websocket-client)

3. src:python-websocket-client: remove

Revision history for this message
Robie Basak (racb) wrote :

Patch for websocket-client in bug 1273865.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-jujuclient - 0.17.5-0ubuntu2

---------------
python-jujuclient (0.17.5-0ubuntu2) trusty; urgency=medium

  * Switch binary dependency from duplicate package
    python-websocket-client to canonical package python-websocket
    (LP: #1292502):
    - d/pydist-overrides: map websocket-client to binary package
      python-websocket.
    - d/control: drop explicit dependency on python-websocket-client and
      rely on ${python:Depends} instead.
  * Standards-Version: 3.9.5 (no changes required).
 -- Robie Basak <email address hidden> Mon, 17 Mar 2014 15:42:50 +0000

Changed in python-jujuclient (Ubuntu):
status: New → Fix Released
Robie Basak (racb) on 2014-03-17
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package websocket-client - 0.12.0-1ubuntu2

---------------
websocket-client (0.12.0-1ubuntu2) trusty; urgency=medium

  * d/p/skip-internet-tests: skip tests which require Internet access.
 -- Robie Basak <email address hidden> Mon, 17 Mar 2014 17:15:50 +0000

Changed in websocket-client (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-websocket-client (Ubuntu):
status: New → Confirmed
Revision history for this message
Colin Watson (cjwatson) wrote :

Removing packages from trusty:
        python-websocket-client 0.11.0-0ubuntu1 in trusty
                python-websocket-client 0.11.0-0ubuntu1 in trusty amd64
                python-websocket-client 0.11.0-0ubuntu1 in trusty arm64
                python-websocket-client 0.11.0-0ubuntu1 in trusty armhf
                python-websocket-client 0.11.0-0ubuntu1 in trusty i386
                python-websocket-client 0.11.0-0ubuntu1 in trusty powerpc
                python-websocket-client 0.11.0-0ubuntu1 in trusty ppc64el
Comment: requested by racb; superseded by python-websocket (src:websocket-client); LP: #1292502
Remove [y|N]? y
1 package successfully removed.

Changed in python-websocket-client (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers