python-wadllib ftbfs in raring

Bug #1132125 reported by Matthias Klose on 2013-02-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-wadllib (Debian)
Fix Released
Unknown
python-wadllib (Ubuntu)
High
Barry Warsaw
Raring
High
Barry Warsaw

Bug Description

see https://launchpad.net/ubuntu/+archive/test-rebuild-20121221/+build/4111165

running build_ext
/build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt
Doctest: README.txt ... /build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt:2: ResourceWarning: unclosed file <_io.BufferedReader name='/build/buildd/python-wadllib-1.3.0/src/wadllib/tests/data/launchpad-wadl.xml'>
  Copyright (C) 2008-2009 Canonical Ltd.
/build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt:1: ResourceWarning: unclosed file <_io.BufferedReader name='/build/buildd/python-wadllib-1.3.0/src/wadllib/tests/data/links-wadl.xml'>
  ..
/build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt:1: ResourceWarning: unclosed file <_io.BufferedReader name='/build/buildd/python-wadllib-1.3.0/src/wadllib/tests/data/data-types-wadl.xml'>
  ..
/build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt:1: ResourceWarning: unclosed file <_io.BufferedReader name='/build/buildd/python-wadllib-1.3.0/src/wadllib/tests/data/options-wadl.xml'>
  ..
/usr/lib/python3.3/doctest.py:2130: ResourceWarning: unclosed file <_io.BufferedReader name='/build/buildd/python-wadllib-1.3.0/src/wadllib/tests/data/multipart-binary-wadl.xml'>
  test.globs.clear()
FAIL

======================================================================
FAIL: /build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt
Doctest: README.txt
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python3.3/doctest.py", line 2154, in runTest
    raise self.failureException(self.format_failure(new.getvalue()))
AssertionError: Failed doctest test for README.txt
  File "/build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt", line 0

----------------------------------------------------------------------
File "/build/buildd/python-wadllib-1.3.0/src/wadllib/README.txt", line 536, in README.txt
Failed example:
    create_team_method.build_representation(
        display_name='Joe Bloggs', name='joebloggs')
Differences (ndiff with -expected +actual):
    - ('application/x-www-form-urlencoded', 'display_name=Joe+Bloggs&ws.op=newTeam&name=joebloggs')
    ? --------------
    + ('application/x-www-form-urlencoded', 'display_name=Joe+Bloggs&name=joebloggs&ws.op=newTeam')
    ? ++++++++++++++

----------------------------------------------------------------------
Ran 1 test in 0.171s

FAILED (failures=1)
make[1]: *** [test-python3.3] Error 1

Related branches

Matthias Klose (doko) on 2013-02-23
Changed in python-wadllib (Ubuntu Raring):
importance: Undecided → High
status: New → Confirmed
Barry Warsaw (barry) wrote :

Looks like a sort order dependency. I wonder if it's better to guarantee an order or parse the value in the test and check for dict equality.

Barry Warsaw (barry) wrote :

Note that there are other bogus sort order dependencies lurking in the README.txt.

Changed in python-wadllib (Ubuntu Raring):
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) on 2013-02-25
Changed in python-wadllib (Ubuntu Raring):
status: Confirmed → In Progress
Colin Watson (cjwatson) on 2013-02-25
summary: - python-wadlib ftbfs in raring
+ python-wadllib ftbfs in raring
Barry Warsaw (barry) on 2013-02-25
Changed in python-wadllib (Ubuntu Raring):
status: In Progress → Fix Released
Changed in python-wadllib (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.