Ubuntu

Segmentation Fault in python program using visual-python module

Reported by Luis Gregorio Navarro on 2011-05-25
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
python-visual (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python-visual

I have recently updated to Ubuntu 11.04, and I can no longer run visual-python related methods since I get segfault error.

lgnr@lgnr-desktop:~$ python
Python 2.7.1+ (r271:86832, Apr 11 2011, 18:13:53)
[GCC 4.5.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from visual import *
>>> a=sphere()
Violación de segmento
lgnr@lgnr-desktop:~$

Does anyone have this problem or has a bug report already been filled for this problem?. The only thing I have done is to update to 11.04 from 10.10 using the update manager.

Thanks,
Luis G. Navarro
P.S. Information about involved packages below:

lgnr@lgnr-desktop:~$ apt-cache policy python-visual
python-visual:
  Instalados: 1:5.12-1.1build2
  Candidato: 1:5.12-1.1build2
  Tabla de versión:
 *** 1:5.12-1.1build2 0
        500 http://mx.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages
        100 /var/lib/dpkg/status

lgnr@lgnr-desktop:~$ apt-cache policy python
python:
  Instalados: 2.7.1-0ubuntu5
  Candidato: 2.7.1-0ubuntu5
  Tabla de versión:
 *** 2.7.1-0ubuntu5 0
        500 http://mx.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status

lgnr@lgnr-desktop:~$ apt-cache policy gcc
gcc:
  Instalados: 4:4.5.2-1ubuntu3
  Candidato: 4:4.5.2-1ubuntu3
  Tabla de versión:
 *** 4:4.5.2-1ubuntu3 0
        500 http://mx.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status

darteaga (darteaga) wrote :

Same thing happens here. Tested on two different Ubuntu 11.04 machines (64 bits)

darteaga (darteaga) wrote :

It looks like that there is a problem with the proprietary drivers in Ubuntu Natty, so the problem it is not with python-visual. Try running 'glxgears'.

In the message: http://sourceforge.net/mailarchive/message.php?msg_id=27461234 a workaround is provided:

[SOLUTION]
Ok, problem has been solved: I de-activated using "ATI/AMD proprietary
FGLRX graphics driver" and re-installed mesa-components, rebooted and
then glxgears as well as some of the pydy/examples-files runs great!

I can correctly run glxgears and even play some 3D games such as Nexuiz. I have a GTX 260, with NVIDIA driver 270.41.06, on a 64 bits system.

Changed in python-visual (Ubuntu):
status: New → Confirmed

I am having the same problem with segfaults in python-visual.

glx-gears and other 3D-accelerated programs work fine, and I am using the proprietary AMD video driver on 64-bit Ubuntu 11.04

loserock (loserock) wrote :

Totally same here. The glxgears and other 3D apps. (ex. games) run fine, because I use 'Sync to VBlank' for OpenGL applications (set it in nvidia-settings), bus without this, glxgears runs fuzzy. Vpython throws a 'seg. fault' on Ubuntu 11.04, when the vpython scene window appears (try this in python: from visual import * ; scene.visible=True ---> seg fault).
I use the last vpython (5.71, compilled from source, but the last .deb version from the repos. works same), on ubuntu 11.04 x64, with nvidia-current video driver (Geforce7000M, driver version: 280.13-0ubuntu1~natty~xup1).

When I removed the closed source nvidia driver and reinstalled mesa-tools/mesa-tools-extra, vpython 5.71 runs well (!), however runs very slowly. After that I reenabled nvidia-current (and xorg.conf), and I see the same seg. fault error.

The situation is funny, because vpython runs in windows under VirtualBox (in same ubuntu system), and it was runing a month ago with nvidia-current driver.

jamesgoodsell (jamesgoodsell) wrote :

dito

I run into the same problem...
Is there any news about this issue ?

no news at all ?

Tuomas (tuma+sec) wrote :

Still no solution or workaround?

still nothing?
Also segfaults in 12.04 in VirtualBox, with the "InnoTek Systemberatung GmbH VirtualBox Graphics Adapter".
glxgears runs fine

In my case, it seems to have been more or less solved by installing libgtkglextmm-x11-1.2-dev. Still showing artifacts though

Guy K. Kloss (guy.kloss) wrote :

This problem apparently affects people on (newer) Ubuntu versions, particularly when running proprietary graphics drivers. I can confirm it to affect Ubuntu Precise on 32 and 64 bit with NVIDIA drivers.

There has recently been some bug hunting on the Visual Python mailing list and John Zelle has found out what the probable problem is. The proposed fix seemes to have helped several users, by reverting to version 8.0.2 on libglapi-mesa, whereas currently 8.0.3 is installed. It seems like the proprietary drivers have been compiled against 8.0.2, so that any code using it segfaults against 8.0.3.

However, this might mean that the bug has got to be escalated elsewhere.

The mail in question is here:

https://sourceforge.net/mailarchive/message.php?msg_id=29790761

I have the proptietary ATI catalyst drivers and Ubuntu 11.04.
I kept getting seg faults when using python visual.
The libglapi-mesa workaround did not work, nor did installing libgtkglextmm-x11-1.2-dev.
what did work was relinking to libGL.so.

sudo rm /usr/lib/x86_64-linux-gnu/libGL.so
sudo ln -s /usr/lib/fglrx/libGL.so.1 /usr/lib/x86_64-linux-gnu/libGL.so

Xiaojun Ma (damage3025) on 2013-12-07
summary: - Segmentation Fault in python program using visual-python module after
- update to Natty Narwhal
+ Segmentation Fault in python program using visual-python module
Xiaojun Ma (damage3025) wrote :

I'm using NVIDIA binary driver on Ubuntu 12.04.

I still hit this problem.

On my system, NVIDIA's libGL.so cause segfault while Mesa's libGL works.

I'd prefer not to mess up with libGL.so linking so I do the following as workaround:
LD_PRELOAD=/usr/lib/x86_64-linux-gnu/mesa/libGL.so python

BTW, the package in Ubuntu (and Debian) is ridiculously oudated compare to upstream:
http://www.vpython.org/contents/download_linux.html

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers