package python-tz 2008b-3ubuntu1 failed to install/upgrade: subprocess post-installation script returned error exit status 1

Bug #320059 reported by Keith Hughitt on 2009-01-22
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
python-tz (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python-tz

sudo aptitude install python-matplotlib python-numpy python-tables

Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following NEW packages will be installed:
  python-dateutil{a} python-excelerator{a} python-matplotlib
  python-matplotlib-data{a} python-pyparsing{a} python-tables python-tz{a}
0 packages upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 4998kB of archives. After unpacking 19.9MB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://us.archive.ubuntu.com intrepid/main python-dateutil 1.4-1ubuntu2 [54.2kB]
Get:2 http://us.archive.ubuntu.com intrepid/universe python-excelerator 0.6.3a-3 [110kB]
Get:3 http://us.archive.ubuntu.com intrepid/universe python-matplotlib-data 0.98.3-4ubuntu1 [1123kB]
Get:4 http://us.archive.ubuntu.com intrepid/universe python-pyparsing 1.5.0-1 [576kB]
Get:5 http://us.archive.ubuntu.com intrepid/main python-tz 2008b-3ubuntu1 [27.8kB]
Get:6 http://us.archive.ubuntu.com intrepid/universe python-matplotlib 0.98.3-4ubuntu1 [2308kB]
Get:7 http://us.archive.ubuntu.com intrepid/universe python-tables 2.0.3-1build1 [798kB]
Fetched 4998kB in 3s (1602kB/s)
Selecting previously deselected package python-dateutil.
(Reading database ... 265794 files and directories currently installed.)
Unpacking python-dateutil (from .../python-dateutil_1.4-1ubuntu2_all.deb) ...
Selecting previously deselected package python-excelerator.
Unpacking python-excelerator (from .../python-excelerator_0.6.3a-3_all.deb) ...
Selecting previously deselected package python-matplotlib-data.
Unpacking python-matplotlib-data (from .../python-matplotlib-data_0.98.3-4ubuntu1_all.deb) ...
Selecting previously deselected package python-pyparsing.
Unpacking python-pyparsing (from .../python-pyparsing_1.5.0-1_all.deb) ...
Selecting previously deselected package python-tz.
Unpacking python-tz (from .../python-tz_2008b-3ubuntu1_all.deb) ...
Selecting previously deselected package python-matplotlib.
Unpacking python-matplotlib (from .../python-matplotlib_0.98.3-4ubuntu1_i386.deb) ...
Selecting previously deselected package python-tables.
Unpacking python-tables (from .../python-tables_2.0.3-1build1_i386.deb) ...
Processing triggers for man-db ...
Setting up python-dateutil (1.4-1ubuntu2) ...

Setting up python-excelerator (0.6.3a-3) ...

Setting up python-matplotlib-data (0.98.3-4ubuntu1) ...
Setting up python-pyparsing (1.5.0-1) ...

Setting up python-tz (2008b-3ubuntu1) ...
pycentral: pycentral pkginstall: not overwriting local files
pycentral pkginstall: not overwriting local files
dpkg: error processing python-tz (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python-matplotlib:
 python-matplotlib depends on python-tz; however:
  Package python-tz is not configured yet.
dpkg: error processing python-matplotlib (--configure):
 dependency problems - leaving unconfigured
Setting up python-tables (2.0.3-1build1) ...
No apport report written because the error message indicates its a followup error from a previous failure.

Processing triggers for python-support ...
Errors were encountered while processing:
 python-tz
 python-matplotlib
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up python-tz (2008b-3ubuntu1) ...
pycentral: pycentral pkginstall: not overwriting local files
pycentral pkginstall: not overwriting local files
dpkg: error processing python-tz (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python-matplotlib:
 python-matplotlib depends on python-tz; however:
  Package python-tz is not configured yet.
dpkg: error processing python-matplotlib (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-tz
 python-matplotlib
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

ProblemType: Package
Architecture: i386
DistroRelease: Ubuntu 8.10
ErrorMessage: subprocess post-installation script returned error exit status 1
NonfreeKernelModules: nvidia
Package: python-tz 2008b-3ubuntu1
PackageArchitecture: all
SourcePackage: python-tz
Title: package python-tz 2008b-3ubuntu1 failed to install/upgrade: subprocess post-installation script returned error exit status 1
Uname: Linux 2.6.27-9-generic i686

Keith Hughitt (keith-hughitt) wrote :
liza (norhasliza-yusof) wrote :

I have same error to but in Ubuntu 8.04 where I installed matplotlib using Synaptic Package Manager

Yaoqian (yaoqian) wrote :

When I update from Ubuntu 9.* to ubuntu 9.10, I got this problem. I try to reinstall it under ubuntu 9.10 and got error again.

Yaoqian (yaoqian) wrote :

I just get. You have to uninstall python-pz at first, and then install it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers