Missing rollover breaks windows PXE booting.

Bug #1476175 reported by Andres Rodriguez on 2015-07-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-tx-tftp (Ubuntu)
Critical
Unassigned
Trusty
Critical
Unassigned

Bug Description

[Impact]
The implementation of rollover allows transfers to reset the block number counter back to 0 after reaching 2^16, allowing to transfer files of any size. This is particularly useful when grabbing large files. This prevents MAAS from successfully installing windows based OS's.

[Test Case]
1. Install MAAS
2. Upload aa windows image.
3. Deploy windows with traidtional installer.
4. Without the fix, windows will fail to deploy.
5. With the fix, windows will deploy correctly.

[Regression Potential]
Minimal, this has been tested in various different environments and QA'd.

Changed in python-tx-tftp (Ubuntu):
status: New → Fix Released
Changed in python-tx-tftp (Ubuntu Trusty):
importance: Undecided → Critical

Hello Andres, or anyone else affected,

Accepted python-tx-tftp into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-tx-tftp/0.1~bzr38-0ubuntu4~14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-tx-tftp (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Changed in python-tx-tftp (Ubuntu):
importance: Undecided → Critical

The fix for this bug has been awaiting testing feedback in the -proposed repository for trusty for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Andres Rodriguez (andreserl) wrote :

This has been tested and we confirm that the package actually fixes the issue.

Marking verification-done.

Thanks

tags: added: verification-done
removed: removal-candidate verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-tx-tftp - 0.1~bzr38-0ubuntu4~14.04.1

---------------
python-tx-tftp (0.1~bzr38-0ubuntu4~14.04.1) trusty-proposed; urgency=medium

  * debian/patches/05_lp1317705.patch: Regonise error code 8, which is
    used to terminate a transfer due to option negotiation.
    See RFC 2347, "TFTP Option Extension". (LP: #1317705)

python-tx-tftp (0.1~bzr38-0ubuntu3) utopic; urgency=medium

  * debian/patches/04-implement-rollover.patch: Resets the block number
    counter back to 0 after it reaches 2^16. (LP: #1476175)

 -- Andres Rodriguez <email address hidden> Mon, 22 Jun 2015 12:33:26 -0400

Changed in python-tx-tftp (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for python-tx-tftp has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers