deprecation of python-support

Bug #1535318 reported by Graham Inggs
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Lernid
Undecided
Unassigned
cx-freeze (Ubuntu)
Undecided
Unassigned
dvdrip-queue (Ubuntu)
Undecided
Unassigned
empcommand (Ubuntu)
Undecided
Unassigned
firmware-addon-dell (Ubuntu)
Undecided
Unassigned
firmware-extract (Ubuntu)
Undecided
Unassigned
firmware-tools (Ubuntu)
Undecided
Unassigned
gnome-lirc-properties (Ubuntu)
Undecided
Unassigned
gpixpod (Ubuntu)
Undecided
Unassigned
indiv-screenlets (Ubuntu)
Undecided
Unassigned
lernid (Ubuntu)
Undecided
Graham Inggs
libdigidocpp (Ubuntu)
Undecided
Unassigned
malbolge (Ubuntu)
Undecided
Unassigned
ncrypt (Ubuntu)
Undecided
Unassigned
openmeeg (Debian)
Fix Released
Unknown
openmeeg (Ubuntu)
Undecided
Unassigned
pybootchartgui (Ubuntu)
Undecided
Unassigned
pymt (Ubuntu)
Undecided
Unassigned
pyrocket (Ubuntu)
Undecided
Unassigned
python-cogent (Debian)
Fix Released
Unknown
python-cogent (Ubuntu)
Undecided
Unassigned
python-peak.rules (Debian)
Fix Released
Unknown
python-peak.rules (Ubuntu)
Undecided
Unassigned
python-peak.util (Debian)
Fix Released
Unknown
python-peak.util (Ubuntu)
Undecided
Unassigned
python-rackspace-cloudservers (Ubuntu)
Undecided
Unassigned
python-simplesettings (Ubuntu)
Undecided
Unassigned
python-support (Ubuntu)
High
Matthias Klose
python-xdgapp (Ubuntu)
Undecided
Unassigned
qdigidoc (Ubuntu)
Undecided
Unassigned
sadms (Ubuntu)
Undecided
Unassigned
system-config-date (Ubuntu)
Undecided
Unassigned

Bug Description

python-support is deprecated and has been replaced by dh_python2
python-support was removed from Debian unstable on 2015-12-28 (see https://bugs.debian.org/746741 ) and from Debian testing on 2016-01-26

This bug is to track the last remaining packages depending on python-support in Ubuntu

For help with converting packages, please see:
https://wiki.debian.org/Python/TransitionToDHPython2

Packages in Debian and Ubuntu
=============================

python-cogent already fixed and waiting to migrate from -proposed on python-numpy

openmeeg removed from Debian testing on 2013-12-30
reverse-recommends: med-imaging med-imaging-dev science-neuroscience-cognitive

python-peak.rules removed from Debian testing on 2016-01-15
reverse-depends: turbojson python-tubojson

python-peak.util removed from Debian testing on 2016-01-15
reverse-depends: python-peak.rules

Packages in Ubuntu only
=======================

firmware-tools reverse-depends: firmware-addon-dell firmware-extract

screenlets-pack-basic reverse-recommends: screenlets

libdigidocpp0 reverse-depends: qdigidoc
libdigidocpp0-dev reverse-build-depends: qdigidoc

pybootchartgui reverse-depends: bootchart phablet-tools
the following note is in sync-blacklist:
"bootchart # keybuk, entirely separate packaging
bootchart2 # cjwatson, ditto; our bootchart source has many of the improvements here, and the pybootchartgui binary clashes"
To be removed after 16.04? LP: #1353587 Why not in 16.04?

python-pymtp reverse-depends: keysync

the remaining packages have no reverse dependencies

Related branches

Changed in python-cogent (Debian):
status: Unknown → Fix Released
Changed in python-peak.rules (Debian):
status: Unknown → New
Changed in python-peak.util (Debian):
status: Unknown → New
Changed in openmeeg (Debian):
status: Unknown → New
Graham Inggs (ginggs)
description: updated
Graham Inggs (ginggs)
description: updated
Graham Inggs (ginggs)
description: updated
Revision history for this message
Martin Pitt (pitti) wrote :

I removed system-config-date, it's totally obsolete.

Changed in system-config-date (Ubuntu):
status: New → Fix Released
Revision history for this message
John S. Gruber (jsjgruber) wrote :

No longer using python-support (assuming dh_python2 is present on the building system, as it should be for all supported Ubuntu systems building packages that have a build-dep on python).

As far as I can tell lernid is no longer in use.

Changed in lernid (Ubuntu):
status: New → Fix Released
Revision history for this message
John S. Gruber (jsjgruber) wrote :
Revision history for this message
Graham Inggs (ginggs) wrote :

> No longer using python-support (assuming dh_python2 is present on the
> building system, as it should be for all supported Ubuntu systems building
> packages that have a build-dep on python).

lernid still has a build-dependency on python-support [1]:

Source: lernid
Section: net
Priority: extra
Build-Depends:
 debhelper (>= 7.0.50~),
 python (>= 2.6),
 python-support
Build-Depends-Indep: python-distutils-extra (>= 2.10)
Maintainer: John S Gruber <email address hidden>
Standards-Version: 3.9.3.1
X-Python-Version: >=2.6

> As far as I can tell lernid is no longer in use.

Requesting lernid's removal is one way to fix the problem.

[1] http://bazaar.launchpad.net/~lernid-devs/lernid/trunk/view/head:/debian/control

Changed in lernid (Ubuntu):
status: Fix Released → New
Changed in lernid (Ubuntu):
assignee: nobody → John S. Gruber (jsjgruber)
status: New → Confirmed
Changed in lernid:
assignee: nobody → John S. Gruber (jsjgruber)
status: New → In Progress
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Fixed in 1.0.2

Changed in lernid:
assignee: John S. Gruber (jsjgruber) → nobody
status: In Progress → Fix Released
Changed in lernid (Ubuntu):
assignee: John S. Gruber (jsjgruber) → nobody
Revision history for this message
John S. Gruber (jsjgruber) wrote :

@Graham Sorry about my mistake--I had looked at the wrong release.

I've fixed upstream Lernid, tested, and released it as 1.0.2. I built it for xenial only. I see you have MOTU privileges. Would you mind taking care of Lernid(Ubuntu) with a copy or rebuild? No Ubuntu changes are necessary.

Here's the buildlog: https://launchpad.net/~lernid-devs/+archive/ubuntu/lernid-releases/+build/8888504/+files/buildlog_ubuntu-xenial-amd64.lernid_1.0.2_BUILDING.txt.gz

Here's the new debian/control:

Source: lernid
Section: net
Priority: extra
Build-Depends:
 debhelper (>= 7.0.50~),
 python (>= 2.6),
Build-Depends-Indep: python-distutils-extra (>= 2.10)
Maintainer: John S Gruber <email address hidden>
Standards-Version: 3.9.3.1
X-Python-Version: >=2.6

Package: lernid
Architecture: all
Depends: ${misc:Depends},
 ${python:Depends},
 telepathy-idle,
 python-xdg,
 python-telepathy,
 python-webkit,
 python-dbus,
 python-notify,
 python-gobject,
 python-vobject,
 python-gtk2,
 python-poppler,
Recommends:
 python-vte,
 python-appindicator
Description: client to easily connect to Ubuntu classroom events
 Lernid provides an interface for joining in Ubuntu learning events such
 as Ubuntu Open Week and Ubuntu Developer Week.

The package is built in: https://launchpad.net/~lernid-devs/+archive/ubuntu/lernid-releases/+packages

The source is in: https://code.launchpad.net/~lernid-devs/lernid/trunk

I elected to fix it as I'm unaware that a decision has been taken to discontinue use of #ubuntu-classroom; it simply seems to have fallen into disuse.

Please let me know if I've missed anything or you need anything else from me.

Revision history for this message
Graham Inggs (ginggs) wrote :

> I've fixed upstream Lernid, tested, and released it as 1.0.2.

Great!

> Would you mind taking care of Lernid(Ubuntu) with a copy or rebuild?

Sure, I will take a look.

Thanks for your work on this!

Changed in lernid (Ubuntu):
assignee: nobody → Graham Inggs (ginggs)
status: Confirmed → In Progress
Revision history for this message
Graham Inggs (ginggs) wrote :

Hi John

I've had a look at the lernid 1.0.2packaging.

Please have a look at this guide to the dh_python2 transition:
https://wiki.debian.org/Python/TransitionToDHPython2

"debian/control - Replace python-central or python-support with dh-python in Build-Depends."
Please add dh-python package to Build-Depends

"debian/control - XS-Python-Version is still supported, but X-Python-Version is preferred. ...
If you don't know what the package's minimum required Python version is, don't add this field ..."

"debian/pycompat - Remove this file (this should have been done long ago). "

Some other complaints from Lintian (I won't insist you fix these):

package-uses-old-debhelper-compat-version 6
syntax-error-in-dep5-copyright line 7: Duplicate field copyright
ancient-standards-version 3.9.3.1 (current is 3.9.6)
desktop-entry-lacks-keywords-entry usr/share/applications/lernid.desktop

Regards
Graham

Changed in lernid:
assignee: nobody → John S. Gruber (jsjgruber)
status: Fix Released → In Progress
Graham Inggs (ginggs)
description: updated
Revision history for this message
John S. Gruber (jsjgruber) wrote :

Fixed in upstream 1.0.4

Changed in lernid:
assignee: John S. Gruber (jsjgruber) → nobody
status: In Progress → Fix Released
Revision history for this message
John S. Gruber (jsjgruber) wrote :

@Graham I had a bit of trouble with the build system, but I think I've covered what you asked for.

I have released upstream at version 1.0.4 at ppa:lernid-devs/lernid-releases

The build page is: https://launchpad.net/~lernid-devs/+archive/ubuntu/lernid-releases/+build/8905669

debian/control:

Source: lernid
Section: net
Priority: extra
Build-Depends:
 debhelper (>= 7.0.50~),
 python (>= 2.6),
 dh-python,
Build-Depends-Indep: python-distutils-extra (>= 2.10)
Maintainer: John S Gruber <email address hidden>
Standards-Version: 3.9.6
X-Python-Version: >=2.6

Package: lernid
Architecture: all
Depends: ${misc:Depends},
 ${python:Depends},
 telepathy-idle,
 python-xdg,
 python-telepathy,
 python-webkit,
 python-dbus,
 python-notify,
 python-gobject,
 python-vobject,
 python-gtk2,
 python-poppler,
Recommends:
 python-vte,
 python-appindicator
Description: client to easily connect to Ubuntu classroom events
 Lernid provides an interface for joining in Ubuntu learning events such
 as Ubuntu Open Week and Ubuntu Developer Week. The Lernid program presents
 session IRC windows for classroom and chat, and optionally presents
 slides, web pages, a terminal session, and the event schedule.

The source is in: https://code.launchpad.net/~lernid-devs/lernid/trunk

Diff between the last and this one is at https://launchpadlibrarian.net/235477199/lernid_1.0.2_1.0.4.diff.gz

No changes should be needed between the upstream and Ubuntu versions.

In particular I removed the debian/pycompat file and added the dh-python build dependency. I also addressed all of the lintian -I complaints I found. XS-Python-Version had already been replaced by X-Python-Version. I think it should be ok at the debian 3.9.6 standards level.

Could you check it to see if I've gotten it right or whether there's more for me to do?

Thanks much.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lernid - 1.0.4

---------------
lernid (1.0.4) xenial; urgency=medium

  * Change version number to enable recipe building

lernid (1.0.3~1) wily; urgency=medium

  * Make Further changes to bring packaging up-to-date. lp: #1535318

lernid (1.0.2) xenial; urgency=medium

  * Remove python-support dependency and condition on use of dh_python2.
    Fixes lp: #1535318

 -- John S Gruber <email address hidden> Wed, 27 Jan 2016 09:11:08 -0500

Changed in lernid (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Graham Inggs (ginggs) wrote :

@ubuntu-archive: can we start by removing the packages already removed from Debian please?

openmeeg
python-peak.rules
python-peak.util
turbojson

Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 openmeeg 2.0.0.dfsg-5.1ubuntu1 in xenial
  libopenmeeg-dev 2.0.0.dfsg-5.1ubuntu1 in xenial amd64
  libopenmeeg-dev 2.0.0.dfsg-5.1ubuntu1 in xenial armhf
  libopenmeeg-dev 2.0.0.dfsg-5.1ubuntu1 in xenial i386
  libopenmeeg-dev 2.0.0.dfsg-5.1ubuntu1 in xenial powerpc
  libopenmeeg1 2.0.0.dfsg-5.1ubuntu1 in xenial amd64
  libopenmeeg1 2.0.0.dfsg-5.1ubuntu1 in xenial armhf
  libopenmeeg1 2.0.0.dfsg-5.1ubuntu1 in xenial i386
  libopenmeeg1 2.0.0.dfsg-5.1ubuntu1 in xenial powerpc
  openmeeg-tools 2.0.0.dfsg-5.1ubuntu1 in xenial amd64
  openmeeg-tools 2.0.0.dfsg-5.1ubuntu1 in xenial armhf
  openmeeg-tools 2.0.0.dfsg-5.1ubuntu1 in xenial i386
  openmeeg-tools 2.0.0.dfsg-5.1ubuntu1 in xenial powerpc
  python-openmeeg 2.0.0.dfsg-5.1ubuntu1 in xenial amd64
  python-openmeeg 2.0.0.dfsg-5.1ubuntu1 in xenial armhf
  python-openmeeg 2.0.0.dfsg-5.1ubuntu1 in xenial i386
  python-openmeeg 2.0.0.dfsg-5.1ubuntu1 in xenial powerpc
Comment: removed from Debian, no reverse dependencies, uses python-support; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in openmeeg (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 turbojson 1.3.2-2.1 in xenial
  python-turbojson 1.3.2-2.1 in xenial amd64
  python-turbojson 1.3.2-2.1 in xenial arm64
  python-turbojson 1.3.2-2.1 in xenial armhf
  python-turbojson 1.3.2-2.1 in xenial i386
  python-turbojson 1.3.2-2.1 in xenial powerpc
  python-turbojson 1.3.2-2.1 in xenial ppc64el
  python-turbojson 1.3.2-2.1 in xenial s390x
Comment: Depends on python-peak.rules, RC buggy in Debian, depends on python-support; Debian bug #798059
Remove [y|N]? y
1 package successfully removed.

Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 python-peak.rules 0.5a1+r2707-1fakesync1 in xenial
  python-peak.rules 0.5a1+r2707-1fakesync1 in xenial amd64
  python-peak.rules 0.5a1+r2707-1fakesync1 in xenial arm64
  python-peak.rules 0.5a1+r2707-1fakesync1 in xenial armhf
  python-peak.rules 0.5a1+r2707-1fakesync1 in xenial i386
  python-peak.rules 0.5a1+r2707-1fakesync1 in xenial powerpc
  python-peak.rules 0.5a1+r2707-1fakesync1 in xenial ppc64el
  python-peak.rules 0.5a1+r2707-1fakesync1 in xenial s390x
Comment: Removed from Debian testing, depends on python-support which is deprecated; Debian bug #786173
Remove [y|N]? y
1 package successfully removed.

Changed in python-peak.rules (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 python-peak.util 20110909-1 in xenial
  python-peak.util 20110909-1 in xenial amd64
  python-peak.util 20110909-1 in xenial arm64
  python-peak.util 20110909-1 in xenial armhf
  python-peak.util 20110909-1 in xenial i386
  python-peak.util 20110909-1 in xenial powerpc
  python-peak.util 20110909-1 in xenial ppc64el
  python-peak.util 20110909-1 in xenial s390x
Comment: Removed from Debian testing, depends on python-support which is deprecated; Debian bug #786317
Remove [y|N]? y
1 package successfully removed.

Changed in python-peak.util (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 dvdrip-queue 0.1.3-0.1ubuntu2 in xenial
  dvdrip-queue 0.1.3-0.1ubuntu2 in xenial amd64
  dvdrip-queue 0.1.3-0.1ubuntu2 in xenial arm64
  dvdrip-queue 0.1.3-0.1ubuntu2 in xenial armhf
  dvdrip-queue 0.1.3-0.1ubuntu2 in xenial i386
  dvdrip-queue 0.1.3-0.1ubuntu2 in xenial powerpc
  dvdrip-queue 0.1.3-0.1ubuntu2 in xenial ppc64el
  dvdrip-queue 0.1.3-0.1ubuntu2 in xenial s390x
Comment: Depends on deprecated python-support, no maintainer in Ubuntu, never in Debian, imported from deb-multimedia.org and never updated; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in dvdrip-queue (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 cx-freeze 4.3.1-0ubuntu1 in xenial
  cx-freeze 4.3.1-0ubuntu1 in xenial amd64
  cx-freeze 4.3.1-0ubuntu1 in xenial arm64
  cx-freeze 4.3.1-0ubuntu1 in xenial armhf
  cx-freeze 4.3.1-0ubuntu1 in xenial i386
  cx-freeze 4.3.1-0ubuntu1 in xenial powerpc
  cx-freeze 4.3.1-0ubuntu1 in xenial ppc64el
  cx-freeze 4.3.1-0ubuntu1 in xenial s390x
Comment: Depends on deprecated python-support, no reverse dependencies, no maintainer in Ubuntu, never in Debian, python2 only; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 empcommand 0.3+svn6617-0ubuntu1 in xenial
  empcommand 0.3+svn6617-0ubuntu1 in xenial amd64
  empcommand 0.3+svn6617-0ubuntu1 in xenial arm64
  empcommand 0.3+svn6617-0ubuntu1 in xenial armhf
  empcommand 0.3+svn6617-0ubuntu1 in xenial i386
  empcommand 0.3+svn6617-0ubuntu1 in xenial powerpc
  empcommand 0.3+svn6617-0ubuntu1 in xenial ppc64el
  empcommand 0.3+svn6617-0ubuntu1 in xenial s390x
Comment: Depends on deprecated python-support, no reverse dependencies, no maintainer in Ubuntu, never in Debian, no update since precise; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in cx-freeze (Ubuntu):
status: New → Fix Released
Changed in empcommand (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 firmware-extract 2.0.13-0ubuntu1 in xenial
  firmware-extract 2.0.13-0ubuntu1 in xenial amd64
  firmware-extract 2.0.13-0ubuntu1 in xenial arm64
  firmware-extract 2.0.13-0ubuntu1 in xenial armhf
  firmware-extract 2.0.13-0ubuntu1 in xenial i386
  firmware-extract 2.0.13-0ubuntu1 in xenial powerpc
  firmware-extract 2.0.13-0ubuntu1 in xenial ppc64el
  firmware-extract 2.0.13-0ubuntu1 in xenial s390x
Comment: Depends on deprecated python-support, no reverse dependencies, no maintainer in Ubuntu, never in Debian, no updates since maverick; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 gnome-lirc-properties 0.5.1-0ubuntu1 in xenial
  gnome-lirc-properties 0.5.1-0ubuntu1 in xenial amd64
  gnome-lirc-properties 0.5.1-0ubuntu1 in xenial arm64
  gnome-lirc-properties 0.5.1-0ubuntu1 in xenial armhf
  gnome-lirc-properties 0.5.1-0ubuntu1 in xenial i386
  gnome-lirc-properties 0.5.1-0ubuntu1 in xenial powerpc
  gnome-lirc-properties 0.5.1-0ubuntu1 in xenial ppc64el
  gnome-lirc-properties 0.5.1-0ubuntu1 in xenial s390x
Comment: Depends on deprecated python-support, no reverse dependencies, never in Debian, no updates since maverick; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in gnome-lirc-properties (Ubuntu):
status: New → Fix Released
Changed in firmware-extract (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 gpixpod 0.6.2-0ubuntu8 in xenial
  gpixpod 0.6.2-0ubuntu8 in xenial amd64
  gpixpod 0.6.2-0ubuntu8 in xenial arm64
  gpixpod 0.6.2-0ubuntu8 in xenial armhf
  gpixpod 0.6.2-0ubuntu8 in xenial i386
  gpixpod 0.6.2-0ubuntu8 in xenial powerpc
  gpixpod 0.6.2-0ubuntu8 in xenial ppc64el
  gpixpod 0.6.2-0ubuntu8 in xenial s390x
Comment: Depends on deprecated python-support, no reverse dependencies, never in Debian, no updates since natty; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in gpixpod (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 malbolge 0.2-0ubuntu1 in xenial
  malbolge 0.2-0ubuntu1 in xenial amd64
  malbolge 0.2-0ubuntu1 in xenial arm64
  malbolge 0.2-0ubuntu1 in xenial armhf
  malbolge 0.2-0ubuntu1 in xenial i386
  malbolge 0.2-0ubuntu1 in xenial powerpc
  malbolge 0.2-0ubuntu1 in xenial ppc64el
  malbolge 0.2-0ubuntu1 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, no updates since jaunty; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in malbolge (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 ncrypt 0.6.4-0ubuntu8 in xenial
  python-ncrypt 0.6.4-0ubuntu8 in xenial amd64
  python-ncrypt 0.6.4-0ubuntu8 in xenial arm64
  python-ncrypt 0.6.4-0ubuntu8 in xenial armhf
  python-ncrypt 0.6.4-0ubuntu8 in xenial i386
  python-ncrypt 0.6.4-0ubuntu8 in xenial powerpc
  python-ncrypt 0.6.4-0ubuntu8 in xenial ppc64el
  python-ncrypt 0.6.4-0ubuntu8 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, python2 only, no updates since precise; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in ncrypt (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 pymt 0.5.1-0ubuntu3 in xenial
  python-pymt 0.5.1-0ubuntu3 in xenial amd64
  python-pymt 0.5.1-0ubuntu3 in xenial arm64
  python-pymt 0.5.1-0ubuntu3 in xenial armhf
  python-pymt 0.5.1-0ubuntu3 in xenial i386
  python-pymt 0.5.1-0ubuntu3 in xenial powerpc
  python-pymt 0.5.1-0ubuntu3 in xenial ppc64el
  python-pymt 0.5.1-0ubuntu3 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, python2 only, no updates since natty; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in pymt (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 pyrocket 0.6-0ubuntu3 in xenial
  pyrocket 0.6-0ubuntu3 in xenial amd64
  pyrocket 0.6-0ubuntu3 in xenial arm64
  pyrocket 0.6-0ubuntu3 in xenial armhf
  pyrocket 0.6-0ubuntu3 in xenial i386
  pyrocket 0.6-0ubuntu3 in xenial powerpc
  pyrocket 0.6-0ubuntu3 in xenial ppc64el
  pyrocket 0.6-0ubuntu3 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, no updates since maverick; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in pyrocket (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial
  python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial amd64
  python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial arm64
  python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial armhf
  python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial i386
  python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial powerpc
  python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial ppc64el
  python-rackspace-cloudservers 1.0~a5-0ubuntu3 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, no real updates since lucid; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in python-rackspace-cloudservers (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 python-simplesettings 0.5-0ubuntu2 in xenial
  python-simplesettings 0.5-0ubuntu2 in xenial amd64
  python-simplesettings 0.5-0ubuntu2 in xenial arm64
  python-simplesettings 0.5-0ubuntu2 in xenial armhf
  python-simplesettings 0.5-0ubuntu2 in xenial i386
  python-simplesettings 0.5-0ubuntu2 in xenial powerpc
  python-simplesettings 0.5-0ubuntu2 in xenial ppc64el
  python-simplesettings 0.5-0ubuntu2 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, no updates since precise; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in python-simplesettings (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 python-xdgapp 1.1-1build1 in xenial
  python-xdgapp 1.1-1build1 in xenial amd64
  python-xdgapp 1.1-1build1 in xenial arm64
  python-xdgapp 1.1-1build1 in xenial armhf
  python-xdgapp 1.1-1build1 in xenial i386
  python-xdgapp 1.1-1build1 in xenial powerpc
  python-xdgapp 1.1-1build1 in xenial ppc64el
  python-xdgapp 1.1-1build1 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, no updates since precise, python2 only; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in python-xdgapp (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 sadms 2.0.15.repack-0ubuntu2 in xenial
  sadms 2.0.15.repack-0ubuntu2 in xenial amd64
  sadms 2.0.15.repack-0ubuntu2 in xenial arm64
  sadms 2.0.15.repack-0ubuntu2 in xenial armhf
  sadms 2.0.15.repack-0ubuntu2 in xenial i386
  sadms 2.0.15.repack-0ubuntu2 in xenial powerpc
  sadms 2.0.15.repack-0ubuntu2 in xenial ppc64el
  sadms 2.0.15.repack-0ubuntu2 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, no updates since natty; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in sadms (Ubuntu):
status: New → Fix Released
Graham Inggs (ginggs)
Changed in python-cogent (Ubuntu):
status: New → Fix Committed
Changed in python-peak.util (Debian):
status: New → Fix Committed
Changed in python-peak.rules (Debian):
status: New → Fix Committed
Changed in python-peak.util (Debian):
status: Fix Committed → Fix Released
Changed in python-peak.rules (Debian):
status: Fix Committed → Fix Released
Revision history for this message
Steve Langasek (vorlon) wrote :

Removing packages from xenial:
 indiv-screenlets 0.1.6-0ubuntu1 in xenial
  screenlets-pack-all 0.1.6-0ubuntu1 in xenial amd64
  screenlets-pack-all 0.1.6-0ubuntu1 in xenial arm64
  screenlets-pack-all 0.1.6-0ubuntu1 in xenial armhf
  screenlets-pack-all 0.1.6-0ubuntu1 in xenial i386
  screenlets-pack-all 0.1.6-0ubuntu1 in xenial powerpc
  screenlets-pack-all 0.1.6-0ubuntu1 in xenial ppc64el
  screenlets-pack-all 0.1.6-0ubuntu1 in xenial s390x
  screenlets-pack-basic 0.1.6-0ubuntu1 in xenial amd64
  screenlets-pack-basic 0.1.6-0ubuntu1 in xenial arm64
  screenlets-pack-basic 0.1.6-0ubuntu1 in xenial armhf
  screenlets-pack-basic 0.1.6-0ubuntu1 in xenial i386
  screenlets-pack-basic 0.1.6-0ubuntu1 in xenial powerpc
  screenlets-pack-basic 0.1.6-0ubuntu1 in xenial ppc64el
  screenlets-pack-basic 0.1.6-0ubuntu1 in xenial s390x
Comment: Depends on deprecated python-support, no reverse-dependencies, never in Debian, no update since precise; LP: #1535318
Remove [y|N]? y
1 package successfully removed.

Changed in indiv-screenlets (Ubuntu):
status: New → Fix Released
Revision history for this message
Graham Inggs (ginggs) wrote :

python-cogent 1.5.3-10 released

Changed in python-cogent (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Graham Inggs (ginggs) wrote :

Remaining reverse dependencies:

Reverse-Depends
===============
* firmware-addon-dell (for firmware-tools)

Reverse-Depends
===============
* qdigidoc (for libdigidocpp0)

Reverse-Recommends
==================
* bootchart (for pybootchartgui)
* phablet-tools (for pybootchartgui)

Changed in firmware-addon-dell (Ubuntu):
status: New → Fix Released
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

firmware-addon-dell uses dh_python2 as far as I can see.

Changed in firmware-tools (Ubuntu):
status: New → Fix Committed
Changed in pybootchartgui (Ubuntu):
status: New → Fix Committed
Changed in qdigidoc (Ubuntu):
status: New → Fix Released
Changed in libdigidocpp (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package firmware-tools - 2.1.14-0ubuntu2

---------------
firmware-tools (2.1.14-0ubuntu2) xenial; urgency=medium

  * Use dh_python2. LP: #1535318.

 -- Dimitri John Ledkov <email address hidden> Tue, 23 Feb 2016 13:19:52 +0000

Changed in firmware-tools (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pybootchartgui - 0+r141-0ubuntu6

---------------
pybootchartgui (0+r141-0ubuntu6) xenial; urgency=medium

  * Use dh-python2. LP: #1535318.

 -- Dimitri John Ledkov <email address hidden> Tue, 23 Feb 2016 13:44:47 +0000

Changed in pybootchartgui (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Dimitri John Ledkov (xnox) wrote :

Please remove python-support from xenial

Changed in python-support (Ubuntu):
importance: Undecided → High
status: New → Triaged
assignee: nobody → Matthias Klose (doko)
Revision history for this message
Matthias Klose (doko) wrote :

Removing packages from xenial:
 python-support 1.0.15 in xenial
  python-support 1.0.15 in xenial amd64
  python-support 1.0.15 in xenial arm64
  python-support 1.0.15 in xenial armhf
  python-support 1.0.15 in xenial i386
  python-support 1.0.15 in xenial powerpc
  python-support 1.0.15 in xenial ppc64el
  python-support 1.0.15 in xenial s390x
Comment: fiiiiinally, lp: #1535318, remove python-support
1 package successfully removed.

Changed in python-support (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :
Changed in libdigidocpp (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Colin Watson (cjwatson) wrote :

Unsubscribing ubuntu-archive; we don't need to have this on our to-do list for the sake of the one remaining Debian task on this bug. Feel free to resubscribe us if there are any further actions for us to take.

Changed in openmeeg (Debian):
status: New → Fix Released
tags: added: id-59f0f672ddc8e97eb1fa4064
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.