plasma-desktop crashed with SIGSEGV in QHash<void*, PyQtProxy*>::duplicateNode()

Bug #905614 reported by tek on 2011-12-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-qt4 (Ubuntu)
Medium
Unassigned

Bug Description

Not sure what or why but I am getting crashes and with 4 gigs of ram the system keeps swapping out to disk till it will crash

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: plasma-desktop 4:4.7.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-14.23-generic 3.0.9
Uname: Linux 3.0.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Fri Dec 16 17:15:14 2011
ExecutablePath: /usr/bin/plasma-desktop
InstallationMedia: Kubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
ProcCmdline: /usr/bin/plasma-desktop --nocrashhandler
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7fb736a190f5: mov 0x10(%rdi),%rax
 PC (0x7fb736a190f5) ok
 source "0x10(%rdi)" (0x00000010) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: kde-workspace
StacktraceTop:
 ?? () from /usr/lib/python2.7/dist-packages/PyQt4/QtCore.so
 QHashData::detach_helper2 (this=0x2c58970, node_duplicate=0x7fb736a190f0, node_delete=0x7fb736a190e0, nodeSize=<optimized out>, nodeAlign=8) at tools/qhash.cpp:235
 ?? () from /usr/lib/python2.7/dist-packages/PyQt4/QtCore.so
 ?? () from /usr/lib/python2.7/dist-packages/sip.so
 ?? () from /usr/lib/libpython2.7.so.1.0
Title: plasma-desktop crashed with SIGSEGV in QHashData::detach_helper2()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (npviewer.bin:23745): Gtk-CRITICAL **: IA__gtk_window_get_type_hint: assertion `GTK_IS_WINDOW (window)' failed
 (npviewer.bin:23745): Gtk-CRITICAL **: IA__gtk_window_get_decorated: assertion `GTK_IS_WINDOW (window)' failed
 (npviewer.bin:23745): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

tek (tek-pervasivenetwerks) wrote :

StacktraceTop:
 QHash<void*, PyQtProxy*>::duplicateNode(QHashData::Node*, void*) () from /tmp/tmp1yr1xM/usr/lib/python2.7/dist-packages/PyQt4/QtCore.so
 QHashData::detach_helper2 (this=0x2c58970, node_duplicate=0x7fb736a190f0 <QHash<void*, PyQtProxy*>::duplicateNode(QHashData::Node*, void*)>, node_delete=0x7fb736a190e0 <QHash<void*, PyQtProxy*>::deleteNode2(QHashData::Node*)>, nodeSize=<optimized out>, nodeAlign=8) at tools/qhash.cpp:235
 sipQtFindSipslot () from /tmp/tmp1yr1xM/usr/lib/python2.7/dist-packages/PyQt4/QtCore.so
 sipWrapper_traverse (arg=0x0, visit=0x7fb737610620 <visit_decref>, self=0x2d864d0) at /build/buildd/sip4-4.12.4/siplib/siplib.c:9648
 sipWrapper_traverse (self=0x2d864d0, visit=0x7fb737610620 <visit_decref>, arg=0x0) at /build/buildd/sip4-4.12.4/siplib/siplib.c:9629

Changed in kde-workspace (Ubuntu):
importance: Undecided → Medium
summary: - plasma-desktop crashed with SIGSEGV in QHashData::detach_helper2()
+ plasma-desktop crashed with SIGSEGV in QHash<void*,
+ PyQtProxy*>::duplicateNode()
tags: removed: need-amd64-retrace
affects: kde-workspace (Ubuntu) → python-qt4 (Ubuntu)
visibility: private → public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers