software-properties-kde crash

Bug #486319 reported by danutzdobrescu on 2009-11-21
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-qt4 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python-qt4

danutz@compy:~$ sudo software-properties-kde
Traceback (most recent call last):
  File "/usr/bin/software-properties-kde", line 122, in <module>
    app = SoftwarePropertiesKDE(datadir=data_dir, options=options, file=file, attachWinID=attachWinID)
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 104, in __init__
    self.show_keys()
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 606, in show_keys
    self.userinterface.treeview2.addTopLevelItem(QTreeWidgetItem([utf8(key)]))
  File "/usr/lib/python2.6/dist-packages/softwareproperties/kde/SoftwarePropertiesKDE.py", line 57, in utf8
    return unicode(str, 'UTF-8')
  File "/usr/lib/python2.6/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 45-46: invalid data
Exception TypeError: TypeError("'NoneType' object is not callable",) in <bound method Popen.__del__ of <subprocess.Popen object at 0xa845eec>> ignored

I've tried reinstalling python-qt4, but without any result ..
I'm running Karmic Koala 32bit, up to date... i've seen on some external forums the same error but i didn't found any result

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers