package python-qt4 4.11.4+dfsg-1build4 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting a removal

Bug #1756306 reported by Rutuja on 2018-03-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-qt4 (Ubuntu)
Undecided
Unassigned

Bug Description

sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libgstreamer-plugins-base0.10-0 libgstreamer0.10-0
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
6 not fully installed or removed.
Need to get 0 B/6,900 B of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: error processing package libxcb-shape0-dev:amd64 (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of libxcb-xfixes0-dev:amd64:
 libxcb-xfixes0-dev:amd64 depends on libxcb-shape0-dev; however:
  Package libxcb-shape0-dev:amd64 is not configured yet.

No apport report written because the error message indicates its a followup error from a previous failure.
                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                    dpkg: error processing package libxcb-xfixes0-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxcb-present-dev:amd64:
 libxcb-present-dev:amd64 depends on libxcb-xfixes0-dev; however:
  Package libxcb-xfixes0-dev:amd64 is not configured yet.

dpkg: error processing package libxcb-present-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-mesa-dev:amd64:
 libgl1-mesa-dev:amd64 depends on libxcb-present-dev; however:
  Package libxcb-present-dev:amd64 is not configured yet.

dpkg: error processing package libgl1-mesa-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libglu1-mesa-dev:amd64:
 libglu1-mesa-dev:amd64 depends on libgl1-mesa-dev | libgl-dev; however:
  Package libgl1-mesa-dev:amd64 is not configured yet.
  Package libgl-dev is not installed.
  Package libgl1-mesa-devNo apport report written because MaxReports is reached already
       No apport report written because MaxReports is reached already
                                                                     No apport report written because MaxReports is reached already
                                                   :amd64 which provides libgl-dev is not configured yet.

dpkg: error processing package libglu1-mesa-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libqt4-opengl-dev:
 libqt4-opengl-dev depends on libgl1-mesa-dev; however:
  Package libgl1-mesa-dev:amd64 is not configured yet.
 libqt4-opengl-dev depends on libglu1-mesa-dev; however:
  Package libglu1-mesa-dev:amd64 is not configured yet.

dpkg: error processing package libqt4-opengl-dev (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libxcb-shape0-dev:amd64
 libxcb-xfixes0-dev:amd64
 libxcb-present-dev:amd64
 libgl1-mesa-dev:amd64
 libglu1-mesa-dev:amd64
 libqt4-opengl-dev
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: python-qt4 4.11.4+dfsg-1build4
ProcVersionSignature: Ubuntu 4.4.0-116.140-generic 4.4.98
Uname: Linux 4.4.0-116-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.15
Architecture: amd64
Date: Fri Mar 16 13:24:54 2018
DpkgTerminalLog:
 dpkg: error processing package python-qt4 (--remove):
  package is in a very bad inconsistent state; you should
  reinstall it before attempting a removal
ErrorMessage: package is in a very bad inconsistent state; you should reinstall it before attempting a removal
InstallationDate: Installed on 2016-09-05 (556 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.4
 apt 1.2.25
SourcePackage: python-qt4
Title: package python-qt4 4.11.4+dfsg-1build4 failed to install/upgrade: package is in a very bad inconsistent state; you should reinstall it before attempting a removal
UpgradeStatus: No upgrade log present (probably fresh install)

Rutuja (rutuja-dhamale) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers