eric: fail to start

Bug #21673 reported by Debian Bug Importer on 2005-09-14
4
Affects Status Importance Assigned to Milestone
python-qt3 (Debian)
Fix Released
Unknown
python-qt3 (Ubuntu)
High
Unassigned

Bug Description

Automatically imported from Debian bug report #328271 http://bugs.debian.org/328271

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Wed, 14 Sep 2005 17:18:05 +0300
From: Eliyahu Sandler <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: eric: fail to start

Package: eric
Version: 3.7.1+3.7.2-rc2-1
Severity: grave
Justification: renders package unusable

When I start eric I get the following error:
[eli@eli:~]1$ eric
Traceback (most recent call last):
  File "/usr/share/eric/modules/eric3.py", line 15, in ?
      from qt import QTextCodec, SIGNAL, SLOT, qApp
      ImportError: /usr/lib/python2.3/site-packages/qt.so: undefined
      symbol: _ZTI11QMotifStyle

I tried apt-get dist-upgade, but it did not help.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-686
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages eric depends on:
ii bicyclerepair 0.9-3 A refactoring tool for python
ii python 2.3.5-3 An interactive high-level object-o
ii python-qt3 3.15-3 Qt3 bindings for Python (default v
ii python-qtext 3.15-3 Qt extensions for PyQt (default ve

Versions of packages eric recommends:
pn eric-api-files <none> (no description available)
pn python-kde3 <none> (no description available)
pn python-profiler <none> (no description available)
pn python-xml <none> (no description available)

-- no debconf information

Debian Bug Importer (debzilla) wrote :

Message-Id: <email address hidden>
Date: Wed, 14 Sep 2005 14:51:29 -0700
From: Steve Langasek <email address hidden>
To: <email address hidden>
Subject: reassign 328271 to python-qt3, merging 327360 328271

# Automatically generated email from bts, devscripts version 2.9.5
reassign 328271 python-qt3
merge 327360 328271

Debian Bug Importer (debzilla) wrote :

Marking as duplicate based on debbugs merge (327360,328271)

This bug has been marked as a duplicate of bug 21438.

Debian Bug Importer (debzilla) wrote :
Download full text (8.5 KiB)

Message-Id: <email address hidden>
Date: Sat, 17 Sep 2005 09:41:00 -0700
From: Debian Qt/KDE Maintainers <email address hidden>
To: <email address hidden>
Subject: Bug#327360: fixed in qt-x11-free 3:3.3.5-1

Source: qt-x11-free
Source-Version: 3:3.3.5-1

We believe that the bug you reported is fixed in the latest version of
qt-x11-free, which is due to be installed in the Debian FTP archive:

libqt3-compat-headers_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-compat-headers_3.3.5-1_i386.deb
libqt3-headers_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-headers_3.3.5-1_i386.deb
libqt3-i18n_3.3.5-1_all.deb
  to pool/main/q/qt-x11-free/libqt3-i18n_3.3.5-1_all.deb
libqt3-mt-dbg_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-dbg_3.3.5-1_i386.deb
libqt3-mt-dev_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-dev_3.3.5-1_i386.deb
libqt3-mt-ibase_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-ibase_3.3.5-1_i386.deb
libqt3-mt-mysql_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-mysql_3.3.5-1_i386.deb
libqt3-mt-odbc_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-odbc_3.3.5-1_i386.deb
libqt3-mt-psql_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-psql_3.3.5-1_i386.deb
libqt3-mt-sqlite_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt-sqlite_3.3.5-1_i386.deb
libqt3-mt_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/libqt3-mt_3.3.5-1_i386.deb
qt-x11-free_3.3.5-1.diff.gz
  to pool/main/q/qt-x11-free/qt-x11-free_3.3.5-1.diff.gz
qt-x11-free_3.3.5-1.dsc
  to pool/main/q/qt-x11-free/qt-x11-free_3.3.5-1.dsc
qt-x11-free_3.3.5.orig.tar.gz
  to pool/main/q/qt-x11-free/qt-x11-free_3.3.5.orig.tar.gz
qt3-apps-dev_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-apps-dev_3.3.5-1_i386.deb
qt3-assistant_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-assistant_3.3.5-1_i386.deb
qt3-designer_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-designer_3.3.5-1_i386.deb
qt3-dev-tools-compat_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-dev-tools-compat_3.3.5-1_i386.deb
qt3-dev-tools-embedded_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-dev-tools-embedded_3.3.5-1_i386.deb
qt3-dev-tools_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-dev-tools_3.3.5-1_i386.deb
qt3-doc_3.3.5-1_all.deb
  to pool/main/q/qt-x11-free/qt3-doc_3.3.5-1_all.deb
qt3-examples_3.3.5-1_all.deb
  to pool/main/q/qt-x11-free/qt3-examples_3.3.5-1_all.deb
qt3-linguist_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-linguist_3.3.5-1_i386.deb
qt3-qtconfig_3.3.5-1_i386.deb
  to pool/main/q/qt-x11-free/qt3-qtconfig_3.3.5-1_i386.deb

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Debian Qt/KDE Maintainers <email address hidden> (supplier of updated qt-x11-free package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by ma...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.