python3-pip cannot be installed (Xenial)

Bug #1788356 reported by Steffen Seckler on 2018-08-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-pip (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
on Ubuntu 16.04.3 LTS:

sudo apt update && sudo apt install python3-pip

fails with

The following packages have unmet dependencies:
 python3-pip : Depends: python-pip-whl (= 8.1.1-2) but 8.1.1-2ubuntu0.4 is to be installed
               Recommends: python3-dev (>= 3.2) but it is not going to be installed
               Recommends: python3-wheel but it is not going to be installed

this seems to be happening, because the wrong python-pip-whl is specified for python3-pip.

The python-pip package, however, is fine:

sudo apt show python-pip
[...]
Depends: ca-certificates, python-pip-whl (= 8.1.1-2ubuntu0.4), python:any (<< 2.8), python:any (>= 2.7.5-5~)
[...]

so apparently python-pip and python3-pip can currently not be installed together in ubuntu 16.04 (over apt).

fix:
fix dependencies

workaround:
sudo apt install python3-setuptools
sudo easy_install3 pip

Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I am not able to reproduce this issue, as I was able to install both python3-pip and python-pip on my Ubuntu 16.04 system. Based on the error message (and that you have python-pip already installed) it seems to be some mismatch in the packages it suggests when you attempt to install python3-pip.

Good call on running `sudo apt update` first, that normally sorts out mismatch issues. Could you please re-run that, and possibly install any missing updates. If the problem persists, I would be interested in the output of `apt policy python3-pip python-pip-whl` to see which package versions it will attempt to find and install.

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in python-pip (Ubuntu):
status: New → Incomplete
tags: added: unmetdeps xenial
Steffen Seckler (grb19) wrote :

Hmm, I also am not able to reproduce this problem on other xenial systems.
Seems like the package lists were somehow broken.

I suppose xenial-updates was once activated and at some point was deactivated again. That would definitely explain the error.

-> can be closed

Changed in python-pip (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers