No module named 'pip._vendor.requests

Bug #1768351 reported by Sergio Schvezov on 2018-05-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-pip (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu@test-snapcraft-bionic:~/t$ sudo apt autoremove --purge python3.6-minimal
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  python3.6* python3.6-minimal*
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 9593 kB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 29870 files and directories currently installed.)
Removing python3.6 (3.6.5-3) ...
dpkg: warning: while removing python3.6, directory '/usr/lib/python3/dist-packages' not empty so not removed
Removing python3.6-minimal (3.6.5-3) ...
Unlinking and removing bytecode for runtime python3.6
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for man-db (2.8.3-2) ...
(Reading database ... 29839 files and directories currently installed.)
Purging configuration files for python3.6-minimal (3.6.5-3) ...
ubuntu@test-snapcraft-bionic:~/t$ sudo apt install --no-install-recommends python3-pip
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  python-pip-whl python3 python3-distutils python3-lib2to3 python3-minimal python3.6
  python3.6-minimal
Suggested packages:
  python3-doc python3-tk python3-venv python3.6-venv python3.6-doc binfmt-support
Recommended packages:
  python3-dev python3-setuptools python3-wheel
The following NEW packages will be installed:
  python-pip-whl python3 python3-distutils python3-lib2to3 python3-minimal python3-pip
  python3.6 python3.6-minimal
0 upgraded, 8 newly installed, 0 to remove and 0 not upgraded.
Need to get 1862 kB/3425 kB of archives.
After this operation, 14.2 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 python3.6-minimal amd64 3.6.5-3 [1425 kB]
Get:2 http://archive.ubuntu.com/ubuntu bionic/main amd64 python3-minimal amd64 3.6.5-3 [23.8 kB]
Get:3 http://archive.ubuntu.com/ubuntu bionic/main amd64 python3.6 amd64 3.6.5-3 [186 kB]
Get:4 http://archive.ubuntu.com/ubuntu bionic/main amd64 python3 amd64 3.6.5-3 [10.2 kB]
Get:5 http://archive.ubuntu.com/ubuntu bionic/main amd64 python3-lib2to3 all 3.6.5-3 [76.6 kB]
Get:6 http://archive.ubuntu.com/ubuntu bionic/main amd64 python3-distutils all 3.6.5-3 [141 kB]
Fetched 1862 kB in 0s (3920 kB/s)
Selecting previously unselected package python3.6-minimal.
(Reading database ... 29839 files and directories currently installed.)
Preparing to unpack .../python3.6-minimal_3.6.5-3_amd64.deb ...
Unpacking python3.6-minimal (3.6.5-3) ...
Selecting previously unselected package python3-minimal.
Preparing to unpack .../python3-minimal_3.6.5-3_amd64.deb ...
Unpacking python3-minimal (3.6.5-3) ...
Selecting previously unselected package python3.6.
Preparing to unpack .../python3.6_3.6.5-3_amd64.deb ...
Unpacking python3.6 (3.6.5-3) ...
Setting up python3.6-minimal (3.6.5-3) ...
Setting up python3-minimal (3.6.5-3) ...
Selecting previously unselected package python3.
(Reading database ... 29893 files and directories currently installed.)
Preparing to unpack .../python3_3.6.5-3_amd64.deb ...
Unpacking python3 (3.6.5-3) ...
Selecting previously unselected package python-pip-whl.
Preparing to unpack .../python-pip-whl_9.0.1-2.1_all.deb ...
Unpacking python-pip-whl (9.0.1-2.1) ...
Selecting previously unselected package python3-lib2to3.
Preparing to unpack .../python3-lib2to3_3.6.5-3_all.deb ...
Unpacking python3-lib2to3 (3.6.5-3) ...
Selecting previously unselected package python3-distutils.
Preparing to unpack .../python3-distutils_3.6.5-3_all.deb ...
Unpacking python3-distutils (3.6.5-3) ...
Selecting previously unselected package python3-pip.
Preparing to unpack .../python3-pip_9.0.1-2.1_all.deb ...
Unpacking python3-pip (9.0.1-2.1) ...
Setting up python-pip-whl (9.0.1-2.1) ...
Setting up python3.6 (3.6.5-3) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Setting up python3 (3.6.5-3) ...
running python rtupdate hooks for python3.6...
running python post-rtupdate hooks for python3.6...
Processing triggers for man-db (2.8.3-2) ...
Setting up python3-lib2to3 (3.6.5-3) ...
Setting up python3-distutils (3.6.5-3) ...
Setting up python3-pip (9.0.1-2.1) ...
ubuntu@test-snapcraft-bionic:~/t$ python3 -m pip
Traceback (most recent call last):
  File "/usr/lib/python3.6/runpy.py", line 183, in _run_module_as_main
    mod_name, mod_spec, code = _get_module_details(mod_name, _Error)
  File "/usr/lib/python3.6/runpy.py", line 142, in _get_module_details
    return _get_module_details(pkg_main_name, error)
  File "/usr/lib/python3.6/runpy.py", line 109, in _get_module_details
    __import__(pkg_name)
  File "/usr/lib/python3/dist-packages/pip/__init__.py", line 21, in <module>
    from pip._vendor.requests.packages.urllib3.exceptions import DependencyWarning
ModuleNotFoundError: No module named 'pip._vendor.requests'

Installing python3-requests worksaround the problem.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: python3-pip 9.0.1-2
ProcVersionSignature: Ubuntu 4.15.0-16.17+surface-generic 4.15.17
Uname: Linux 4.15.0-16-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue May 1 22:56:30 2018
InstallationDate: Installed on 2018-04-09 (22 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Beta amd64 (20180404)
PackageArchitecture: all
SourcePackage: python-pip
UpgradeStatus: No upgrade log present (probably fresh install)

Sergio Schvezov (sergiusens) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-pip (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers