requests Testsuite: autopkgtest-pkg-python but module includes '.' and no import_name set

Bug #1912792 reported by Dan Streetman
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-oslo.versionedobjects (Ubuntu)
Undecided
Unassigned
Bionic
Medium
Corey Bryant
python-oslo.vmware (Ubuntu)
Undecided
Unassigned
Bionic
Medium
Unassigned

Bug Description

[impact]

the (trivial) autopkgtest for this package always fails, since some change in upstream autodep8, dctrl-tools, or autopkgtest code that has changed the import module name used.

The problem is the autodep8-generated test used to correctly calculate the module name to import as "oslo_versionedobjects", but now incorrectly calculates it as "oslo.versionedobjects". This is likely due to the autodep8 test generation script changing all '-' chars to '_', but not '.' to '_'. With python2, this package created a (dummy) binary package named python-oslo-versionedobjects, while with python3 it provides only python3-oslo.versionedobjects.

[test case]

check the autopkgtests, e.g.:
https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-bionic/bionic/amd64/p/python-oslo.versionedobjects/20210113_184523_626c0@/log.gz

[regression potential]

any regression would almost certainly be limited to failing to run the autodep8 test, or an incorrect pass or incorrect fail of the autodep8 test.

[scope]

This was detected and fixed starting in cosmic with this version:
http://launchpadlibrarian.net/375048921/python-oslo.versionedobjects_1.33.1-0ubuntu1_1.33.1-0ubuntu2.diff.gz

This fix was not backported to bionic or earlier.

[other info]

as this is a trivial autopkgtest fix, I'll add block-proposed-bionic, and really this bug probably doesn't even need a fix uploaded, as this package's tests haven't been run for bionic in 2 years, so it should be enough to just point to this bug as explanation for why to ignore this package's failing autopkgtests on bionic.

I specifically opened this bug due to reverse-depends autopkgtest failure of this package in bionic, as a result of updating python-oslo.messaging package for bug 1789177.

Dan Streetman (ddstreet)
Changed in python-oslo.versionedobjects (Ubuntu):
status: New → Fix Released
description: updated
Mathew Hodson (mhodson)
tags: added: testcase
Changed in python-oslo.versionedobjects (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Triaged
assignee: nobody → Corey Bryant (corey.bryant)
Revision history for this message
Corey Bryant (corey.bryant) wrote :

I've uploaded a new version of python-oslo.versionedobjects with autopkgtest enhancements/fixes to the bionic unapproved

Revision history for this message
Corey Bryant (corey.bryant) wrote :
Revision history for this message
Dan Streetman (ddstreet) wrote :

I added block-proposed-bionic tag since this is test fix only, however @corey.bryant or any sru reviewer feel free to remove it if you think it's appropriate to release to -updates.

tags: added: block-proposed-bionic
Revision history for this message
Dan Streetman (ddstreet) wrote :
Revision history for this message
Dan Streetman (ddstreet) wrote :

with python-oslo.vmware, it appears to have been also fixed in cosmic but not backported:
https://launchpad.net/ubuntu/+source/python-oslo.vmware/2.29.2-0ubuntu2

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Dan, or anyone else affected,

Accepted python-oslo.versionedobjects into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-oslo.versionedobjects/1.31.2-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python-oslo.versionedobjects (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Revision history for this message
Corey Bryant (corey.bryant) wrote :

I've uploaded a patched python-oslo.vmware to the bionic unapproved queue for this bug.

Changed in python-oslo.vmware (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in python-oslo.vmware (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Triaged
Changed in python-oslo.vmware (Ubuntu):
status: Triaged → Fix Released
importance: Medium → Undecided
Revision history for this message
Robie Basak (racb) wrote :

Hello Dan, or anyone else affected,

Accepted python-oslo.vmware into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-oslo.vmware/2.26.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python-oslo.vmware (Ubuntu Bionic):
status: Triaged → Fix Committed
Revision history for this message
Dan Streetman (ddstreet) wrote :
tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers