Can't run tests in liberty cloudarchive environment

Bug #1535134 reported by Sam Morrison on 2016-01-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-openstack-compute (Ubuntu)
Undecided
Unassigned

Bug Description

Trying to run tox for my liberty branch inside a ubuntu liberty environment and get the following error: (pip version is too old I think)

Traceback (most recent call last):
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/local/lib/python2.7/site-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/local/lib/python2.7/site-packages/pip/commands/install.py", line 262, in run
    for req in parse_requirements(filename, finder=finder, options=options, session=session):
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/local/lib/python2.7/site-packages/pip/req.py", line 1632, in parse_requirements
    req = InstallRequirement.from_line(line, comes_from, prereleases=getattr(options, "pre", None))
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/local/lib/python2.7/site-packages/pip/req.py", line 173, in from_line
    return cls(req, comes_from, url=url, prereleases=prereleases)
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/local/lib/python2.7/site-packages/pip/req.py", line 71, in __init__
    req = pkg_resources.Requirement.parse(req)
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/lib/python-wheels/setuptools-18.4-py2.py3-none-any.whl/pkg_resources/__init__.py", line 2986, in parse
    req, = parse_requirements(s)
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/lib/python-wheels/setuptools-18.4-py2.py3-none-any.whl/pkg_resources/__init__.py", line 2930, in parse_requirements
    "version spec")
  File "/jenkins/workspace/nova-python-tox-py27/.tox/py27/lib/python-wheels/setuptools-18.4-py2.py3-none-any.whl/pkg_resources/__init__.py", line 2906, in scan_list
    raise RequirementParseError(msg, line, "at", line[p:])
RequirementParseError: Expected ',' or end-of-list in Routes!=2.0,!=2.1,>=1.12.3;python_version=='2.7' at ;python_version=='2.7'

Storing debug log for failure in /jenkins/.pip/pip.log

ERROR: could not install deps [-r/jenkins/workspace/nova-python-tox-py27/requirements.txt, -r/jenkins/workspace/nova-python-tox-py27/test-requirements.txt]; v = InvocationError('/jenkins/workspace/nova-python-tox-py27/.tox/py27/bin/pip install -U --force-reinstall -r/jenkins/workspace/nova-python-tox-py27/requirements.txt -r/jenkins/workspace/nova-python-tox-py27/test-requirements.txt (see /jenkins/workspace/nova-python-tox-py27/.tox/py27/log/py27-1.log)', 2)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-openstack-compute (Ubuntu):
status: New → Confirmed

Had the same problem trying to run the neutron test suite on Ubuntu 15.10. A new pip version fixed it for me.

Ubuntu ships with pip 1.5.6. But according to the pip docs, you need at least version 6 to parse one of the openstack requirements.txt
https://pip.pypa.io/en/stable/reference/pip_install/#requirement-specifiers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers